Bug 211988 - dolphin crashed while copying files
Summary: dolphin crashed while copying files
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-26 21:53 UTC by Yannis Tsopokis
Modified: 2009-11-04 16:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yannis Tsopokis 2009-10-26 21:53:32 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic-pae i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
While copying a file from disk to usb and started a second copy, dolphin constantly refreshed the target folder until it crashed.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0xb6004829 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0xb6c23d89 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0xb759928e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0xb758875f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0xb7462a36 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0xb74666bd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0xb7466902 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0xb74679a6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0xb6066263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0xb6066ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0xb60a0667 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0xb606b9ae in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0xb60603bf in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb6265f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb626d67c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb6f6fbfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb60506cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb607d7ce in ?? () from /usr/lib/libQtCore.so.4
#24 0xb607b0e0 in ?? () from /usr/lib/libQtCore.so.4
#25 0xb565ee78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0xb5662720 in ?? () from /lib/libglib-2.0.so.0
#27 0xb5662853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0xb607b02c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0xb6306be5 in ?? () from /usr/lib/libQtGui.so.4
#30 0xb604ec79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0xb604f0ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0xb605153f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0xb6265dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2009-10-26 23:57:41 UTC
Thanks for the bug report! This looks just like bug 200125, but that one should actually be fixed in KDE 4.3.2...
Comment 2 Yannis Tsopokis 2009-10-27 08:14:28 UTC
In my case I had 2 instances of dolphin running and I copied a large file from the first instance to the second. Then, I changed path in the first window and copied another large file to the second window (same path as before). After that dolphin crashed (it seemed as it tried to refresh the target folder too many times per second).
Comment 3 Dario Andres 2009-10-28 17:43:59 UTC
I wonder if this could be merged with bug 211525...
Comment 4 Dario Andres 2009-11-04 16:11:42 UTC
Merging with bug 211525. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***