Bug 211586 - KDE NetworkManager doesn't connect wiifi on start up very often
Summary: KDE NetworkManager doesn't connect wiifi on start up very often
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-23 22:03 UTC by zefiro75
Modified: 2009-11-17 18:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zefiro75 2009-10-23 22:03:12 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-11-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
KDE NetworkManager doesn't connect as usually, I try this on tty1:

$ sudo service network-manager restart

Then it crashed.

Info:
Linux 2.6.31-11-generic #38-Ubuntu SMP Fri Oct 2 11:55:55 UTC 2009 i686 GNU/Linux
Qt: 4.5.2
KDE: 4.3.2 (KDE 4.3.2)

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0x00612527 in QMetaObject::cast(QObject*) const () from /usr/lib/libQtCore.so.4
#7  0x00166b2c in NMDBusActiveConnectionMonitor::activeConnectionListChanged() () from /usr/lib/libknm_nm.so
#8  0x0013257d in NMDBusActiveConnectionMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknm_nm.so
#9  0x00623263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#10 0x00623ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#11 0x004b3777 in Solid::Control::NetworkManager::Notifier::activeConnectionsChanged() () from /usr/lib/libsolidcontrol.so.4
#12 0x004b3973 in Solid::Control::NetworkManager::Notifier::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libsolidcontrol.so.4
#13 0x004b439a in ?? () from /usr/lib/libsolidcontrol.so.4
#14 0x00623263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0x00623ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0x0935e007 in NMNetworkManager::activeConnectionsChanged() () from /usr/lib/kde4/solid_networkmanager07.so
#17 0x09361c73 in NMNetworkManager::propertiesChanged(QMap<QString, QVariant> const&) () from /usr/lib/kde4/solid_networkmanager07.so
#18 0x09362765 in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#19 0x00623263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#20 0x00623ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#21 0x0936edb3 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#22 0x0936f775 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#23 0x001987b4 in ?? () from /usr/lib/libQtDBus.so.4
#24 0x001a0197 in ?? () from /usr/lib/libQtDBus.so.4
#25 0x0061d5fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#26 0x010fef54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0x0110667c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#28 0x00adbbfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#29 0x0060d6cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#30 0x0060e2b2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#31 0x0060e47d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#32 0x006383ff in ?? () from /usr/lib/libQtCore.so.4
#33 0x0919de78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#34 0x091a1720 in ?? () from /lib/libglib-2.0.so.0
#35 0x091a1853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#36 0x0063802c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#37 0x0119fbe5 in ?? () from /usr/lib/libQtGui.so.4
#38 0x0060bc79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0x0060c0ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#40 0x0060e53f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#41 0x010fedd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#42 0x08052925 in _start ()

Reported using DrKonqi
Comment 1 Will Stephenson 2009-11-17 18:32:43 UTC

*** This bug has been marked as a duplicate of bug 210878 ***