Bug 211537 - Kile crash when reloading a file which has been modified externally
Summary: Kile crash when reloading a file which has been modified externally
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-23 14:06 UTC by jguilhemsang
Modified: 2009-10-23 14:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jguilhemsang 2009-10-23 14:06:45 UTC
Application that crashed: kile
Version of the application: 2.0.81
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic x86_64
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
Kile crash when reloading a file which has been modified externally.
I use aspell to spell check my file, so kile detects the modification and crash when reloading the file. This happen randomly.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x2f45dd0, pos=@0x7fffc510b990, internal=true) at /build/buildd/kde4libs-4.3.2/kate/smart/katesmartcursor.cpp:186
#6  0x00007ff3b05dc560 in KateSmartCursor::translate (this=0x2f45dd0, edit=@0x36e77c0) at /build/buildd/kde4libs-4.3.2/kate/smart/katesmartcursor.cpp:305
#7  0x00007ff3b05e1d74 in KateSmartGroup::translateChanged (this=0x214a860, edit=@0x36e77c0) at /build/buildd/kde4libs-4.3.2/kate/smart/katesmartmanager.cpp:464
#8  0x00007ff3b05e55bb in KateSmartManager::slotTextChanged (this=0x1e78eb0, edit=0x36e77c0) at /build/buildd/kde4libs-4.3.2/kate/smart/katesmartmanager.cpp:368
#9  0x00007ff3b05e597f in KateSmartManager::qt_metacall (this=0x1e78eb0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fffc510bc10)
    at /build/buildd/kde4libs-4.3.2/obj-x86_64-linux-gnu/kate/katesmartmanager.moc:74
#10 0x00007ff3b8e3bea2 in QMetaObject::activate (sender=0x1e79820, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#11 0x00007ff3b05b779f in KateEditHistory::editDone (this=0x7fffc510b990, _t1=0x36e77c0) at /build/buildd/kde4libs-4.3.2/obj-x86_64-linux-gnu/kate/kateedit.moc:78
#12 0x00007ff3b0590f1f in KateDocument::closeUrl (this=0x2c6b350) at /build/buildd/kde4libs-4.3.2/kate/document/katedocument.cpp:3606
#13 0x00007ff3bbc81bc7 in KParts::ReadOnlyPart::openUrl (this=0x2c6b350, url=@0x7fffc510c1d0) at /build/buildd/kde4libs-4.3.2/kparts/part.cpp:537
#14 0x00007ff3b0591b7c in KateDocument::documentReload (this=0x2c6b350) at /build/buildd/kde4libs-4.3.2/kate/document/katedocument.cpp:5066
#15 0x00007ff3b0593e12 in KateDocument::slotModifiedOnDisk (this=0x2c6b350) at /build/buildd/kde4libs-4.3.2/kate/document/katedocument.cpp:4970
#16 0x00007ff3b0593637 in KateDocument::qt_metacall (this=0x2c6b350, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc510c730)
    at /build/buildd/kde4libs-4.3.2/obj-x86_64-linux-gnu/kate/katedocument.moc:312
#17 0x00007ff3b8e3bea2 in QMetaObject::activate (sender=0x2f83fe0, from_signal_index=<value optimized out>, to_signal_index=27, argv=0x0) at kernel/qobject.cpp:3113
#18 0x00007ff3bbec6c5f in KTextEditor::View::focusIn (this=0x7fffc510b990, _t1=0x2f83fe0) at /build/buildd/kde4libs-4.3.2/obj-x86_64-linux-gnu/interfaces/ktexteditor/view.moc:119
#19 0x00007ff3b061634a in KateView::slotGotFocus (this=0x2f83fe0) at /build/buildd/kde4libs-4.3.2/kate/view/kateview.cpp:1000
#20 0x00007ff3b99f949c in QWidget::event (this=0x2f79f70, event=0x7fffc510cd70) at kernel/qwidget.cpp:7647
#21 0x00007ff3b99a7f4d in QApplicationPrivate::notify_helper (this=0x1686680, receiver=0x2f79f70, e=0x7fffc510cd70) at kernel/qapplication.cpp:4056
#22 0x00007ff3b99b018a in QApplication::notify (this=0x7fffc510ebf0, receiver=0x2f79f70, e=0x7fffc510cd70) at kernel/qapplication.cpp:4021
#23 0x00007ff3ba846abb in KApplication::notify (this=0x7fffc510ebf0, receiver=0x2f79f70, event=0x7fffc510cd70) at /build/buildd/kde4libs-4.3.2/kdeui/kernel/kapplication.cpp:302
#24 0x00007ff3b8e266ac in QCoreApplication::notifyInternal (this=0x7fffc510ebf0, receiver=0x2f79f70, event=0x7fffc510cd70) at kernel/qcoreapplication.cpp:610
#25 0x00007ff3b99ae887 in QApplicationPrivate::setFocusWidget (focus=0x1a530b0, reason=Qt::ActiveWindowFocusReason) at kernel/qapplication.cpp:2097
#26 0x00007ff3b99f3135 in QWidget::setFocus (this=0x2f79f70, reason=Qt::ActiveWindowFocusReason) at kernel/qwidget.cpp:5747
#27 0x00007ff3b99aee62 in QApplication::setActiveWindow (act=<value optimized out>) at kernel/qapplication.cpp:2438
#28 0x00007ff3b9a185c0 in QApplication::x11ProcessEvent (this=0x7fffc510ebf0, event=0x7fffc510e7e0) at kernel/qapplication_x11.cpp:3469
#29 0x00007ff3b9a41454 in x11EventSourceDispatch (s=0x168a340, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x00007ff3b448820a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0x00007ff3b448b8e0 in ?? () from /usr/lib/libglib-2.0.so.0
#32 0x00007ff3b448ba7c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0x00007ff3b8e4fa8f in QEventDispatcherGlib::processEvents (this=0x165ff40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#34 0x00007ff3b9a40bdf in QGuiEventDispatcherGlib::processEvents (this=0x7fffc510b990, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00007ff3b8e24f42 in QEventLoop::processEvents (this=<value optimized out>, flags={i = -988747056}) at kernel/qeventloop.cpp:149
#36 0x00007ff3b8e25314 in QEventLoop::exec (this=0x7fffc510eb10, flags={i = -988746976}) at kernel/qeventloop.cpp:201
#37 0x00007ff3b8e275e4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x0000000000595a85 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-23 14:46:01 UTC
Merging with bug 200450 (kate bug). Thanks

*** This bug has been marked as a duplicate of bug 200450 ***