Bug 211484 - Kile crashed as clicked an open file's tab
Summary: Kile crashed as clicked an open file's tab
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-22 23:14 UTC by Wolfgang Mader
Modified: 2009-10-22 23:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Mader 2009-10-22 23:14:12 UTC
Application that crashed: kile
Version of the application: 2.0.83
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux 2.6.30-2-686 i686

What I was doing when the application crashed:
I had a couples of files opend from a project. As I wanted to select one of those open files by clicking on it's tab, Kile crashed.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#6  0xb3d6519f in KateSmartCursor::setPositionInternal (this=0x9cb8ee0, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#7  0xb3d65588 in KateSmartCursor::translate (this=0x9cb8ee0, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#8  0xb3d6ac41 in KateSmartGroup::translateChanged (this=0x9ced4d8, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#9  0xb3d6e507 in KateSmartManager::slotTextChanged (this=0xa0ed758, edit=0xa488250) at ../../kate/smart/katesmartmanager.cpp:368
#10 0xb3d6e8b4 in KateSmartManager::qt_metacall (this=0xa0ed758, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf9581dc) at ./katesmartmanager.moc:74
#11 0xb6b6e303 in QMetaObject::activate (sender=0x9ffb968, from_signal_index=4, to_signal_index=4, argv=0xbf9581dc) at kernel/qobject.cpp:3112
#12 0xb6b6ef42 in QMetaObject::activate (sender=0x9ffb968, m=0xb3e73cc4, local_signal_index=0, argv=0xbf9581dc) at kernel/qobject.cpp:3186
#13 0xb3d3d383 in KateEditHistory::editDone (this=0x9ffb968, _t1=0xa488250) at ./kateedit.moc:78
#14 0xb3d14f53 in KateDocument::closeUrl (this=0x9ec3968) at ../../kate/document/katedocument.cpp:3606
#15 0x082cf310 in _start ()

Reported using DrKonqi
Comment 1 Wolfgang Mader 2009-10-22 23:21:28 UTC
I have been blown away form the now bug report tool, so I have forgotten to mention a possibly important detail. If I recall right, I have not hit the tab, I hit the close button embebed in the tab.
Comment 2 Dario Andres 2009-10-22 23:32:31 UTC
This is a Kate bug: bug 200450
Thanks

*** This bug has been marked as a duplicate of bug 200450 ***