Bug 211471 - I pressed F5 and kile crush
Summary: I pressed F5 and kile crush
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-22 20:47 UTC by Sebastian Souyris
Modified: 2009-10-22 23:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Souyris 2009-10-22 20:47:49 UTC
Application that crashed: kile
Version of the application: 2.0.83
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu karmic (development branch)

What I was doing when the application crashed:
Working in a document, I pressed F5 to compile pdflatex (instead F6 that I have configurated to do it) and it crush.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x280c650, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#6  0x00007f076a9780cf in KateSmartCursor::translate (this=0x280c650, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#7  0x00007f076a97d35c in KateSmartGroup::translateChanged (this=0x2b845a0, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#8  0x00007f076a980a9b in KateSmartManager::slotTextChanged (this=0x2ce13c0, edit=0x3113a10) at ../../kate/smart/katesmartmanager.cpp:368
#9  0x00007f076a980e1c in KateSmartManager::qt_metacall (this=0x2ce13c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2ea0b080) at ./katesmartmanager.moc:74
#10 0x00007f077906addc in QMetaObject::activate (sender=0x1e4d320, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x280c650) at kernel/qobject.cpp:3113
#11 0x00007f076a952b5f in KateEditHistory::editDone (this=0x7fff2ea0ade0, _t1=0x3113a10) at ./kateedit.moc:78
#12 0x00007f076a92bb7b in KateDocument::closeUrl (this=0x2b84380) at ../../kate/document/katedocument.cpp:3606
#13 0x00007f077bebefcf in KParts::ReadOnlyPart::openUrl (this=0x2b84380, url=...) at ../../kparts/part.cpp:537
#14 0x00007f076a92c761 in KateDocument::documentReload (this=0x2b84380) at ../../kate/document/katedocument.cpp:5066
#15 0x00007f076a9b356d in KateView::qt_metacall (this=0x2c89e30, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2ea0b980) at ./kateview.moc:415
#16 0x00007f077906addc in QMetaObject::activate (sender=0x231efb0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x280c650) at kernel/qobject.cpp:3113
#17 0x00007f0779be10a7 in QAction::triggered (this=0x7fff2ea0ade0, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
#18 0x00007f0779be24ef in QAction::activate (this=0x231efb0, event=<value optimized out>) at kernel/qaction.cpp:1160
#19 0x00007f0779be4fa7 in QAction::event (this=0x7fff2ea0ade0, e=<value optimized out>) at kernel/qaction.cpp:1079
#20 0x00007f077a9a417d in KAction::event (this=0x7fff2ea0ade0, event=0x7fff2ea0be80) at ../../kdeui/actions/kaction.cpp:88
#21 0x00007f0779be6efc in QApplicationPrivate::notify_helper (this=0x1145a80, receiver=0x231efb0, e=0x7fff2ea0be80) at kernel/qapplication.cpp:4056
#22 0x00007f0779bee1ce in QApplication::notify (this=0x7fff2ea0e4d0, receiver=0x231efb0, e=0x7fff2ea0be80) at kernel/qapplication.cpp:4021
#23 0x00007f077aa75ab6 in KApplication::notify (this=0x7fff2ea0e4d0, receiver=0x231efb0, event=0x7fff2ea0be80) at ../../kdeui/kernel/kapplication.cpp:302
#24 0x00007f0779055c2c in QCoreApplication::notifyInternal (this=0x7fff2ea0e4d0, receiver=0x231efb0, event=0x7fff2ea0be80) at kernel/qcoreapplication.cpp:610
#25 0x00007f0779c1b666 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fff2ea0c310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#26 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fff2ea0c310) at kernel/qshortcutmap.cpp:884
#27 0x00007f0779c1d4f7 in QShortcutMap::tryShortcutEvent (this=0x1145b98, o=<value optimized out>, e=0x7fff2ea0c310) at kernel/qshortcutmap.cpp:369
#28 0x00007f0779beee6e in QApplication::notify (this=0x7fff2ea0e4d0, receiver=0x2b5a360, e=0x7fff2ea0c310) at kernel/qapplication.cpp:3645
#29 0x00007f077aa75ab6 in KApplication::notify (this=0x7fff2ea0e4d0, receiver=0x2b5a360, event=0x7fff2ea0c310) at ../../kdeui/kernel/kapplication.cpp:302
#30 0x00007f0779055c2c in QCoreApplication::notifyInternal (this=0x7fff2ea0e4d0, receiver=0x2b5a360, event=0x7fff2ea0c310) at kernel/qcoreapplication.cpp:610
#31 0x00007f0779c77dfa in QKeyMapper::sendKeyEvent (keyWidget=0x2b5a360, grab=<value optimized out>, type=QEvent::KeyPress, code=16777268, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=71, nativeVirtualKey=65474, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#32 0x00007f0779c7a370 in QKeyMapperPrivate::translateKeyEvent (this=0x1180510, keyWidget=0x2b5a360, event=<value optimized out>, grab=false) at kernel/qkeymapper_x11.cpp:1831
#33 0x00007f0779c52493 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff2ea0e0f0) at kernel/qapplication_x11.cpp:3443
#34 0x00007f0779c7bd0c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007f07752f6bbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x00007f07752fa588 in ?? () from /lib/libglib-2.0.so.0
#37 0x00007f07752fa6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x00007f077907e1a6 in QEventDispatcherGlib::processEvents (this=0x111f110, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#39 0x00007f0779c7b4be in QGuiEventDispatcherGlib::processEvents (this=0x7fff2ea0ade0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#40 0x00007f0779054532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00007f0779054904 in QEventLoop::exec (this=0x7fff2ea0e420, flags=) at kernel/qeventloop.cpp:201
#42 0x00007f0779056ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#43 0x00000000005e6872 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-22 23:34:55 UTC
Kate bug , merging with bug 200450.
Thanks

*** This bug has been marked as a duplicate of bug 200450 ***