Bug 211384 - kate crash while file edition
Summary: kate crash while file edition
Status: RESOLVED DUPLICATE of bug 200858
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-21 23:38 UTC by Mariusz Pluciński
Modified: 2009-10-22 15:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mariusz Pluciński 2009-10-21 23:38:26 UTC
Application that crashed: kate
Version of the application: 3.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.31custom1 x86_64
Distribution: "Fedora release 11 (Leonidas)"

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=<value optimized out>) at /usr/src/debug/kdelibs-4.3.1/kate/render/katelinelayout.cpp:173
#6  KateLineLayout::viewLine (this=<value optimized out>) at /usr/src/debug/kdelibs-4.3.1/kate/render/katelinelayout.cpp:179
#7  0x00007f0c70fd830e in KateLayoutCache::textLayout (this=<value optimized out>, realLine=5241, _viewLine=-1) at /usr/src/debug/kdelibs-4.3.1/kate/render/katelayoutcache.cpp:346
#8  0x00007f0c71025740 in KateViewInternal::previousLayout (this=0x188b760) at /usr/src/debug/kdelibs-4.3.1/kate/view/kateviewinternal.cpp:1282
#9  0x00007f0c7102d6ef in KateViewInternal::cursorUp (this=0x188b760, sel=false) at /usr/src/debug/kdelibs-4.3.1/kate/view/kateviewinternal.cpp:1462
#10 0x00007f0c71017dfd in KateView::qt_metacall (this=0x17db9c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd1f45670)
    at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kate/kateview.moc:371
#11 0x00000038933547dc in QMetaObject::activate (sender=0x19c5230, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3113
#12 0x0000003895389857 in QAction::triggered (this=0x7fffd1f45480, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
#13 0x000000389538acbf in QAction::activate (this=0x19c5230, event=<value optimized out>) at kernel/qaction.cpp:1160
#14 0x000000389538d747 in QAction::event (this=0x7fffd1f45480, e=<value optimized out>) at kernel/qaction.cpp:1079
#15 0x000000354114010d in KAction::event (this=0x7fffd1f45480, event=0x7fffd1f45b70) at /usr/src/debug/kdelibs-4.3.1/kdeui/actions/kaction.cpp:88
#16 0x000000389538f69c in QApplicationPrivate::notify_helper (this=0x11a5ca0, receiver=0x19c5230, e=0x7fffd1f45b70) at kernel/qapplication.cpp:4056
#17 0x00000038953968fe in QApplication::notify (this=0x7fffd1f48210, receiver=0x19c5230, e=0x7fffd1f45b70) at kernel/qapplication.cpp:4021
#18 0x0000003541211b56 in KApplication::notify (this=0x7fffd1f48210, receiver=0x19c5230, event=0x7fffd1f45b70) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#19 0x000000389333f59c in QCoreApplication::notifyInternal (this=0x7fffd1f48210, receiver=0x19c5230, event=0x7fffd1f45b70) at kernel/qcoreapplication.cpp:610
#20 0x00000038953c3cb6 in QCoreApplication::sendEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:213
#21 QShortcutMap::dispatchEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qshortcutmap.cpp:884
#22 0x00000038953c5b27 in QShortcutMap::tryShortcutEvent (this=0x11a5db8, o=<value optimized out>, e=0x7fffd1f46000) at kernel/qshortcutmap.cpp:369
#23 0x0000003895397596 in QApplication::notify (this=0x7fffd1f48210, receiver=0x188b760, e=0x7fffd1f46000) at kernel/qapplication.cpp:3645
#24 0x0000003541211b56 in KApplication::notify (this=0x7fffd1f48210, receiver=0x188b760, event=0x7fffd1f46000) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#25 0x000000389333f59c in QCoreApplication::notifyInternal (this=0x7fffd1f48210, receiver=0x188b760, event=0x7fffd1f46000) at kernel/qcoreapplication.cpp:610
#26 0x000000389541e8ba in QKeyMapper::sendKeyEvent (keyWidget=0x188b760, grab=<value optimized out>, type=QEvent::KeyPress, code=16777235, modifiers=<value optimized out>, text=@0x7fffd1f46220, 
    autorepeat=false, count=1, nativeScanCode=111, nativeVirtualKey=65362, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#27 0x0000003895420e50 in QKeyMapperPrivate::translateKeyEvent (this=0x11dd100, keyWidget=0x188b760, event=<value optimized out>, grab=false) at kernel/qkeymapper_x11.cpp:1831
#28 0x00000038953fa4e4 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffd1f47de0) at kernel/qapplication_x11.cpp:3438
#29 0x00000038954227dc in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x000000389223790e in g_main_dispatch (context=<value optimized out>) at gmain.c:1824
#31 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2377
#32 0x000000389223b0e8 in g_main_context_iterate (context=0x11a7e20, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2455
#33 0x000000389223b20a in IA__g_main_context_iteration (context=0x11a7e20, may_block=1) at gmain.c:2518
#34 0x0000003893367936 in QEventDispatcherGlib::processEvents (this=0x11891b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#35 0x0000003895421f8e in QGuiEventDispatcherGlib::processEvents (this=0x7fffd1f45480, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#36 0x000000389333ded2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 36}) at kernel/qeventloop.cpp:149
#37 0x000000389333e2a4 in QEventLoop::exec (this=0x7fffd1f48110, flags={i = 0}) at kernel/qeventloop.cpp:201
#38 0x0000003893340439 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#39 0x0000003541804aed in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdesdk-4.3.1/kate/app/katemain.cpp:257
#40 0x0000003aaba1ea2d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffd1f49428) at libc-start.c:220
#41 0x00000000004006c9 in _start ()
Warning: the current language does not match this frame.

Reported using DrKonqi
Comment 1 Milian Wolff 2009-10-22 00:01:08 UTC
Adding the check in katelinelayout could be enough, but I doubt it's the correct fix, even though other places in that file also check for m_layout. For one, what should the function return, if there is no layout? -1 ? 0?
Comment 2 Dario Andres 2009-10-22 15:16:15 UTC
Merging with bug 200858 Thanks

*** This bug has been marked as a duplicate of bug 200858 ***