Bug 211323 - Crash opening Kate via ssh X forwarding
Summary: Crash opening Kate via ssh X forwarding
Status: RESOLVED DUPLICATE of bug 211401
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-21 12:52 UTC by Michael L. Tant
Modified: 2009-12-19 10:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael L. Tant 2009-10-21 12:52:21 UTC
Application that crashed: kate
Version of the application: 3.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30.8-64.fc11.i586 i686
Distribution: "Fedora release 11 (Leonidas)"

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[KCrash Handler]
#6  0x0626ce00 in QDataStream::operator>>(int&) () from /usr/lib/libQtCore.so.4
#7  0x06815e5d in KServiceFactory::KServiceFactory() () from /usr/lib/libkdecore.so.5
#8  0x068161ac in KServiceFactory::self() () from /usr/lib/libkdecore.so.5
#9  0x0680dc05 in KService::serviceByDesktopName(QString const&) () from /usr/lib/libkdecore.so.5
#10 0x07fd06f0 in KTextEditor::EditorChooser::editor(QString const&, bool) () from /usr/lib/libktexteditor.so.4
#11 0x07e43cb1 in ?? () from /usr/lib/libkateinterfaces.so.4
#12 0x07e35317 in KateApp::KateApp(KCmdLineArgs*) () from /usr/lib/libkateinterfaces.so.4
#13 0x004ae5a7 in kdemain () from /usr/lib/libkdeinit4_kate.so
#14 0x0804864b in _start ()

Reported using DrKonqi
Comment 1 Michael L. Tant 2009-10-21 12:56:54 UTC
This is the first time since the installation of Fedora 11 that Kate has been accessed via SSH X forwarding.  Immediately following this crash I attempted to duplicate the results by using the exact command and syntax, however the command functioned normally thus far.  I will begin testing various Kate functions (editing, saving, opening, searching, etc) to see if any of these functions returns errors.  I will include any data gathered from bug report generator and command line.
Comment 2 Dario Andres 2009-12-12 23:59:30 UTC
I don't really know the internals of the SSH X forwarding, but, could that also mean that you were running the app as a different user? That would be bug 211401. Thanks
Comment 3 Michael L. Tant 2009-12-13 03:36:27 UTC
I have attempted to recreate the bug, to no avail.  It appears to occur only on the first use attempt, and is limited to Kate.  All other X applications via forwarding do not experience this issue.  ausearch of the appropriate log archive reveals nothing that suggests selinux to be the culprit.  I have since upgraded to 12, still attempting to recreate the glitch.

Thanks for looking into this, and I will both check out the above bug report and keep you posted.
Comment 4 Christoph Feck 2009-12-19 10:19:32 UTC

*** This bug has been marked as a duplicate of bug 211401 ***