Bug 211288 - Default Desktop Effect Shortcut Keys are Difficult to Use
Summary: Default Desktop Effect Shortcut Keys are Difficult to Use
Status: RESOLVED NOT A BUG
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-21 04:10 UTC by David Rankin
Modified: 2009-10-26 23:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Rankin 2009-10-21 04:10:20 UTC
Version:            (using KDE 4.3.2)
Installed from:    Unspecified

Making shortcuts work with Desktop Effects and Compiz
(Note: this became longer than originally anticipated)

    One place where kde4 suffers badly is in its default definition of keyboard shortcuts. (globally) It seems that every thing you might want to do with a shortcut is defined by default with a shortcut that requires you to completely rearrange your hands on the keyboard -- defeating the benefit of the "shortcut."

    Having to get to 'F'-anything moves the left or right hand to the complete top of the keyboard. For some reason I just find it awkward to reset coming back down from the F-keys at the top of the keyboard, but I don't find it difficult at all to use the arrow keys and then reset the right hand on the keyboard. (I'm sure it is probably due to a personal mental defect -- or the frequent use we all make of the arrow keys, one or the other) I generally try to figure out a comfortable shortcut combination to replace the awkward ones. My goal is to do it without altering any existing keyboard combination, if possible.

    One area in particular where kde4 suffers is with desktop effects. CTRL+F8, CTRL+F9, CTRL+F11, CTRL+SHIFT+F11 are for the birds in my book. (just look at the position your hands have to get to in order to do CTRL+SHIFT+F11) I have come up with replacements that work much better for me. You may hate them, but some may find them very convenient compared to the afterthought keystrokes kde4 offers by default. Setting the similar compiz effects to the same thing provides a seamless transition between WMs. Setup will take about 3 minutes (5 if you do both kde and compiz).

    For desktop effects, it is easier to set most of the shortcuts throught the kde system settings -> Computer Administration -> Keyboard & Mouse -> Global Keyboard Shortcuts -- then set "KDE Component" to KWin. (to set the shortcut, just click on the line with the Action you want to set the shortcut for and then press the button next to "Custom" (the one with the wrench on it) and enter your new keystroke)

    Since most CTRL and ALT combination are taken, reluctantly I use the Windows key instead. (kde detects the Windows key as a 'Meta' key, compiz calls it the 'Super' key) Below I use Win to designate the Windows key. If you have a laptop with the Windows key in some really strange location that is hard to reach, then consider using the Left-Alt or Left-CTRL instead if you can do it without getting rid of a needed shortcut) Here are the shortcuts you can set there (in the order they appear down the page):

    INITIATING DESKTOP CUBE

    Win+u		Desktop Cube (compiz cube or current deformaton)
    Win+i		Desktop Cylinder
    Win+p		Desktop Sphere  ('o' just didn't seem right for sphere...)

    SWITCHING DESKTOPS -- NEXT DESKTOP / PREVIOUS DESKTOP
    (My most used)

    Win+[up-arrow]	Show Desktop Grid (it toggles on/off) (Compiz Expo)
    Win+[right-arrow]	Switch to Next Desktop
    Win+[left-arrow]	Switch to Previous Desktop
    Win+[down-arrow]	Toggle Present Windows
	(Compiz Scale uses top-right of screen hot-spot, I use Win-down to unfold cube there)

    SCREEN EDGE (kde & compiz) [system setting -> Desktop -> Screen Edges]

    Top-Left		Desktop Grid (compiz Expo)
    Top-Right		Present Windows (compiz Scale)(it doesn't bother the cashew)
    Mid-Left		Desktop Cube (kde only)*
    Mid-Right		Desktop Cylinder (kde only)*

    * Compiz provides mouse activation for the desktop cube or cylinder. I change the CTRL+ALT+Button 1 default in compiz to Win+Button 1.
    
    WINDOW TO NEXT/PREVIOUS DESKTOP (KDE4)
    ROTATE LEFT/RIGHT WITH WINDOW (compiz)
    
    Alt+Win[right-arrow]	Window to Next Desktop
    Alt+Win[lef-arrow]		Window to Previous Desktop

    That's it. If you give these a try, you just might find using the new desktop effects really becomes intuitive and a whole lot more convenient that struggling to use them with the default shortcuts. On the other hand, if you already like reaching across the keyboard using the defaults, then don't change a thing -- this post isn't for you.
Comment 1 Chani 2009-10-21 05:04:00 UTC
this isn't a bug report, it's a howto. please post it to forums.kde.org instead. :)
Comment 2 David Rankin 2009-10-26 18:38:25 UTC
Chani

Are you crazy? This was filed as a "Wish" and was filed to help KDE4 improve its efficiency regarding default keyboard shortcuts for desktop effects. This is something that should receive fair debate among the kde team and not something that should be summarily dismissed with a "go post it to a mailing list." That's just ridiculous. What in the heck is the "wishlist" for??

I'm reopening it as a wish so I can receive the fair deliberation it deserves.
Comment 3 Chani 2009-10-26 23:01:34 UTC
the way it was written, I thought you wanted *users* to read it, which is why I suggested you post it on the forums where they'll actually see it.

all of your suggested shortcuts are for kwin anyways, so this has nothing to do with plasma; you still haven't reached your intended audience. and I don't really feel like cluttering up their bug list with it. *if* the kwin team wanted to dicuss their choice of default shortcuts, then they would do so on their mailing list or irc. bugzilla is not a tool for discussing such decisions. really, it isn't.

I just checked with them on IRC and, as I suspected, there's a reason they're not using the win key by default: not all keyboards have it.