Bug 211004 - Moving file from trash results in name change
Summary: Moving file from trash results in name change
Status: RESOLVED DUPLICATE of bug 183403
Alias: None
Product: kio
Classification: Unclassified
Component: general (show other bugs)
Version: 4.3
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-18 20:51 UTC by michael
Modified: 2012-01-13 08:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michael 2009-10-18 20:51:23 UTC
Version:            (using KDE 4.3.2)
OS:                Linux
Installed from:    Ubuntu Packages

I am reporting this under kio because I have already attempted to change this from with the trash protocol ioslave module and determined that a proper fix seems to require changes deeper in kde. The scenario I'm stuck on is this I have two files one called "0-test.txt" the other called "test.txt". I move "test.txt" to the trash. Using the restore feature will correctly restore the file to its original location and name with no prompt. However, if I attempt to drag it from the trash back to the original location I get prompted to replace "0-test.txt". I am able to path the trash protocol so that it does not actual replace this file but instead restores the original name. However the code responsible for the replacement prompt still checks based on the physical name of the file which is not correct for trash: protocol. I am willing to help with this if its not already fixed but I don't know where to look.
Comment 1 Asen Lekov 2011-11-25 15:42:56 UTC
Same situation in KDE 4.7.2
Comment 2 Myriam Schweingruber 2011-11-25 22:21:48 UTC
I think this is intended behavior, deleted files should be restored, not just moved. David?
Comment 3 michael 2011-12-16 15:45:22 UTC
It may be but its confusing to end user who don't expect this. Neither OS X nor windows causes the file name to change on moving it from the trash. OS X sometimes does this when moving to the the trash but the display name is changed to match what the file will be called if moved back out of the trash. Perhaps, KDE could do this. As it is the display name and actually name if moved are out of sync.
Comment 4 Myriam Schweingruber 2011-12-17 17:21:02 UTC
Wrong, Windows does change the file name to 0-*, so when you move it out of the trash instead of restoring it you will have a renamed file.
Again, the correct way is not to move files out of the trash but to restore them. Just right click on it and you will see the option.
Comment 5 michael 2011-12-18 03:53:46 UTC
Thanks. My primary experience is with OS X so aware that windows now does this. If KDE is intentionally imitating this no need to change it. For myself I may still patch my own system.
Comment 6 Anne-Marie Mahfouf 2012-01-13 08:47:38 UTC

*** This bug has been marked as a duplicate of bug 183403 ***