Bug 210831 - plasma crashed after moving folder
Summary: plasma crashed after moving folder
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-16 22:55 UTC by Samuel
Modified: 2009-10-17 19:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel 2009-10-16 22:55:01 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
plasma crashed after I moved a folder from my desktop (folder view) to my external hard drive opened with dolphin

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 0 (LWP 4557)]

Thread 2 (Thread 0xa6affb90 (LWP 4560)):
#0  0xb80b6430 in __kernel_vsyscall ()
#1  0xb65cd0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb67ad2ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb7eb4172 in QWaitCondition::wait (this=0x8a1b198, mutex=0x8a1b194, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb77f0ac2 in QHostInfoAgent::run (this=0x8a1b188) at kernel/qhostinfo.cpp:260
#5  0xb7eb3132 in QThreadPrivate::start (arg=0x8a1b188) at thread/qthread_unix.cpp:188
#6  0xb65c94ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb679e49e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb60d6a10 (LWP 4557)):
[KCrash Handler]
#6  0xb7999848 in KFileItem::isDir (this=0x8d19208) at /build/buildd/kde4libs-4.3.2/kio/kio/kfileitem.cpp:969
#7  0xb7987642 in KDirModelPrivate::removeFromNodeHash (this=0x8ea1870, node=0x8d19208, url=@0xbfed3564) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirmodel.cpp:200
#8  0xb7988700 in KDirModelPrivate::_k_slotDeleteItems (this=0x8ea1870, items=@0xbfed36c8) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirmodel.cpp:487
#9  0xb798a0e5 in KDirModel::qt_metacall (this=0x95d8f18, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfed368c) at /build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/kio/kdirmodel.moc:83
#10 0xb7fbd1b8 in QMetaObject::activate (sender=0x9754fb8, from_signal_index=17, to_signal_index=17, argv=0xbfed368c) at kernel/qobject.cpp:3113
#11 0xb7fbde42 in QMetaObject::activate (sender=0x9754fb8, m=0xb7af801c, local_signal_index=13, argv=0xbfed368c) at kernel/qobject.cpp:3187
#12 0xb796caa3 in KDirLister::itemsDeleted (this=0x9754fb8, _t1=@0xbfed36c8) at /build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/kio/kdirlister.moc:289
#13 0xb796d9b1 in KDirLister::Private::emitItemsDeleted (this=0x84d9e50, _items=@0x892daa4) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirlister.cpp:2351
#14 0xb7978150 in KDirListerCache::itemsDeleted (this=0x84026b8, listers=@0x8d19230, deletedItems=@0x892daa4) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirlister.cpp:1697
#15 0xb7978972 in KDirListerCache::slotFilesRemoved (this=0x84026b8, fileList=@0xbfed38bc) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirlister.cpp:808
#16 0xb7978d98 in KDirListerCache::slotFilesRemoved (this=0x84026b8, fileList=@0x881ea50) at /build/buildd/kde4libs-4.3.2/kio/kio/kdirlister.cpp:763
#17 0xb798023a in KDirListerCache::qt_metacall (this=0x84026b8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfed39bc) at /build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/kio/kdirlister_p.moc:92
#18 0xb7fbd1b8 in QMetaObject::activate (sender=0x83aa8f0, from_signal_index=9, to_signal_index=9, argv=0xbfed39bc) at kernel/qobject.cpp:3113
#19 0xb7fbde42 in QMetaObject::activate (sender=0x83aa8f0, m=0xb7af8274, local_signal_index=4, argv=0xbfed39bc) at kernel/qobject.cpp:3187
#20 0xb798bc73 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x83aa8f0, _t1=@0x881ea50) at /build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/kio/kdirnotify.moc:125
#21 0xb798be72 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x83aa8f0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfed3b58)
    at /build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/kio/kdirnotify.moc:83
#22 0xb735de5a in QDBusConnectionPrivate::deliverCall (this=0x80bc7c8, object=0x83aa8f0, msg=@0x9b28bb4, metaTypes=@0x9b28bb8, slotIdx=9) at qdbusintegrator.cpp:891
#23 0xb7365eb7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9b28b88, object=0x83aa8f0) at qdbusintegrator_p.h:101
#24 0xb7fb83b0 in QObject::event (this=0x83aa8f0, e=0x9b28b88) at kernel/qobject.cpp:1111
#25 0xb6a63d3c in QApplicationPrivate::notify_helper (this=0x80f9eb8, receiver=0x83aa8f0, e=0x9b28b88) at kernel/qapplication.cpp:4056
#26 0xb6a6c03e in QApplication::notify (this=0x80bbbb0, receiver=0x83aa8f0, e=0x9b28b88) at kernel/qapplication.cpp:3603
#27 0xb757449d in KApplication::notify (this=0x80bbbb0, receiver=0x83aa8f0, event=0x9b28b88) at /build/buildd/kde4libs-4.3.2/kdeui/kernel/kapplication.cpp:302
#28 0xb7fa7bcb in QCoreApplication::notifyInternal (this=0x80bbbb0, receiver=0x83aa8f0, event=0x9b28b88) at kernel/qcoreapplication.cpp:610
#29 0xb7fa8825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8081b38) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#30 0xb7fa8a1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#31 0xb7fd36af in postEventSourceDispatch (s=0x80fbf10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#32 0xb6616b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb661a0eb in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb661a268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb7fd32f8 in QEventDispatcherGlib::processEvents (this=0x80f9990, flags={i = -1074970280}) at kernel/qeventdispatcher_glib.cpp:327
#36 0xb6b05a75 in QGuiEventDispatcherGlib::processEvents (this=0x80f9990, flags={i = -1074970232}) at kernel/qguieventdispatcher_glib.cpp:202
#37 0xb7fa61fa in QEventLoop::processEvents (this=0xbfed4200, flags={i = -1074970168}) at kernel/qeventloop.cpp:149
#38 0xb7fa6642 in QEventLoop::exec (this=0xbfed4200, flags={i = -1074970104}) at kernel/qeventloop.cpp:201
#39 0xb7fa8ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#40 0xb6a63bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#41 0xb3e542f0 in kdemain (argc=1, argv=0x80d4d28) at /build/buildd/kdebase-workspace-4.3.2/plasma/shells/desktop/main.cpp:50
#42 0x0804e27d in launch (argc=1, _name=0x808257c "/usr/bin/plasma-desktop", args=0x8082594 "", cwd=0x0, envc=0, envs=0x8082598 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x805136d "0") at /build/buildd/kde4libs-4.3.2/kinit/kinit.cpp:677
#43 0x0804ea5d in handle_launcher_request (sock=7, who=<value optimized out>) at /build/buildd/kde4libs-4.3.2/kinit/kinit.cpp:1169
#44 0x0804efe5 in handle_requests (waitForPid=0) at /build/buildd/kde4libs-4.3.2/kinit/kinit.cpp:1362
#45 0x0804fbca in main (argc=2, argv=0xbfed49f4, envp=0xbfed4a00) at /build/buildd/kde4libs-4.3.2/kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-17 19:11:32 UTC
Merging with bug 196695. Thanks

*** This bug has been marked as a duplicate of bug 196695 ***