Bug 210761 - Amarok UI freezes while examining removable media
Summary: Amarok UI freezes while examining removable media
Status: RESOLVED DUPLICATE of bug 212615
Alias: None
Product: amarok
Classification: Applications
Component: Collections/Local (show other bugs)
Version: 2.2.0
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-16 09:15 UTC by Matt Whitlock
Modified: 2009-11-28 09:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Whitlock 2009-10-16 09:15:35 UTC
Version:           2.2.0 (using KDE 4.3.2)
Compiler:          gcc (Gentoo 4.4.1 p1.0) 4.4.1 
OS:                Linux
Installed from:    Gentoo Packages

A few seconds after starting Amarok, the GUI freezes for a considerable time (often a minute or more).  This appears to be due to Amarok's crawling the directory hierarchies of mounted removable storage media.  No activity or progress is displayed in the status bar during this time, and the GUI is unresponsive.

I have a USB flash drive mounted that contains 155303 files in 21349 directories.  Needless to say, if the dentries aren't already cached in memory, it takes a bit of time to load them all from the flash.  During that time, Amarok is completely frozen and useless.

Suggested fix: Perform the scan of removable media in a thread other than the GUI thread.
Comment 1 Mikko C. 2009-11-28 09:23:56 UTC

*** This bug has been marked as a duplicate of bug 212615 ***