Bug 210291 - webkit button does not respond
Summary: webkit button does not respond
Status: RESOLVED UPSTREAM
Alias: None
Product: kwebkitpart
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: webkit-devel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-12 10:27 UTC by Ferdinand Gassauer
Modified: 2010-09-10 07:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ferdinand Gassauer 2009-10-12 10:27:57 UTC
Version:           4.3.2 (KDE 4.3.2) "release 5" (using 4.3.2 (KDE 4.3.2) "release 5", KDE:43 / openSUSE_11.0)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.25.20-0.5-default

http://www.dpd.com/de
the button next to "Sendungsverfolgung" does not react on click - works in khtml
Comment 1 Ferdinand Gassauer 2009-10-12 10:29:04 UTC
BTW there is no component "Webkit"
Comment 2 Frank Reininghaus 2009-10-12 10:54:27 UTC
(In reply to comment #1)
> BTW there is no component "Webkit"

It's called 'webkitkde'.
Comment 3 Dawit Alemayehu 2009-10-19 23:19:27 UTC
Works fine for me... At least I get the same result I get in both khtml and firefox3. Please note that it will not work if you have disabled javascript!
Comment 4 Ferdinand Gassauer 2009-10-20 09:12:59 UTC
I found some pages where buttons work as long as no variables are associated
the example above - 
the button reacts as long as no packet number is enterd
another example
http://www.1point618.com/search/search
the browse button executes search as long as no selection is made
so javascript must be enabled in both cases
Comment 5 Dawit Alemayehu 2009-10-23 01:15:15 UTC
That example works for me as well. Perhaps a detailed steps on how to reproduce the problem might help, but I cannot duplicate this issue at all...
Comment 6 Ferdinand Gassauer 2009-10-23 22:30:32 UTC
@Dawit: please try http://www.dpd.at/
with this number 01635001689282H

it seems to work (open 1 empty and one filled window ) after setting javascript 
Open New windows to "allow" but not with "smart"
Comment 7 Dawit Alemayehu 2009-10-25 05:43:12 UTC
@ferdinand: that works correctly here as well. I get a blank window and a 'filled' window. I have javascript enabled globally and "Open new windows" is set to "Smart".
Comment 8 Ferdinand Gassauer 2009-10-25 09:13:09 UTC
strange .. 
I tested it on OpenSuSE 11.1 / x86_64 on a fresh install now - same symptoms
have to set "open windows" to allow - smart does not work
could it be a SuSE issue?
Comment 9 Dawit Alemayehu 2009-10-30 23:20:06 UTC
Well I am not sure. However, unless you compiled webkitkde from source I suspect the version packaged by your distro might be completely out of date.
Comment 10 Urs Wolfer 2010-01-23 17:18:50 UTC
It's behaving strange for me as well. The first time, two popups open; one with the correct content. The following times, just an empty (but probably correctly sized) popup opens.
Comment 11 Dawit Alemayehu 2010-06-24 00:14:40 UTC
Is this problem still valid with recent versions of kwebkitpart or can it be closed ?
Comment 12 Dawit Alemayehu 2010-09-10 07:54:51 UTC
I am unable to duplicate the "smart" vs "open" javascript setting issue. However, I am now able to reproduce what Urs stated in comment #10 and since the issue can be reproduced using QtTestBrowser, I have opened an upstream ticket for it. 
See http://webkit.org/b/45523