Bug 210182 - konqueror sometimes crash when opening new tab
Summary: konqueror sometimes crash when opening new tab
Status: RESOLVED DUPLICATE of bug 203809
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.3.1
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-11 13:23 UTC by Martin Naď
Modified: 2009-10-11 13:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Naď 2009-10-11 13:23:48 UTC
Version:            (using KDE 4.3.1)
OS:                Linux
Installed from:    Fedora RPMs

Description of problem:
konqueror sometimes crash when I open new tab

Version-Release number of selected component (if applicable):
kdebase-runtime-4.3.1-2.fc11.x86_64
kdebase-libs-4.3.1-2.fc11.x86_64
kdebase-runtime-libs-4.3.1-2.fc11.x86_64
kdebase-workspace-libs-4.3.1-9.fc11.x86_64
kdebase-workspace-4.3.1-9.fc11.x86_64
kdebase-workspace-python-applet-4.3.1-9.fc11.x86_64
kdebase-4.3.1-2.fc11.x86_64
kdelibs-4.3.1-3.fc11.x86_64
kdelibs-experimental-4.3.1-1.fc11.x86_64
kdelibs-common-4.3.1-3.fc11.x86_64
kdelibs-devel-4.3.1-3.fc11.x86_64
kdelibs3-3.5.10-13.fc11.1.x86_64
kdelibs-debuginfo-4.3.1-3.fc11.x86_64

How reproducible:
sometimes

Steps to Reproduce:
1.runing konqueror with so 5 tab
2.open new tab
3.konqueror crash

Actual results:
konqueror sometimes crash when opening new tab

https://bugzilla.redhat.com/show_bug.cgi?id=527764
Comment 1 Martin Naď 2009-10-11 13:24:30 UTC
Application: Konqueror (konqueror), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff6c87ed820 (LWP 2885))]

Thread 3 (Thread 0x7ff6ba1c4910 (LWP 2894)):
#0  0x00000033ef4d7102 in select () from /lib64/libc.so.6
#1  0x00000033fa11e981 in QProcessManager::run (this=0xacb6d0) at io/qprocess_unix.cpp:296
#2  0x00000033fa059d45 in QThreadPrivate::start (arg=0xacb6d0) at thread/qthread_unix.cpp:188
#3  0x00000033f000686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#4  0x00000033ef4de3bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff6a90c2910 (LWP 3208)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00000033fa05ad62 in QWaitConditionPrivate::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x00000033fa050e3a in QThreadPoolThread::run (this=<value optimized out>) at concurrent/qthreadpool.cpp:140
#4  0x00000033fa059d45 in QThreadPrivate::start (arg=0x11b4440) at thread/qthread_unix.cpp:188
#5  0x00000033f000686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#6  0x00000033ef4de3bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff6c87ed820 (LWP 2885)):
[KCrash Handler]
#5  __cxxabiv1::__dynamic_cast(const void *, const struct __cxxabiv1::__class_type_info *, const struct __cxxabiv1::__class_type_info *, ptrdiff_t) (src_ptr=0x1f75c58, src_type=0x30c60f47e0, 
    dst_type=0x30c60f4d20, src2dst=40) at ../../../../libstdc++-v3/libsupc++/dyncast.cc:43
#6  0x00000030c5e9599e in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () at /usr/src/debug/kdelibs-4.3.1/kdecore/config/kconfiggroup.cpp:954
#7  0x00000030c5ea2f25 in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () at /usr/src/debug/kdelibs-4.3.1/kdecore/config/kconfiggroup.cpp:954
#8  0x00000033fa1547dc in QMetaObject::activate (sender=0xbcb620, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x28) at kernel/qobject.cpp:3113
#9  0x00000030c5e4dabf in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () at /usr/src/debug/kdelibs-4.3.1/kdecore/config/kconfiggroup.cpp:954
#10 0x00000030c5e4e68b in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () at /usr/src/debug/kdelibs-4.3.1/kdecore/config/kconfiggroup.cpp:954
#11 0x00000030c5ea31ed in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () at /usr/src/debug/kdelibs-4.3.1/kdecore/config/kconfiggroup.cpp:954
#12 0x00000033fa1547dc in QMetaObject::activate (sender=0x4f82a60, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x28) at kernel/qobject.cpp:3113
#13 0x00000033fa1597bf in QSingleShotTimer::timerEvent (this=0x4f82a60) at kernel/qtimer.cpp:298
#14 0x00000033fa14e7de in QObject::event (this=0x4f82a60, e=0x30c60f47e0) at kernel/qobject.cpp:1075
#15 0x000000384f78f69c in QApplicationPrivate::notify_helper (this=0xac7440, receiver=0x4f82a60, e=0x7fff27bb2810) at kernel/qapplication.cpp:4056
#16 0x000000384f7968fe in QApplication::notify (this=0x7fff27bb2ca0, receiver=0x4f82a60, e=0x7fff27bb2810) at kernel/qapplication.cpp:4021
#17 0x0000003851011b56 in KApplication::notify (this=0x7fff27bb2ca0, receiver=0x4f82a60, event=0x7fff27bb2810) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#18 0x00000033fa13f59c in QCoreApplication::notifyInternal (this=0x7fff27bb2ca0, receiver=0x4f82a60, event=0x7fff27bb2810) at kernel/qcoreapplication.cpp:610
#19 0x00000033fa169fc2 in QCoreApplication::sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:213
#20 QTimerInfoList::activateTimers (event=<value optimized out>, receiver=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:572
#21 0x00000033fa1679ed in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#22 0x00000033f103790e in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#23 0x00000033f103b0e8 in ?? () from /lib64/libglib-2.0.so.0
#24 0x00000033f103b20a in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#25 0x00000033fa167936 in QEventDispatcherGlib::processEvents (this=0xaa9d90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x000000384f821f8e in QGuiEventDispatcherGlib::processEvents (this=0x1f75c58, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00000033fa13ded2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 36}) at kernel/qeventloop.cpp:149
#28 0x00000033fa13e2a4 in QEventLoop::exec (this=0x7fff27bb2ab0, flags={i = 0}) at kernel/qeventloop.cpp:201
#29 0x00000033fa140439 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x00000030c5ecf4e3 in kdemain () from /usr/lib64/libkdeinit4_konqueror.so
#31 0x00000033ef41ea2d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff27bb36b8) at libc-start.c:220
#32 0x0000000000400759 in _start ()
Comment 2 Tommi Tervo 2009-10-11 13:52:55 UTC

*** This bug has been marked as a duplicate of bug 203809 ***