Bug 210084 - KDE Needs Automake >=1.6.1 -- I have 1.11
Summary: KDE Needs Automake >=1.6.1 -- I have 1.11
Status: RESOLVED INTENTIONAL
Alias: None
Product: kdevelop
Classification: Applications
Component: Build tools: Automake (show other bugs)
Version: 3.5.4
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-10 15:25 UTC by Lucélio Gomes de Freitas
Modified: 2009-10-11 19:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lucélio Gomes de Freitas 2009-10-10 15:25:03 UTC
Version:           kdevelop - devel.x86_64 9:3.5.4-3.fc11 (using KDE 4.3.1)
OS:                Linux
Installed from:    Fedora RPMs

I'm on the most updated Fedora-11-x86_64 with KDevelop 3.5.4-3.fc11. I have automake 1.11 installed, but when I attempt to run automake and friends on a new project I get:

*** YOU'RE USING automake (GNU automake) 1.11
*** KDE requires automake 1.6.1 or newer

Ps: Am I right to say (1.11 > 1.6.1)?
Comment 1 Andreas Pakulat 2009-10-10 17:44:45 UTC
Yes you're right, but the checks in the automake-files provided by kde3 are not flexible enough to handle that. As KDE3 and with that KDevelop3 are completely unmaintained since 2 years, this won't change.
Comment 2 Lucélio Gomes de Freitas 2009-10-10 17:55:49 UTC
Ok.

Please, I accept sugestions where to go from now.
what ways I should take to go on with my jobs.   I need an IDE to work.

Thanks.

Em 10-10-2009 12:44, Andreas Pakulat escreveu:
> https://bugs.kde.org/show_bug.cgi?id=210084
>
>
> Andreas Pakulat<apaku@gmx.de>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>               Status|UNCONFIRMED                 |RESOLVED
>           Resolution|                            |WONTFIX
>
>
>
>
> --- Comment #1 from Andreas Pakulat<apaku gmx de>   2009-10-10 17:44:45 ---
> Yes you're right, but the checks in the automake-files provided by kde3 are not
> flexible enough to handle that. As KDE3 and with that KDevelop3 are completely
> unmaintained since 2 years, this won't change.
>
>
Comment 3 Lucélio Gomes de Freitas 2009-10-11 14:19:27 UTC
Sorry,

I did't understand.   I said using most updated Fedora-11-x86_64 with KDevelop 3.5.4-3.fc11 (KDE 4.3.1)

Thanks.
Comment 4 Amilcar do Carmo Lucas 2009-10-11 15:28:14 UTC
What Andreas meant was:
That part of the code belongs to KDE3 build system. The KDE3 developers are no longer working on that code since two years.
KDevelop3 relies on that code, so unless you fix it, or convince the old KDE3 developers to fix it, no one on the KDevelop team will fix it for you (it is not KDevelop3 code).

So basically downgrade automake to 1.9 and that's it.
Comment 5 Andreas Pakulat 2009-10-11 19:27:05 UTC
and its still a wontfix.