Bug 209905 - currency import is broken
Summary: currency import is broken
Status: RESOLVED FIXED
Alias: None
Product: skrooge
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephane MANKOWSKI
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-08 20:43 UTC by David Krapohl
Modified: 2009-10-09 13:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screen capture (60.71 KB, image/jpeg)
2009-10-08 22:44 UTC, Stephane MANKOWSKI
Details
Snapshort of currency section (50.90 KB, image/png)
2009-10-08 23:50 UTC, David Krapohl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Krapohl 2009-10-08 20:43:39 UTC
Version:           0.5.2 (using KDE 4.3.1)
Compiler:          gcc 4.4.1 
OS:                Linux
Installed from:    Unspecified Linux

I am trying to download EURSEK=X, Euro in Swedish Krona. But all I get is a list of numbers and none of them makes sense. 
It starts with:
Today 95.85€
2008-02-25 9.31€
2008-02-22 806.95€
...
2007-12-13 522,971,198,099,999,978,233,912,166,343,988,854,446,014,595,072.00€
Comment 1 Stephane MANKOWSKI 2009-10-08 22:44:36 UTC
Created attachment 37456 [details]
screen capture

Hi David,

As you can see in screen capture, I did the test and it seems correct.

What are yours settings for download ?
Comment 2 David Krapohl 2009-10-08 23:50:16 UTC
Created attachment 37458 [details]
Snapshort of currency section

Here is a snapshot of the same section. I tried with a clean account but that doesn't help either.
Comment 3 Stephane MANKOWSKI 2009-10-09 13:16:38 UTC
Hi,

I am able to reproduce.
I will deliver a correction.

Because of the Internet code is "EURSEK=X", the reference unit for SK must be € instead of $.
Comment 4 Stephane MANKOWSKI 2009-10-09 13:55:37 UTC
SVN commit 1033054 by smankowski:

BUG: 209905: currency import is broken

 M  +1 -0      CHANGELOG  
 M  +13 -0     skgbankmodeler/skgunitobject.cpp  
 M  +12 -6     skrooge_unit/skgunitpluginwidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1033054