Bug 209777 - knetworkmanager can't establish a GSM connection without a saved PIN code - and it gives no error message
Summary: knetworkmanager can't establish a GSM connection without a saved PIN code - a...
Status: RESOLVED DUPLICATE of bug 264083
Alias: None
Product: Network Management
Classification: Unclassified
Component: Mobile Broadband (show other bugs)
Version: 0.9
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-07 17:51 UTC by Tamás Németh
Modified: 2011-05-01 03:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Németh 2009-10-07 17:51:57 UTC
Version:            (using KDE 4.3.1)
OS:                Linux
Installed from:    SuSE RPMs

The SIM card in my 3G modem requires a PIN code. When I don't save the PIN code in knetworkmanager's configuration, then knetworkmanager - instead of asking for it offering the choose between saving it permanently or using only for that session - silently fails to register to the GSM network, it doesn't even give me any error messages. The constant need for the saved PIN code may be dangerous, becouse if anyone uses the notebook unauthorized, he/she will be able to use the GSM network without any problem.

What makes this problem even worse, is that knetworkmanager sometimes just forgets the PIN code and other random GSM connection data (e.g. APN, password, etc.)

In addition to this, when I accidentally fill in a wring PIN code, then knetworkmanager - instead of warning me - silently tries to connect using the wrong PIN code every time I clock on the connection's entry. This may cause the SIM card to go locked and only able to be unlocked using the PUK code. Very annoying!
Comment 1 Axel Braun 2009-11-26 12:50:26 UTC
I jump on this because my problem seems to be similar.
Environemnt: kubuntu netbook remix 9.10 on an eeePC 901 go (with build-in UMTS-modem): Even with the same settings as Tamas I'm unable to establish a connection. The standard ubuntu netbook remix 9.10 (using gnome) connects w/o problems, so it seems to be a Knetworkmanager Problem....
Comment 2 Axel Braun 2010-01-06 08:26:01 UTC
BTW, it even reports a PIN failure if PIN is disabled (some mobile phones allow to do this setting, and I was told the SIM card recognizes that)
Comment 3 Axel Braun 2010-01-09 16:31:59 UTC
CORRECTION: If PIN is disabled, dial-in works as you expect it. Sorry for the confusion
Comment 4 Lamarque V. Souza 2011-02-27 20:04:58 UTC
Is this problem still happening with the latest Plasma NM snapshot?
Comment 5 Daniel Baumgartner 2011-04-05 18:40:30 UTC
A compareable Problem in KDE 4.6 in Suse 11.4.

No connection for USB Stick because no valid PIN is provided.
Comment 6 Lamarque V. Souza 2011-05-01 03:23:38 UTC

*** This bug has been marked as a duplicate of bug 264083 ***