Bug 209729 - Crash while drag and drop
Summary: Crash while drag and drop
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Drag&Drop (show other bugs)
Version: 1.5.0
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-07 11:25 UTC by Andreas Bank
Modified: 2019-08-14 18:52 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments
New crash information added by DrKonqi (19.54 KB, text/plain)
2010-12-05 14:07 UTC, Javier Conti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Bank 2009-10-07 11:25:05 UTC
Version:           0.10.0 (using 4.2.4 (KDE 4.2.4), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.28-15-generic

Hi,

while dragging pictures from digikam to another application digikam and the other app crashes. Here is what i do.
1.) Start dragging the picture
2.) Toggle the application (Alt + Tab)
3.) Drop the image

The crash occurs during the toggling and does not occur during every drag-and-drop. But once in 10 times.

Here the crash report:
Anwendung: digiKam (digikam), Signal SIGSEGV
[Current thread is 0 (LWP 7221)]

Thread 12 (Thread 0xb3052b90 (LWP 7222)):
#0  0xb8061430 in __kernel_vsyscall ()
#1  0xb54af0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55b12ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb579d9b2 in QWaitCondition::wait (this=0x9a8de38, mutex=0x9a8de34, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0x0828f319 in Digikam::ScanController::run (this=0x9af8a60) at /build/buildd/digikam-0.10.0/digikam/scancontroller.cpp:412
#5  0xb579c96e in QThreadPrivate::start (arg=0x9af8a60) at thread/qthread_unix.cpp:189
#6  0xb54ab4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb55a249e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 11 (Thread 0xb239fb90 (LWP 7224)):
#0  0xb8061430 in __kernel_vsyscall ()
#1  0xb54af0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55b12ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb579d9b2 in QWaitCondition::wait (this=0x9cdaa38, mutex=0x9cdaa34, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb728dd4a in Digikam::LoadSaveThread::run (this=0x9cdaa28) at /build/buildd/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#5  0xb579c96e in QThreadPrivate::start (arg=0x9cdaa28) at thread/qthread_unix.cpp:189
#6  0xb54ab4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb55a249e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 10 (Thread 0xb17ffb90 (LWP 7225)):
#0  0xb8061430 in __kernel_vsyscall ()
#1  0xb54af0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55b12ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb579d9b2 in QWaitCondition::wait (this=0x9cdb620, mutex=0x9cdb61c, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb728dd4a in Digikam::LoadSaveThread::run (this=0x9cdb610) at /build/buildd/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#5  0xb579c96e in QThreadPrivate::start (arg=0x9cdb610) at thread/qthread_unix.cpp:189
#6  0xb54ab4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb55a249e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 9 (Thread 0xaebf0b90 (LWP 7226)):
#0  0xb8061430 in __kernel_vsyscall ()
#1  0xb54af412 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55b1344 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0xafa28ae3 in ?? () from /usr/lib/libxine.so.1

Thread 8 (Thread 0xadf68b90 (LWP 7227)):
#0  0xb8061430 in __kernel_vsyscall ()
#1  0xb559a7b1 in select () from /lib/tls/i686/cmov/libc.so.6
#2  0xafa527d6 in xine_usec_sleep () from /usr/lib/libxine.so.1
#3  0x00000000 in ?? ()

Thread 7 (Thread 0xad767b90 (LWP 7228)):
#0  0xb58bc053 in socketNotifierSourcePrepare (timeout=0xad7671e8) at kernel/qeventdispatcher_glib.cpp:75
#1  0xb4b69dda in ?? () from /usr/lib/libglib-2.0.so.0
#2  0xb4b6a268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0xb58bc457 in QEventDispatcherGlib::processEvents (this=0xa2cf890, flags={i = -1384746392}) at kernel/qeventdispatcher_glib.cpp:325
#4  0xb588f06a in QEventLoop::processEvents (this=0xad7672e0, flags={i = -1384746328}) at kernel/qeventloop.cpp:149
#5  0xb588f4aa in QEventLoop::exec (this=0xad7672e0, flags={i = -1384746264}) at kernel/qeventloop.cpp:200
#6  0xb5799639 in QThread::exec (this=0xa2cf4c0) at thread/qthread.cpp:481
#7  0xafa7620a in ?? () from /usr/lib/kde4/plugins/phonon_backend/phonon_xine.so
#8  0xb579c96e in QThreadPrivate::start (arg=0xa2cf4c0) at thread/qthread_unix.cpp:189
#9  0xb54ab4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0xb55a249e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 6 (Thread 0xacf5cb90 (LWP 7231)):
#0  0xb8061430 in __kernel_vsyscall ()
#1  0xb5597ae7 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0xacf60b19 in ?? () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 5 (Thread 0xac75bb90 (LWP 7232)):
#0  0xb8061430 in __kernel_vsyscall ()
#1  0xb54af0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55b12ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xafa39d8e in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xab727b90 (LWP 7247)):
#0  0xb8061430 in __kernel_vsyscall ()
#1  0xb54af0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55b12ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb579d9b2 in QWaitCondition::wait (this=0xab8fce8, mutex=0xab8fce4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb728dd4a in Digikam::LoadSaveThread::run (this=0xab8fcd8) at /build/buildd/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#5  0xb579c96e in QThreadPrivate::start (arg=0xab8fcd8) at thread/qthread_unix.cpp:189
#6  0xb54ab4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb55a249e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xabf28b90 (LWP 7411)):
#0  0xb8061430 in __kernel_vsyscall ()
#1  0xb54af0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55b12ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb579d9b2 in QWaitCondition::wait (this=0xba717f0, mutex=0xba717ec, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb728dd4a in Digikam::LoadSaveThread::run (this=0xba717e0) at /build/buildd/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#5  0xb579c96e in QThreadPrivate::start (arg=0xba717e0) at thread/qthread_unix.cpp:189
#6  0xb54ab4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb55a249e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa9afdb90 (LWP 7412)):
#0  0xb8061430 in __kernel_vsyscall ()
#1  0xb54af0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55b12ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb579d9b2 in QWaitCondition::wait (this=0xa7df8290, mutex=0xa7df828c, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb728dd4a in Digikam::LoadSaveThread::run (this=0xa7df8280) at /build/buildd/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#5  0xb579c96e in QThreadPrivate::start (arg=0xa7df8280) at thread/qthread_unix.cpp:189
#6  0xb54ab4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb55a249e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb4758920 (LWP 7221)):
[KCrash Handler]
#6  0xb5da8391 in QWidget::testAttribute_helper (this=0xbacfb78, attribute=Qt::WA_Hover) at kernel/qwidget.cpp:9905
#7  0xb5d68c0b in QApplication::notify (this=0xbfa7cad4, receiver=0xbacfb78, e=0xbfa7b078) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:997
#8  0xb6983e0d in KApplication::notify (this=0xbfa7cad4, receiver=0xbacfb78, event=0xbfa7b078) at /build/buildd/kde4libs-4.2.4/kdeui/kernel/kapplication.cpp:307
#9  0xb5890a3b in QCoreApplication::notifyInternal (this=0xbfa7cad4, receiver=0xbacfb78, event=0xbfa7b078) at kernel/qcoreapplication.cpp:602
#10 0xb5d67b7e in QApplicationPrivate::sendMouseEvent (receiver=0xbacfb78, event=0xbfa7b078, alienWidget=0x0, nativeWidget=0xbacfb78, buttonDown=0xb660a200, lastMouseReceiver=@0xb660a204)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#11 0xb5dd797e in QETWidget::translateMouseEvent (this=0xbacfb78, event=0xbfa7b6bc) at kernel/qapplication_x11.cpp:4425
#12 0xb5dd6ca7 in QApplication::x11ProcessEvent (this=0xbfa7cad4, event=0xbfa7b6bc) at kernel/qapplication_x11.cpp:3421
#13 0xb5e01c6a in x11EventSourceDispatch (s=0x9a342a0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#14 0xb4b66b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#15 0xb4b6a0eb in ?? () from /usr/lib/libglib-2.0.so.0
#16 0xb4b6a268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#17 0xb58bc438 in QEventDispatcherGlib::processEvents (this=0x9a1d5b8, flags={i = -1079527304}) at kernel/qeventdispatcher_glib.cpp:323
#18 0xb5e01365 in QGuiEventDispatcherGlib::processEvents (this=0x9a1d5b8, flags={i = -1079527256}) at kernel/qguieventdispatcher_glib.cpp:202
#19 0xb588f06a in QEventLoop::processEvents (this=0xbb160d8, flags={i = -1079527192}) at kernel/qeventloop.cpp:149
#20 0xb588f4aa in QEventLoop::exec (this=0xbb160d8, flags={i = -1079527080}) at kernel/qeventloop.cpp:200
#21 0xb5de8310 in QDragManager::drag (this=0xbf8fd70, o=0xbc26a00) at kernel/qdnd_x11.cpp:1952
#22 0xb5d7353a in QDrag::exec (this=0xbc26a00, supportedActions={i = -1079526880}, defaultDropAction=Qt::IgnoreAction) at kernel/qdrag.cpp:282
#23 0xb5d735e4 in QDrag::exec (this=0xbc26a00, supportedActions={i = -1079526624}) at kernel/qdrag.cpp:239
#24 0x081e4236 in Digikam::AlbumIconView::startDrag (this=0x9b99598) at /build/buildd/digikam-0.10.0/digikam/albumiconview.cpp:1377
#25 0x0826d5d4 in Digikam::IconView::contentsMouseMoveEvent (this=0x9b99598, e=0xbfa7bccc) at /build/buildd/digikam-0.10.0/digikam/iconview.cpp:1241
#26 0xb763ff71 in Q3ScrollView::viewportMouseMoveEvent (this=0x9b99598, e=0xbfa7c188) at widgets/q3scrollview.cpp:1793
#27 0xb7641d32 in Q3ScrollView::eventFilter (this=0x9b99598, obj=0x9c97a40, e=0xbfa7c188) at widgets/q3scrollview.cpp:1491
#28 0xb588fc5a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9a31538, receiver=0x9c97a40, event=0xbfa7c188) at kernel/qcoreapplication.cpp:718
#29 0xb5d5fe7a in QApplicationPrivate::notify_helper (this=0x9a31538, receiver=0x9c97a40, e=0xbfa7c188) at kernel/qapplication.cpp:4080
#30 0xb5d68b11 in QApplication::notify (this=0xbfa7cad4, receiver=0x9c97a40, e=0xbfa7c188) at kernel/qapplication.cpp:3786
#31 0xb6983e0d in KApplication::notify (this=0xbfa7cad4, receiver=0x9c97a40, event=0xbfa7c188) at /build/buildd/kde4libs-4.2.4/kdeui/kernel/kapplication.cpp:307
#32 0xb5890a3b in QCoreApplication::notifyInternal (this=0xbfa7cad4, receiver=0x9c97a40, event=0xbfa7c188) at kernel/qcoreapplication.cpp:602
#33 0xb5d67b7e in QApplicationPrivate::sendMouseEvent (receiver=0x9c97a40, event=0xbfa7c188, alienWidget=0x9c97a40, nativeWidget=0x9b99598, buttonDown=0xb660a200, lastMouseReceiver=@0xb660a204)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#34 0xb5dd797e in QETWidget::translateMouseEvent (this=0x9b99598, event=0xbfa7c7cc) at kernel/qapplication_x11.cpp:4425
#35 0xb5dd6ca7 in QApplication::x11ProcessEvent (this=0xbfa7cad4, event=0xbfa7c7cc) at kernel/qapplication_x11.cpp:3421
#36 0xb5e01c6a in x11EventSourceDispatch (s=0x9a342a0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#37 0xb4b66b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#38 0xb4b6a0eb in ?? () from /usr/lib/libglib-2.0.so.0
#39 0xb4b6a268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#40 0xb58bc438 in QEventDispatcherGlib::processEvents (this=0x9a1d5b8, flags={i = -1079522936}) at kernel/qeventdispatcher_glib.cpp:323
#41 0xb5e01365 in QGuiEventDispatcherGlib::processEvents (this=0x9a1d5b8, flags={i = -1079522888}) at kernel/qguieventdispatcher_glib.cpp:202
#42 0xb588f06a in QEventLoop::processEvents (this=0xbfa7ca30, flags={i = -1079522824}) at kernel/qeventloop.cpp:149
#43 0xb588f4aa in QEventLoop::exec (this=0xbfa7ca30, flags={i = -1079522760}) at kernel/qeventloop.cpp:200
#44 0xb5891959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#45 0xb5d5fd17 in QApplication::exec () at kernel/qapplication.cpp:3553
#46 0x082b4e3b in main (argc=1, argv=0xbfa7cd34) at /build/buildd/digikam-0.10.0/digikam/main.cpp:190
Comment 1 caulier.gilles 2009-10-07 11:37:59 UTC
I think it have been fixed in current implementation from svn. Please try again with digiKam 1.0.0-beta5

Gilles Caulier
Comment 2 Andreas Bank 2009-10-07 12:08:19 UTC
Hi Gilles,


thanks for the quick reply.
I'll check the latest version today.

By the way, I allways wanted to say thanks to you for this great peace of 
Software!
I really love Digikam!

All the best.

Andi


Am Mittwoch, 7. Oktober 2009 11:38:05 schrieb Gilles Caulier:
> https://bugs.kde.org/show_bug.cgi?id=209729
>
>
> Gilles Caulier <caulier.gilles@gmail.com> changed:
>
>            What    |Removed                     |Added
> ---------------------------------------------------------------------------
>- CC|                            |caulier.gilles@gmail.com
>
>
>
>
> --- Comment #1 from Gilles Caulier <caulier gilles gmail com>  2009-10-07
> 11:37:59 --- I think it have been fixed in current implementation from svn.
> Please try again with digiKam 1.0.0-beta5
>
> Gilles Caulier
Comment 3 Dario Andres 2009-10-09 01:22:23 UTC
- Are you using Desktop Effects / Compositing ? There are know Qt drag&drop bugs while alt-tabbing which could trigger such a crash 
Thanks
Comment 4 caulier.gilles 2009-12-25 20:07:28 UTC
digiKam 1.0.0 is out since few days...

http://www.digikam.org/drupal/node/491

Please try with this version coming with more than 400 bug-fixes.

Thanks in advance

Gilles Caulier
Comment 5 caulier.gilles 2010-01-25 21:49:38 UTC
digiKam 1.1. release will be done in few days. Please check if this entry still valid.

Thanks in advance

Gilles Caulier
Comment 6 caulier.gilles 2010-04-04 10:44:03 UTC
digiKam and Kipi-plugins 1.2.0 are out. Please check if crash is still valid there.

Thanks in advance

Gilles Caulier
Comment 7 Jonathan Verner 2010-09-07 15:09:55 UTC
I can reproduce it with digikam 1.4.0 and KDE 4.5.1. When doing drag-and-drop to inkscape (possibly also other apps, not tested) AND using Alt-Tab, digikam crashes when I release the Alt-Tab key with the backtrace shown below. When doing just drag-and-drop without the Alt-Tab switching, everything works fine.
Also, when I disable desktop effects, everything works fine, which would seem to indicate a qt bug (see comment #3)

This is the output from digikam:

xdndHandleBadwindow returned true
QSocketNotifier: Invalid socket 36 and type 'Read', disabling...
QSocketNotifier: Invalid socket 39 and type 'Read', disabling...
QSocketNotifier: Invalid socket 42 and type 'Read', disabling...

This is the backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0xb65b6740 (LWP 7801))]

Thread 15 (Thread 0xb4476b70 (LWP 7802)):
#0  0x00b90422 in __kernel_vsyscall ()
#1  0x00ad1015 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x0199db07 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0x08332054 in ?? ()
#4  0x0199cf39 in ?? () from /usr/lib/libQtCore.so.4
#5  0x00acc96e in start_thread (arg=0xb4476b70) at pthread_create.c:300
#6  0x01d94a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 14 (Thread 0xb3c75b70 (LWP 7806)):
#0  0x03c4292d in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0x03c42c99 in ?? () from /lib/libglib-2.0.so.0
#2  0x03c43268 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x01acc82f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x01a9ca99 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x01a9cf1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x01999c5e in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x0042ef1d in ?? () from /usr/lib/libdigikamdatabase.so.1
#8  0x0199cf39 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00acc96e in start_thread (arg=0xb3c75b70) at pthread_create.c:300
#10 0x01d94a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 13 (Thread 0xb3474b70 (LWP 7807)):
#0  0x00acef5b in __pthread_mutex_lock (mutex=0x8869404) at pthread_mutex_lock.c:61
#1  0x03c4324e in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0x01acc82f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#3  0x01a9ca99 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x01a9cf1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x01999c5e in QThread::exec() () from /usr/lib/libQtCore.so.4
#6  0x0042ef1d in ?? () from /usr/lib/libdigikamdatabase.so.1
#7  0x0199cf39 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00acc96e in start_thread (arg=0xb3474b70) at pthread_create.c:300
#9  0x01d94a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 12 (Thread 0xb1cd3b70 (LWP 7808)):
#0  0x00b90422 in __kernel_vsyscall ()
#1  0x00ad1015 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x0199db07 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0x014bd3ba in ?? () from /usr/lib/libdigikamcore.so.1
#4  0x0199cf39 in ?? () from /usr/lib/libQtCore.so.4
#5  0x00acc96e in start_thread (arg=0xb1cd3b70) at pthread_create.c:300
#6  0x01d94a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 11 (Thread 0xb14d2b70 (LWP 7809)):
#0  0x00ad0344 in __pthread_mutex_unlock_usercnt (mutex=0x8a66f7c, decr=<value optimized out>) at pthread_mutex_unlock.c:52
#1  0x03c42544 in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0x03c42e7e in ?? () from /lib/libglib-2.0.so.0
#3  0x03c43268 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x01acc82f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x01a9ca99 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x01a9cf1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x01999c5e in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0x0199cf39 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00acc96e in start_thread (arg=0xb14d2b70) at pthread_create.c:300
#10 0x01d94a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 10 (Thread 0xb0cd1b70 (LWP 7810)):
#0  __pthread_mutex_unlock (mutex=0x882b374) at pthread_mutex_unlock.c:289
#1  0x03c42868 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#2  0x03c42c99 in ?? () from /lib/libglib-2.0.so.0
#3  0x03c43268 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x01acc82f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x01a9ca99 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x01a9cf1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x01999c5e in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0x0199cf39 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00acc96e in start_thread (arg=0xb0cd1b70) at pthread_create.c:300
#10 0x01d94a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 9 (Thread 0xadcaeb70 (LWP 7812)):
#0  0x00b90422 in __kernel_vsyscall ()
#1  0x00ad1342 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:179
#2  0x08516ce7 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 8 (Thread 0xad0a2b70 (LWP 7813)):
#0  0x00b90422 in __kernel_vsyscall ()
#1  0x01d8d971 in select () at ../sysdeps/unix/syscall-template.S:82
#2  0x085405cc in xine_usec_sleep () from /usr/lib/libxine.so.1
#3  0x00000000 in ?? ()

Thread 7 (Thread 0xac8a1b70 (LWP 7814)):
#0  0x00b90422 in __kernel_vsyscall ()
#1  0x01d86b86 in *__GI___poll (fds=0x1e1cff4, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x03c504db in g_poll () from /lib/libglib-2.0.so.0
#3  0x03c42e5c in ?? () from /lib/libglib-2.0.so.0
#4  0x03c43268 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x01acc82f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x01a9ca99 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x01a9cf1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x01999c5e in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x0340d81a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#10 0x0199cf39 in ?? () from /usr/lib/libQtCore.so.4
#11 0x00acc96e in start_thread (arg=0xac8a1b70) at pthread_create.c:300
#12 0x01d94a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 6 (Thread 0xac0a0b70 (LWP 7817)):
#0  0x00b90422 in __kernel_vsyscall ()
#1  0x01d86b86 in *__GI___poll (fds=0x1e1cff4, nfds=1, timeout=333) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x0399aa8f in ?? () from /usr/lib/xine/plugins/1.27/xineplug_ao_out_alsa.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 5 (Thread 0xab89fb70 (LWP 7818)):
#0  0x00b90422 in __kernel_vsyscall ()
#1  0x00ad1015 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x085279ee in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xab09eb70 (LWP 7819)):
#0  0x01243e16 in *__GI_clock_gettime (clock_id=19169268, tp=0xab09df60) at ../sysdeps/unix/clock_gettime.c:100
#1  0x019f848b in ?? () from /usr/lib/libQtCore.so.4
#2  0x01ace965 in ?? () from /usr/lib/libQtCore.so.4
#3  0x01ace9aa in ?? () from /usr/lib/libQtCore.so.4
#4  0x01acca38 in ?? () from /usr/lib/libQtCore.so.4
#5  0x01accac5 in ?? () from /usr/lib/libQtCore.so.4
#6  0x03c4287a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x03c42c99 in ?? () from /lib/libglib-2.0.so.0
#8  0x03c43268 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x01acc82f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0x01a9ca99 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0x01a9cf1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#12 0x01999c5e in QThread::exec() () from /usr/lib/libQtCore.so.4
#13 0x01a7b9ab in ?? () from /usr/lib/libQtCore.so.4
#14 0x0199cf39 in ?? () from /usr/lib/libQtCore.so.4
#15 0x00acc96e in start_thread (arg=0xab09eb70) at pthread_create.c:300
#16 0x01d94a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xaa7bdb70 (LWP 7826)):
#0  __i686.get_pc_thunk.bx () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/sem_post.S:170
#1  0x00ad0319 in __pthread_mutex_unlock_usercnt (mutex=0xa50d0ac, decr=1) at pthread_mutex_unlock.c:36
#2  0x03c42544 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x03c42e7e in ?? () from /lib/libglib-2.0.so.0
#4  0x03c43268 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x01acc82f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x01a9ca99 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x01a9cf1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x01999c5e in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x01a7b9ab in ?? () from /usr/lib/libQtCore.so.4
#10 0x0199cf39 in ?? () from /usr/lib/libQtCore.so.4
#11 0x00acc96e in start_thread (arg=0xaa7bdb70) at pthread_create.c:300
#12 0x01d94a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xa9fbcb70 (LWP 7836)):
#0  0x00b90422 in __kernel_vsyscall ()
#1  0x01d86b86 in *__GI___poll (fds=0x1e1cff4, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x03c504db in g_poll () from /lib/libglib-2.0.so.0
#3  0x03c42e5c in ?? () from /lib/libglib-2.0.so.0
#4  0x03c43268 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x01acc82f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x01a9ca99 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x01a9cf1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x01999c5e in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x01a7b9ab in ?? () from /usr/lib/libQtCore.so.4
#10 0x0199cf39 in ?? () from /usr/lib/libQtCore.so.4
#11 0x00acc96e in start_thread (arg=0xa9fbcb70) at pthread_create.c:300
#12 0x01d94a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb65b6740 (LWP 7801)):
[KCrash Handler]
#7  0x022d206f in QWidget::testAttribute_helper(Qt::WidgetAttribute) const () from /usr/lib/libQtGui.so.4
#8  0x043b5a9a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#9  0x01a9dfeb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#10 0x02286812 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#11 0x023150d8 in ?? () from /usr/lib/libQtGui.so.4
#12 0x02314569 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#13 0x0234356a in ?? () from /usr/lib/libQtGui.so.4
#14 0x03c3f265 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#15 0x03c43088 in ?? () from /lib/libglib-2.0.so.0
#16 0x03c43268 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#17 0x01acc7f5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#18 0x02342de5 in ?? () from /usr/lib/libQtGui.so.4
#19 0x01a9ca99 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#20 0x01a9cf1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#21 0x02328887 in ?? () from /usr/lib/libQtGui.so.4
#22 0x022993ee in QDrag::exec(QFlags<Qt::DropAction>, Qt::DropAction) () from /usr/lib/libQtGui.so.4
#23 0x014d27a2 in Digikam::DCategorizedView::startDrag(QFlags<Qt::DropAction>) () from /usr/lib/libdigikamcore.so.1
#24 0x02852bca in QAbstractItemView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#25 0x0286ceda in QListView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#26 0x01500af9 in KCategorizedView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libdigikamcore.so.1
#27 0x014cf5b7 in Digikam::DCategorizedView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libdigikamcore.so.1
#28 0x022df1aa in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#29 0x026fefb3 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#30 0x0279be42 in QAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#31 0x02857957 in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#32 0x014d23ad in Digikam::DCategorizedView::viewportEvent(QEvent*) () from /usr/lib/libdigikamcore.so.1
#33 0x0279e885 in ?? () from /usr/lib/libQtGui.so.4
#34 0x01a9d74a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#35 0x02281759 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#36 0x02288167 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#37 0x043b5a9a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#38 0x01a9dfeb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#39 0x02286812 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#40 0x023150d8 in ?? () from /usr/lib/libQtGui.so.4
#41 0x02314569 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#42 0x0234356a in ?? () from /usr/lib/libQtGui.so.4
#43 0x03c3f265 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#44 0x03c43088 in ?? () from /lib/libglib-2.0.so.0
#45 0x03c43268 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#46 0x01acc7f5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#47 0x02342de5 in ?? () from /usr/lib/libQtGui.so.4
#48 0x01a9ca99 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#49 0x01a9cf1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#50 0x01aa14cf in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#51 0x022805a7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#52 0x083bfa13 in ?? ()
#53 0x01cddbd6 in __libc_start_main (main=0x83bc840, argc=1, ubp_av=0xbfc7a364, init=0x83c1cb0 <__libc_csu_init>, fini=0x83c1ca0 <__libc_csu_fini>, rtld_fini=0x6990c0 <_dl_fini>, 
    stack_end=0xbfc7a35c) at libc-start.c:226
#54 0x080aa1b1 in _start ()
Comment 8 Marcel Wiesweg 2010-09-24 10:53:40 UTC
*** Bug 252189 has been marked as a duplicate of this bug. ***
Comment 9 caulier.gilles 2010-11-24 09:06:51 UTC
digiKam 1.6.0 is out:

http://www.digikam.org/drupal/node/550

Please update and check if this entry still valid.

Thanks in advance

Gilles Caulier
Comment 10 Javier Conti 2010-12-05 14:07:47 UTC
Created attachment 54157 [details]
New crash information added by DrKonqi

digikam (1.5.0) on KDE Platform 4.5.4 (KDE 4.5.4) "release 3" using Qt 4.6.3

- What I was doing when the application crashed:

I dragged a picture, pressed ALT+TAB bringing kflickr on top, then dropped the picture into it. Quite often, but not always, digikam crashes.

-- Backtrace (Reduced):
#6  0x00007f51663d3dbf in QWidget::testAttribute_helper (this=0x1764cf0, attribute=Qt::WA_Hover) at kernel/qwidget.cpp:10580
#7  0x00007f516639b40f in testAttribute (this=<value optimized out>, receiver=0x1764cf0, e=0x7fff49cffe70) at ../../src/gui/kernel/qwidget.h:1026
#8  QApplication::notify (this=<value optimized out>, receiver=0x1764cf0, e=0x7fff49cffe70) at kernel/qapplication.cpp:3889
#9  0x00007f5167b3c816 in KApplication::notify (this=0x7fff49d02dd0, receiver=0x1764cf0, event=0x7fff49cffe70) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#10 0x00007f5167216e4c in QCoreApplication::notifyInternal (this=0x7fff49d02dd0, receiver=0x1764cf0, event=0x7fff49cffe70) at kernel/qcoreapplication.cpp:726
Comment 11 Jonathan Verner 2010-12-15 12:37:24 UTC
When I have time, will try to compile digiKam 1.6 and test it.

(In reply to comment #9)
> digiKam 1.6.0 is out:
> 
> http://www.digikam.org/drupal/node/550
> 
> Please update and check if this entry still valid.
> 
> Thanks in advance
> 
> Gilles Caulier
Comment 12 Marcel Wiesweg 2011-01-18 14:18:05 UTC
There are similar reports all over KDE. Seems to be a Qt bug really.

*** This bug has been marked as a duplicate of bug 192270 ***
Comment 13 caulier.gilles 2019-08-14 18:52:48 UTC
Fixed with bug #192270