Bug 209251 - plasma crashed when moving files
Summary: plasma crashed when moving files
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-02 22:58 UTC by Piotr Mitas
Modified: 2009-10-03 21:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Mitas 2009-10-02 22:58:36 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-gentoo-r1 x86_64

What I was doing when the application crashed:
Plasma crashed when I was moving a directory from the desktop to other partition.

 -- Backtrace:
Application: Przestrzeń robocza Plazmy (kdeinit4), signal: Segmentation fault
[Current thread is 0 (LWP 1971)]

Thread 2 (Thread 0x7f82171b0910 (LWP 1974)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f8235051dbb in QWaitCondition::wait (this=<value optimized out>, mutex=0x18940b8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  0x00007f8233c72da4 in QHostInfoAgent::run (this=0x18940a0) at kernel/qhostinfo.cpp:260
#3  0x00007f8235050783 in QThreadPrivate::start (arg=<value optimized out>) at thread/qthread_unix.cpp:188
#4  0x00007f8234ddb624 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#5  0x00007f82319d656d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8235617750 (LWP 1971)):
[KCrash Handler]
#5  0x00007f823403d183 in KFileItem::isDir (this=0x18722e0) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kio/kio/kfileitem.cpp:969
#6  0x00007f823402ae18 in KDirModelPrivate::removeFromNodeHash (this=0x2110430, node=0x18722e0, url=@0x7fffd28eab10)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kio/kio/kdirmodel.cpp:200
#7  0x00007f823402bd29 in KDirModelPrivate::_k_slotDeleteItems (this=0x2110430, items=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kio/kio/kdirmodel.cpp:487
#8  0x00007f823402d802 in KDirModel::qt_metacall (this=0x2058c40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd28ead00)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1_build/kio/kdirmodel.moc:83
#9  0x00007f8235173e14 in QMetaObject::activate (sender=<value optimized out>, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3101
#10 0x00007f8234011555 in KDirLister::itemsDeleted (this=0x18722e0, _t1=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1_build/kio/kdirlister.moc:289
#11 0x00007f8234012291 in KDirLister::Private::emitItemsDeleted (this=0x1b11310, _items=<value optimized out>)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kio/kio/kdirlister.cpp:2351
#12 0x00007f823402123e in KDirListerCache::itemsDeleted (this=0x15f2300, listers=<value optimized out>, deletedItems=@0x240e908)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kio/kio/kdirlister.cpp:1697
#13 0x00007f8234022c7a in KDirListerCache::slotFilesRemoved (this=0x15f2300, fileList=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kio/kio/kdirlister.cpp:808
#14 0x00007f8234023104 in KDirListerCache::slotFilesRemoved (this=0x15f2300, fileList=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kio/kio/kdirlister.cpp:763
#15 0x00007f8234023a60 in KDirListerCache::qt_metacall (this=0x15f2300, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd28eb190)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1_build/kio/kdirlister_p.moc:92
#16 0x00007f8235173e14 in QMetaObject::activate (sender=<value optimized out>, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3101
#17 0x00007f823402ed95 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x18722e0, _t1=<value optimized out>)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1_build/kio/kdirnotify.moc:125
#18 0x00007f823402ef10 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x15f23e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd28eb270)
    at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1_build/kio/kdirnotify.moc:83
#19 0x00007f82331494f0 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=<value optimized out>, 
    slotIdx=<value optimized out>) at qdbusintegrator.cpp:891
#20 0x00007f823314f0cf in QDBusCallDeliveryEvent::placeMetaCall (this=0x0, object=0x18722e0) at qdbusintegrator_p.h:101
#21 0x00007f8235175339 in QObject::event (this=0x15f23e0, e=0x2263d60) at kernel/qobject.cpp:1099
#22 0x00007f82325a328c in QApplicationPrivate::notify_helper (this=0x14c1c80, receiver=0x15f23e0, e=0x2263d60) at kernel/qapplication.cpp:4056
#23 0x00007f82325a8b38 in QApplication::notify (this=0x14b7aa0, receiver=0x15f23e0, e=0x2263d60) at kernel/qapplication.cpp:4021
#24 0x00007f82335a7656 in KApplication::notify (this=0x14b7aa0, receiver=0x15f23e0, event=0x2263d60) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#25 0x00007f8235160dbb in QCoreApplication::notifyInternal (this=0x14b7aa0, receiver=0x15f23e0, event=0x2263d60) at kernel/qcoreapplication.cpp:606
#26 0x00007f8235163ea7 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x142ff80) at kernel/qcoreapplication.h:213
#27 0x00007f823518cec3 in postEventSourceDispatch (s=<value optimized out>) at kernel/qcoreapplication.h:218
#28 0x00007f823103db2d in IA__g_main_context_dispatch (context=0x14c4120) at gmain.c:1824
#29 0x00007f82310412d8 in g_main_context_iterate (context=0x14c4120, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2455
#30 0x00007f8231041400 in IA__g_main_context_iteration (context=0x14c4120, may_block=1) at gmain.c:2518
#31 0x00007f823518cb46 in QEventDispatcherGlib::processEvents (this=0x1432850, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#32 0x00007f823262821e in QGuiEventDispatcherGlib::processEvents (this=0x18722e0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#33 0x00007f823515fa12 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#34 0x00007f823515fe9e in QEventLoop::exec (this=0x7fffd28ebd00, flags=) at kernel/qeventloop.cpp:197
#35 0x00007f82351641fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#36 0x00007f8228ecc2df in kdemain (argc=<value optimized out>, argv=<value optimized out>)
    at /var/tmp/portage/kde-base/plasma-workspace-4.3.1/work/plasma-workspace-4.3.1/plasma/shells/desktop/main.cpp:50
#37 0x0000000000407195 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a5dd "0") at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kinit/kinit.cpp:677
#38 0x0000000000407e50 in handle_launcher_request (sock=8, who=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kinit/kinit.cpp:1169
#39 0x00000000004082d1 in handle_requests (waitForPid=6342240) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kinit/kinit.cpp:1362
#40 0x0000000000408f21 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-03 19:08:13 UTC
- Does Plasma crash again if you try to repeat the action ?
- Does Dolphin/Konqueror crash if you repeat the action ?
Thanks
Comment 2 Dario Andres 2009-10-03 21:09:13 UTC
Merging with bug 196695. Thanks

*** This bug has been marked as a duplicate of bug 196695 ***