Bug 209188 - Sending files with umlauts in the filename to an MTP device fails.
Summary: Sending files with umlauts in the filename to an MTP device fails.
Status: RESOLVED NOT A BUG
Alias: None
Product: amarok
Classification: Applications
Component: Collections/MTP player (show other bugs)
Version: 2.3-GIT
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-02 10:37 UTC by Andreas Scheck
Modified: 2011-12-20 11:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Scheck 2009-10-02 10:37:33 UTC
Version:           2.2.0 (using Devel)
OS:                Linux
Installed from:    Compiled sources

A file with an umlaut (ä,ö, ...) in the filename cannot be send to an attached MTP device. 

Example: 
- the file "testa.mp3" can be send without problem to the device
- the file "testä.mp3" (only filename changed) cannot be send to the device; on the console the follwing message is displayed:

LIBMTP_Send_Track_From_File(): Could not open source file "/home/andreas/media/mp3/testä.mp3"

The file "testä.mp3" is played without problems by amarok.

(the MP3 device is an Philips GoGear, SA6014/02)
Comment 1 Mikko C. 2009-10-02 12:11:14 UTC
does it work with other apps, such as gnomad? If not, please fill a bug to libmtp.
Comment 2 Andreas Scheck 2009-10-02 15:25:24 UTC
My test with gnomad2 2.9.1 is not conclusive. In fact, only the file without umlauts in the filename can be transfered. Still, gnomad has a more general problem with mp3 files that have umlauts in the file name. The "Music transfer" tab shows for the file "testa.mp3" the "Arist" and the "Title" tags correctly. After renaming the file to "testä.mp3" the "Artits" changes to "Media" and the "Title" to "Testä". Additionally, the  length is shown as "0:00" ("testa.mp3": 3:22). 

Is there another application that uses libmtp to send files to an MTP device?
Comment 3 Mikko C. 2009-10-02 15:28:59 UTC
you can use direct mtp commands. I guess mtp-sendtr will do.
Just type mtp- [TAB] to see them all.
Comment 4 Andreas Scheck 2009-10-02 16:07:52 UTC
Using "mtp-sendtr" I was able to transfer a file with umlauts to the MTP device. 

The commands

mtp-sendtr testa.mp3 testa.mp3
mtp-sendtr testä.mp3 testä.mp3

both work, and the resulting tracks appear to be identical on the device (same length, same sound, etc.).
Comment 5 Alejandro Wainzinger 2009-11-19 01:57:31 UTC
I have tested this on a Samsung YP-K3 MTP device with "Liebe ist für alle da" and it worked perfectly.  The output you posted would indicate that there's a bug in the way Amarok is handling filenames for MTP transfers, but the file I was able to send was at:

/home/me/Music/Rammstein - Liebe Ist Für Alle Da [Deluxe Edition] [2009]/09  Rammstein - Liebe Ist Für Alle Da.mp3

As you can see there is an umlaut in the filename.  I am unsure what could be causing this since I can't reproduce it, but will investigate.
Comment 6 Myriam Schweingruber 2009-12-17 17:16:19 UTC
Any news on this? 
Is this still valid for a current Amarok version, be this 2.2.1  2.2.2 beta or 2.2-git?
Does this behavior change with a somewhat newer libmtp version? Current seem to be 1.0.1
Comment 7 Andreas Scheck 2009-12-19 11:00:02 UTC
Some time ago I tested my device with Amarok version 2.2.1, the result was the same initially reported, i.e. the bug was still present.

Right now, a friend of mine is using the player, but next week I will be able to test if the situation has changed in "2.2.2 beta".

Apparently, I made a mistake when submitting the bug report. Actually, I am using a Debian system (mixture of stable/testing/...) and did not build Amarok using the sources. Therefore, I'm not sure if I can provide information regarding "2.2-git". Still, I might find some free time during the upcoming holidays and give it a try. 

The "new" version of libmtp (1.0.1) did not appear in Debian, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=560098. Therefore, I build a version from the sources but I am not sure how to make Amarok use it. Is it enough to do something like

LD_LIBRARY_PATH=/usr/local/lib amarok

or do I have to rebuild Amarok as well?
Comment 8 Myriam Schweingruber 2009-12-19 12:40:43 UTC
Andreas, don't worry, we are testing it with a newer version already. This was more a reminder to set a correct version.
I can confirm this still exists in 2.2-git.
Comment 9 Myriam Schweingruber 2011-09-26 15:23:57 UTC
Is this still valid with Amarok 2.4.3 or current git? I don't have a media player around to test. It copies correctly to an external USB disk for me in current git.
Comment 10 Myriam Schweingruber 2011-11-07 11:56:22 UTC
Closing for lack of feedback. Feel free to reopen if this is still valid with the latest git build