Bug 209096 - Compositing makes screen flash with Firefox on fullscreen
Summary: Compositing makes screen flash with Firefox on fullscreen
Status: RESOLVED DUPLICATE of bug 177495
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-01 14:07 UTC by André Neves
Modified: 2009-10-01 14:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description André Neves 2009-10-01 14:07:35 UTC
Version:           unknown (using 4.3.1 (KDE 4.3.1), Debian packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.30-1-amd64

When Compositing is enabled and Firefox is fullscreen, many actions cause the screen to blink black. Some of them are:

* displaying a tooltip (mouseover, like xkcd.com)
* clicking on a dropdown-list control (like the Severity picker)
* exiting fullscreen (by pressing F11 again)
* activating address bar search (writing anything on the address bar)
* pressing Alt+F3

Both application fullscreen (F11) and kwin fullscreen (Alt+F3 > Advanced > Fullscreen) cause these.

When Compositing is disabled, none of these happen.
Comment 1 Martin Flöser 2009-10-01 14:09:29 UTC

*** This bug has been marked as a duplicate of bug 177495 ***