Bug 208688 - kompare fails to diff "mysqldump --no-data" dump files
Summary: kompare fails to diff "mysqldump --no-data" dump files
Status: RESOLVED FIXED
Alias: None
Product: kompare
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kompare developers
URL:
Keywords:
: 204253 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-27 13:46 UTC by Steve McInerney
Modified: 2009-09-28 02:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve McInerney 2009-09-27 13:46:04 UTC
Version:           3.5.4 (using KDE 4.2.4)
OS:                Linux
Installed from:    Ubuntu Packages

"Error. Could not parse diff output" when run from the cmd line, or opening the two files manually from the app already open.
'diff -u' works fine; as does kdiff3 (which I've fallen back to use in this case)

Grab two mysql dump files using the '--no-data', such that you only get the create table etc statements; want the diff to compare OLD version of DB, with new version of DB.

Sample extract from the full files that shows the problem:
File 1:
-- MySQL dump 10.11
--
-- Host: grokdb    Database: groklaw
-- ------------------------------------------------------
-- Server version       5.0.45-community-log

File 2:
-- MySQL dump 10.11
--
-- Host: localhost    Database: gl_new
-- ------------------------------------------------------
-- Server version       5.0.84
Comment 1 Jeff Snyder 2009-09-27 14:23:27 UTC
Confirming.
The diff output will have lines that start with "---" in the content, it's probably tripping up on them. 3_way_kompare branch doesn't have the same problem, i'll try to see why.
Comment 2 Jeff Snyder 2009-09-27 15:05:49 UTC
SVN commit 1028512 by je4d:

Revert the fix for bug 139209 - the fix used caused bug 208688. 139209 needs to be fixed by counting lines instead.
BUG:208688
CCBUG:139209


 M  +1 -3      parserbase.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1028512
Comment 3 Kevin Kofler 2009-09-27 15:10:49 UTC
This is actually a duplicate of bug 204253. It's the "--" at the beginning of lines which confuses Kompare. (This also breaks diffing Haskell source files with their -- comments, by the way.) There's a proposed patch there, which AFAICT implements exactly this "counting lines" feature. We should look at that one, as it should allow fixing both bug 139209 and this one.
Comment 4 Kevin Kofler 2009-09-27 15:44:00 UTC
*** Bug 204253 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Kofler 2009-09-27 15:44:38 UTC
We're using the fix from https://bugs.kde.org/show_bug.cgi?id=204253#c4 (which actually counts diff lines) now.
Comment 6 Kevin Kofler 2009-09-28 02:27:02 UTC
SVN commit 1028719 by kkofler:

Revert the fix for bug 139209 - the fix used caused bug 208688. 139209 needs to be fixed by counting lines instead.
CCBUG:208688
CCBUG:139209

backport revision 1028512 by je4d from trunk

 M  +1 -3      parserbase.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1028719