Bug 207880 - amarok2: support for compilations on ipod does not work
Summary: amarok2: support for compilations on ipod does not work
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/iPod iPhone (show other bugs)
Version: 2.4-GIT
Platform: openSUSE RPMs Linux
: NOR normal with 100 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-19 13:23 UTC by Egbert König
Modified: 2011-12-20 11:05 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments
a patch for current git version. (12.39 KB, patch)
2010-11-16 17:28 UTC, Albert Farres
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egbert König 2009-09-19 13:23:42 UTC
Version:           2.1.85 (using KDE 4.3.1)
OS:                Linux
Installed from:    SuSE RPMs

If I transfer my collection with Amarok2 to my ipod, collections (various artists) are not recognized (and shown) as "compilations" on the ipod. This is working with Amarok 1.4.

How to reproduce: transfer a compilation (various artists) to the ipod, that has been recognized by amarok (in the German version these albums are shown under "Verschiedene Interpreten". The ipod will not show it under Music/Compilations. My ipod is an ipod classic 120 GB.

Expected behaviour: compilations should be shown under Music/Compilations on the ipod.
Comment 1 Myriam Schweingruber 2009-12-08 12:02:29 UTC
Is this still valid with Amarok 2.2.1?
Comment 2 johnhalton 2010-01-03 14:39:24 UTC
This is still happening on 2.2.2 beta 1 (version in Debian Experimental) with iPod Classic 80 GB.
Comment 3 Myriam Schweingruber 2010-01-04 17:47:43 UTC
Thank you for the feeback.
Comment 4 Myriam Schweingruber 2010-02-07 14:47:54 UTC
Is this still valid in Amarok 2.2.2 or current git?
Comment 5 johnhalton 2010-02-07 16:58:07 UTC
Confirmed as still applying in version 2.2.2 in Debian Unstable.
Comment 6 Myriam Schweingruber 2010-02-07 17:51:12 UTC
Thank you for your feedback.
Comment 7 Hakan Bayindir 2010-03-29 15:52:13 UTC
This bug still exists in amarok 2.3.0 and can be reliably reproduced with an iPod nano 2G 8GB
Comment 8 Fabian Lesniak 2010-05-16 14:02:37 UTC
Bug does still exist in 2.3.1 beta 1, reproducable.
Comment 9 kinto 2010-06-19 12:19:31 UTC
I can confirm this on Amarok 2.3.1 on Kubuntu 10.04. I think that the developers know of this shortcoming of amarok in managing ipods but it would be nice to here something about any plans to address it.
Comment 10 Hakan Bayindir 2010-06-19 20:24:00 UTC
It was working on 1.4.x. I think since it was possible on 1.4.x, There's no reason for not implementing it on 2.x. In other words it's a regression, not a missing feature and will surely be fixed.
Comment 11 Christophe Fergeau 2010-08-10 10:51:39 UTC
The ipod plugin should set Itdb_Track::compilation for compilations.
Comment 12 Albert Farres 2010-11-16 17:28:00 UTC
Created attachment 53468 [details]
a patch for current git version.
Comment 13 Myriam Schweingruber 2010-11-16 23:07:42 UTC
Thank you for the patch, Albert. Please register at http://identity.kde.org and
submit your patch with reference to this report in http://git.reviewboard.kde.org
Comment 14 Timothy Lanzi 2011-01-04 03:39:32 UTC
Amarok 2.4-GIT, kubuntu 10.10. Bug is still present. Songs recognized by Amarok under various artists are not transferred to music/compilations on iPod (2g nano). The songs are transferred to the music/ various artists folder.
Comment 15 Myriam Schweingruber 2011-01-05 00:49:23 UTC
Thanks for testing, changing version.
Comment 16 muzius 2011-05-14 22:55:23 UTC
Bug still exists in 2.4.1 (Kubuntu 11.04 PPA - IPod Video 30Gb) .. 
I'm wondering if this issue got lost somewhere since a tiny patch was submitted about half a year ago, which was reviewed as well (https://git.reviewboard.kde.org/r/100156/)
don't want to offend anyone, but this issue keeps me from giving amarok2 a descent try for ages, since I use compilations on my iPod quite a lot
Comment 17 Myriam Schweingruber 2011-05-15 01:16:29 UTC
That patch was committed about 4 weeks ago, so apparently it didn't solve the issue.
Comment 18 muzius 2011-05-15 11:02:52 UTC
the patch did work for me! by looking at the git-sources, it definitely never got committed to trunk though. dont know what the right procedure to reopen this issue would be (maybe changing the status on the reviewboard) ?
Comment 19 jmpablos 2011-09-18 08:28:45 UTC
It seems that the status has been changed to NEW.

This is the only bug which I need to be solved to use definitely Amarok 2 instead of Amarok 1.4.

Thanks to Amarok's developers.
Comment 20 Myriam Schweingruber 2011-09-18 19:45:32 UTC
The status NEW just means that the bug is confirmed, nothing else.
Comment 21 Matěj Laitl 2011-10-20 12:56:15 UTC
Hi, I will take care of integrating the patch into Amarok, please be patient.
Comment 22 muzius 2011-10-20 16:29:25 UTC
used the patch from #12 on a GIT-Version of 2.4. early this year and it works like a charm .. but I haven't upgraded amarok since patching/compiling because of the additional work to get the patch back in - doesn't make much sense if not done upstream

would be great to see this issue finally getting resolved, huge thanks in advance Matěj !!!
Comment 23 Matěj Laitl 2011-10-25 20:36:57 UTC
Git commit 960304b1d4918342c323f0baa4955cca3113cd77 by Matěj Laitl, on behalf of Albert Farres.
Committed on 16/11/2010 at 17:05.
Pushed by laitl into branch 'master'.

iPod handler, MediaDeviceCollection: support for compilations

Compilation albums are now shown under Various Artists item on iPod
devices. Transferring music from/to iPod retains compilation
attribute.

FEATURE: 207880
FIXED-IN: 2.5
REVIEWBOARD: 102966

M  +2    -0    ChangeLog
M  +14   -0    src/core-impl/collections/ipodcollection/handler/IpodHandler.cpp
M  +2    -0    src/core-impl/collections/ipodcollection/handler/IpodHandler.h
M  +6    -0    src/core-impl/collections/ipodcollection/handler/capabilities/IpodReadCapability.cpp
M  +2    -1    src/core-impl/collections/ipodcollection/handler/capabilities/IpodReadCapability.h
M  +6    -0    src/core-impl/collections/ipodcollection/handler/capabilities/IpodWriteCapability.cpp
M  +1    -0    src/core-impl/collections/ipodcollection/handler/capabilities/IpodWriteCapability.h
M  +14   -5    src/core-impl/collections/mediadevicecollection/handler/MediaDeviceHandler.cpp
M  +1    -0    src/core-impl/collections/mediadevicecollection/handler/capabilities/ReadCapability.cpp
M  +2    -1    src/core-impl/collections/mediadevicecollection/handler/capabilities/ReadCapability.h
M  +1    -0    src/core-impl/collections/mediadevicecollection/handler/capabilities/WriteCapability.h

http://commits.kde.org/amarok/960304b1d4918342c323f0baa4955cca3113cd77