Bug 207676 - cannot fetch missing covers
Summary: cannot fetch missing covers
Status: RESOLVED DUPLICATE of bug 205032
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.1.80
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-17 13:00 UTC by Vadym Krevs
Modified: 2009-09-17 13:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vadym Krevs 2009-09-17 13:00:55 UTC
Version:           2.1.80 (using 4.3.1 (KDE 4.3.1) "release 162", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.27.29-0.1-default

Yesterday I upgraded to the latest Amarok from opensuse's build service for kde 4.3.1.
As a result, Amarok lost the ability to fetch missing cover art. Clicking on "Fetch missing covers" in the Cover Manager does nothing. The following is the relevant portion of "amarok -debug" output:

amarok: BEGIN: CoverManager::CoverManager()
amarok: END__: CoverManager::CoverManager() - Took 0.0041s
amarok: BEGIN: void CoverManager::slotArtistQueryResult(QString, Meta::ArtistList)
amarok: END__: void CoverManager::slotArtistQueryResult(QString, Meta::ArtistList) - Took 0.00017s
amarok: BEGIN: void CoverManager::slotContinueConstruction()
amarok:   BEGIN: CoverView::CoverView(QWidget*, const char*, Qt::WFlags)
amarok:   END__: CoverView::CoverView(QWidget*, const char*, Qt::WFlags) - Took 0.00013s
amarok: END__: void CoverManager::slotContinueConstruction() - Took 0.0098s
amarok: BEGIN: void CoverManager::init()
amarok:   BEGIN: void CoverManager::changeView(int)
amarok:   END__: void CoverManager::changeView(int) - Took 4.4e-05s
amarok: END__: void CoverManager::init() - Took 0.00024s
amarok: BEGIN: void CoverManager::slotArtistSelectedContinue()
amarok: END__: void CoverManager::slotArtistSelectedContinue() - Took 0.00096s
amarok: BEGIN: void CoverManager::slotAlbumQueryResult(QString, Meta::AlbumList)
amarok: END__: void CoverManager::slotAlbumQueryResult(QString, Meta::AlbumList) - Took 0.00016s
amarok: BEGIN: void CoverManager::slotArtistSelectedContinueAgain()
amarok: END__: void CoverManager::slotArtistSelectedContinueAgain() - Took 0.68s
amarok: BEGIN: void CoverManager::fetchMissingCovers()
amarok:     QUrl( "http://ws.audioscrobbler.com/2.0/?method=album.getinfo&api_key=402d3ca8e9bc9d3cf9b85e1202944ca5&album=1,000 Oceans Single (US)&artist=Tori Amos" )
amarok: END__: void CoverManager::fetchMissingCovers() - Took 0.0013s


Integrestingly, it is still possible to fetch cover for a single explicitly selected album.
Comment 1 Myriam Schweingruber 2009-09-17 13:13:27 UTC

*** This bug has been marked as a duplicate of bug 205032 ***