Bug 207542 - Amarok 2.1.85 crashes on adding stream to empty playlist
Summary: Amarok 2.1.85 crashes on adding stream to empty playlist
Status: RESOLVED DUPLICATE of bug 207382
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-16 08:47 UTC by Alexey Shvetsov
Modified: 2009-09-16 08:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Shvetsov 2009-09-16 08:47:46 UTC
Application: amarok (2.1.85)
KDE Version: 4.3.67 (KDE 4.3.67 (KDE 4.4 >= 20090904)) (Compiled from sources)
Qt Version: 4.6.0-tp1
Operating System: Linux 2.6.31-gentoo x86_64
Distribution (Platform): Gentoo Packages

What I was doing when the application crashed:
Amarok 2.1.85 crashes on adding stream to empty playlist

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 0 (LWP 32391)]

Thread 14 (Thread 0x7f9f7bcac910 (LWP 32466)):
#0  0x0000003066c0afea in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9f7e6287ee in ?? () from /usr/lib64/libxine.so.1
#2  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#3  0x00000030660cc4ad in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 13 (Thread 0x7f9f7b4ab910 (LWP 32467)):
#0  0x00000030660c4463 in poll () from /lib/libc.so.6
#1  0x000000338e43e601 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x000000338e43e93c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00000036797b42ae in QEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:330
#4  0x0000003679784922 in QEventLoop::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:149
#5  0x0000003679784cf4 in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:201
#6  0x0000003679670d79 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f9f7e88669b in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#8  0x0000003679673bd5 in QThreadPrivate::start (arg=<value optimized out>) at thread/qthread_unix.cpp:244
#9  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#10 0x00000030660cc4ad in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 12 (Thread 0x7f9f7aaa0910 (LWP 32482)):
#0  0x00000030660c4463 in poll () from /lib/libc.so.6
#1  0x00007f9f7aaa68ae in ?? () from /usr/lib64/xine/plugins/1.26/xineplug_ao_out_alsa.so
#2  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#3  0x00000030660cc4ad in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f9f7a27e910 (LWP 32483)):
#0  0x0000003066c0ad76 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9f7e63a46b in ?? () from /usr/lib64/libxine.so.1
#2  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#3  0x00000030660cc4ad in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f9f79630910 (LWP 32495)):
#0  0x0000003066c0ad76 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9f7e63a46b in ?? () from /usr/lib64/libxine.so.1
#2  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#3  0x00000030660cc4ad in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f9f70fe5910 (LWP 536)):
#0  0x0000003066c0ad76 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x0000003679674b73 in QWaitCondition::wait (this=<value optimized out>, mutex=<value optimized out>, time=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  0x000000368320a445 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x000000368320d4db in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x000000368320d4f4 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x000000368320d4f4 in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x000000368320bc05 in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x000000368320bcb0 in ThreadWeaver::Thread::run () from /usr/lib64/libthreadweaver.so.4
#8  0x0000003679673bd5 in QThreadPrivate::start (arg=<value optimized out>) at thread/qthread_unix.cpp:244
#9  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#10 0x00000030660cc4ad in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f9f707e4910 (LWP 537)):
#0  0x0000003066c0ad76 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x0000003679674b73 in QWaitCondition::wait (this=<value optimized out>, mutex=<value optimized out>, time=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  0x000000368320a445 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x000000368320d4db in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x000000368320bc05 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x000000368320bcb0 in ThreadWeaver::Thread::run () from /usr/lib64/libthreadweaver.so.4
#6  0x0000003679673bd5 in QThreadPrivate::start (arg=<value optimized out>) at thread/qthread_unix.cpp:244
#7  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#8  0x00000030660cc4ad in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f9f6ffe3910 (LWP 569)):
#0  0x0000003066c0ad76 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x0000003679674b73 in QWaitCondition::wait (this=<value optimized out>, mutex=<value optimized out>, time=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  0x000000368320a445 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x000000368320d4db in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x000000368320bc05 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x000000368320bcb0 in ThreadWeaver::Thread::run () from /usr/lib64/libthreadweaver.so.4
#6  0x0000003679673bd5 in QThreadPrivate::start (arg=<value optimized out>) at thread/qthread_unix.cpp:244
#7  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#8  0x00000030660cc4ad in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f9f63475910 (LWP 945)):
#0  0x00000030660c6002 in select () from /lib/libc.so.6
#1  0x00007f9f7e654af5 in xine_usec_sleep () from /usr/lib64/libxine.so.1
#2  0x00007f9f7e636d12 in ?? () from /usr/lib64/libxine.so.1
#3  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#4  0x00000030660cc4ad in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f9f6288b910 (LWP 946)):
#0  0x0000003066c0ad76 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9f7e62c2fb in ?? () from /usr/lib64/libxine.so.1
#2  0x00007f9f7e63298f in ?? () from /usr/lib64/libxine.so.1
#3  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#4  0x00000030660cc4ad in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f9f6208a910 (LWP 947)):
#0  0x0000003066c0ad76 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9f7e62c2fb in ?? () from /usr/lib64/libxine.so.1
#2  0x00007f9f7e6339e7 in ?? () from /usr/lib64/libxine.so.1
#3  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#4  0x00000030660cc4ad in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f9f61889910 (LWP 948)):
#0  0x0000003066c0ad76 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f9f7e63d7db in xine_event_wait () from /usr/lib64/libxine.so.1
#2  0x00007f9f7e63d84e in ?? () from /usr/lib64/libxine.so.1
#3  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#4  0x00000030660cc4ad in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9f5be1c910 (LWP 1021)):
#0  0x0000003066c0ad76 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x0000003679674b73 in QWaitCondition::wait (this=<value optimized out>, mutex=<value optimized out>, time=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  0x000000368320a445 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x000000368320d4db in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x000000368320d4f4 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x000000368320bc05 in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x000000368320bcb0 in ThreadWeaver::Thread::run () from /usr/lib64/libthreadweaver.so.4
#7  0x0000003679673bd5 in QThreadPrivate::start (arg=<value optimized out>) at thread/qthread_unix.cpp:244
#8  0x0000003066c0653a in start_thread () from /lib/libpthread.so.0
#9  0x00000030660cc4ad in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9f80b17770 (LWP 32391)):
[KCrash Handler]
#5  QGraphicsSceneFindItemBspTreeVisitor::visit (this=<value optimized out>, items=<value optimized out>) at graphicsview/qgraphicsscene_bsp.cpp:79
#6  0x00000033a1bf0215 in QGraphicsSceneBspTree::climbTree (this=<value optimized out>, visitor=<value optimized out>, rect=<value optimized out>, index=<value optimized out>)
    at graphicsview/qgraphicsscene_bsp.cpp:247
#7  0x00000033a1bf025d in QGraphicsSceneBspTree::climbTree (this=<value optimized out>, visitor=<value optimized out>, rect=<value optimized out>, index=<value optimized out>)
    at graphicsview/qgraphicsscene_bsp.cpp:252
#8  0x00000033a1bf0bf3 in QGraphicsSceneBspTree::items (this=<value optimized out>, rect=<value optimized out>, onlyTopLevelItems=<value optimized out>) at graphicsview/qgraphicsscene_bsp.cpp:261
#9  0x00000033a1bf4fc2 in QGraphicsSceneBspTreeIndexPrivate::estimateItems (this=<value optimized out>, rect=<value optimized out>, order=<value optimized out>, 
    onlyTopLevelItems=<value optimized out>) at graphicsview/qgraphicsscenebsptreeindex.cpp:387
#10 0x00000033a1bf5373 in QGraphicsSceneBspTreeIndex::estimateTopLevelItems (this=<value optimized out>, rect=<value optimized out>, order=<value optimized out>)
    at graphicsview/qgraphicsscenebsptreeindex.cpp:604
#11 0x00000033a1bfa1ac in QGraphicsSceneIndex::items (this=<value optimized out>, rect=<value optimized out>, mode=<value optimized out>, order=<value optimized out>, 
    deviceTransform=<value optimized out>) at graphicsview/qgraphicssceneindex_p.h:157
#12 0x00000033a1bd1905 in QGraphicsScene::items (this=<value optimized out>, rect=<value optimized out>, mode=<value optimized out>, order=<value optimized out>, 
    deviceTransform=<value optimized out>) at graphicsview/qgraphicsscene.cpp:1866
#13 0x00000033a1bd3b66 in QGraphicsScenePrivate::itemsAtPosition (this=<value optimized out>, screenPos=<value optimized out>, scenePos=<value optimized out>, widget=<value optimized out>)
    at graphicsview/qgraphicsscene.cpp:937
#14 0x00000033a1bea24d in QGraphicsScenePrivate::dispatchHoverEvent (this=<value optimized out>, hoverEvent=<value optimized out>) at graphicsview/qgraphicsscene.cpp:3591
#15 0x00000033a1bea522 in QGraphicsScene::mouseMoveEvent (this=<value optimized out>, mouseEvent=<value optimized out>) at graphicsview/qgraphicsscene.cpp:3794
#16 0x00000033a1bea7f0 in QGraphicsScene::event (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsscene.cpp:3175
#17 0x00000033a15ad2bc in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4153
#18 0x00000033a15ad3b6 in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4101
#19 0x00000033a283d4f6 in KApplication::notify () from /usr/lib64/libkdeui.so.5
#20 0x0000003679785d0b in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:699
#21 0x00000033a1c06f07 in QGraphicsViewPrivate::mouseMoveEventHandler (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:616
#22 0x00000033a1c0723e in QGraphicsView::mouseMoveEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3108
#23 0x00000033a16061d2 in QWidget::event (this=<value optimized out>, event=<value optimized out>) at kernel/qwidget.cpp:7875
#24 0x00000033a19ac734 in QFrame::event (this=<value optimized out>, e=<value optimized out>) at widgets/qframe.cpp:557
#25 0x00000033a1c03fa3 in QGraphicsView::viewportEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:2698
#26 0x0000003679785416 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>)
    at kernel/qcoreapplication.cpp:814
#27 0x00000033a15ad28c in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4149
#28 0x00000033a15adcf8 in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:3798
#29 0x00000033a283d4f6 in KApplication::notify () from /usr/lib64/libkdeui.so.5
#30 0x0000003679785d0b in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:699
#31 0x00000033a15b18cb in QApplicationPrivate::sendMouseEvent (receiver=<value optimized out>, event=<value optimized out>, alienWidget=<value optimized out>, nativeWidget=<value optimized out>, 
    buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#32 0x00000033a162105c in QETWidget::translateMouseEvent (this=<value optimized out>, event=<value optimized out>) at kernel/qapplication_x11.cpp:4391
#33 0x00000033a161fe20 in QApplication::x11ProcessEvent (this=<value optimized out>, event=<value optimized out>) at kernel/qapplication_x11.cpp:3530
#34 0x00000033a164a254 in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x000000338e43df9f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0x000000338e43e818 in ?? () from /usr/lib/libglib-2.0.so.0
#37 0x000000338e43e93c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#38 0x00000036797b4256 in QEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:328
#39 0x00000033a1649a2e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#40 0x0000003679784922 in QEventLoop::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:149
#41 0x0000003679784cf4 in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:201
#42 0x000000367978746b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:976
#43 0x00000000004076f7 in main (argc=3, argv=0x7fff8c6c3558) at /var/tmp/portage/media-sound/amarok-2.1.85/work/amarok-2.1.85/src/main.cpp:216

This bug may be a duplicate of or related to bug 207382.

Reported using DrKonqi
Comment 1 Mikko C. 2009-09-16 08:50:46 UTC
i suggest you downgrade qt :)

*** This bug has been marked as a duplicate of bug 207382 ***