Bug 207512 - sudden crash, associated with boxswitch, but different
Summary: sudden crash, associated with boxswitch, but different
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-15 23:30 UTC by Steffen Möller
Modified: 2009-09-15 23:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Möller 2009-09-15 23:30:30 UTC
Application that crashed: kwin
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux 4.0r8 (etch)

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f41bbd4facd in KWin::BoxSwitchEffect::calculateItemSizes (this=0x1cb06f0) at ../../../kwin/effects/boxswitch/boxswitch.cpp:686
#6  0x00007f41bbd5110d in KWin::BoxSwitchEffect::tabBoxUpdated (this=0x1cb06f0) at ../../../kwin/effects/boxswitch/boxswitch.cpp:428
#7  0x00007f41c98062e1 in KWin::EffectsHandlerImpl::tabBoxUpdated (this=<value optimized out>) at ../../kwin/effects.cpp:295
#8  0x00007f41c97a46f5 in KWin::TabBox::reset (this=0x1cd4110, partial_reset=true) at ../../kwin/tabbox.cpp:331
#9  0x00007f41c9786e92 in KWin::Workspace::removeClient (this=0x1bc3ce0, c=0x210cfb0) at ../../kwin/workspace.cpp:660
#10 0x00007f41c97929d6 in KWin::Client::releaseWindow (this=0x210cfb0, on_shutdown=false) at ../../kwin/client.cpp:239
#11 0x00007f41c97b3d3b in KWin::Client::windowEvent (this=0x210cfb0, e=0x7fff43765980) at ../../kwin/events.cpp:642
#12 0x00007f41c97b40f8 in KWin::Workspace::workspaceEvent (this=0x1bc3ce0, e=0x7fff43765980) at ../../kwin/events.cpp:319
#13 0x00007f41c979d648 in KWin::Application::x11EventFilter (this=0x7fff43765d70, e=0x7fff43765980) at ../../kwin/main.cpp:357
#14 0x00007f41c60f1b6f in qt_x11EventFilter (ev=0x7fff43765980) at kernel/qapplication_x11.cpp:375
#15 0x00007f41c6104c8e in QApplication::x11ProcessEvent (this=0x7fff43765d70, event=0x7fff43765980) at kernel/qapplication_x11.cpp:3271
#16 0x00007f41c612de9c in x11EventSourceDispatch (s=0x1aaf040, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#17 0x00007f41c033386a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#18 0x00007f41c0336eb8 in ?? () from /usr/lib/libglib-2.0.so.0
#19 0x00007f41c033706c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#20 0x00007f41c597cbff in QEventDispatcherGlib::processEvents (this=0x1a916a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#21 0x00007f41c612d64f in QGuiEventDispatcherGlib::processEvents (this=0x7fff43763950, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#22 0x00007f41c5952de2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#23 0x00007f41c59531b4 in QEventLoop::exec (this=0x7fff43765cb0, flags=...) at kernel/qeventloop.cpp:201
#24 0x00007f41c5955424 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#25 0x00007f41c979fae8 in kdemain (argc=3, argv=0x7fff43766258) at ../../kwin/main.cpp:522
#26 0x00007f41c94285c6 in __libc_start_main (main=0x400710 <main>, argc=3, ubp_av=0x7fff43766258, init=0x400740 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fff43766248) at libc-start.c:222
#27 0x0000000000400649 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 195295

Reported using DrKonqi
Comment 1 Martin Flöser 2009-09-15 23:33:10 UTC
fixen in 4.3.2

*** This bug has been marked as a duplicate of bug 179865 ***