Bug 206952 - Bug reporting website problems
Summary: Bug reporting website problems
Status: RESOLVED WORKSFORME
Alias: None
Product: bugs.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Matt Rogers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-10 11:55 UTC by Steve Kroon
Modified: 2021-03-09 17:11 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Kroon 2009-09-10 11:55:17 UTC
Version:            (using KDE 4.3.1)
Installed from:    Ubuntu Packages

The bugs.kde.org website has no feedback link so that one can report issues with the website use itself.

That forces me to submit a "wish" to say it would help if one provided a link to how to find out your KDE version in the bug reporting wizard.

A second problem I have is that KDE 4.2.2 (my KDE version) is current on Ubuntu Jaunty - surely not that old (I've done all my updates, etc) - yet your system says it's too old to report bugs.  Surely Kubuntu users of Jaunty (and even Intrepid/Hardy) are a significant portion of KDE's user base - are all their KDE's too old?
Comment 1 Dario Andres 2009-09-11 13:48:17 UTC
Normal report and/or feedback to the bug tracking system itself can be done if you report a bug(or wish) against the "bugs.kde.org" product in the same site(this).

About the KDE"vs"Distribution version: I think that if the distributions are providing "old"&"stable" releases, they should "maintain" them too. We don't have enough manpower to maintain three different versions (4.2,  4.3 (current stable branch) and 4.4 (current unstable branch/"trunk"). Things move really fast, that is why we suggest to try the latest stable KDE version to see if a bug is properly fixed.
Distributions may provide the "old&stable" releases, but they should also handle their bugs(which could have been fixed in "old&stable"+1.) Sometimes distributions backport fixes or features from 4.x+1 to 4.x; improving the "old&stable" packages (and.. sometimes.. they just broke things...)
This is a problem of target, support and how to split up the energy the KDE team has.

Just my two cents (you should know that is only my personal opinion about this issue, it may not represent the ideas of other members of the development team)

Regards
Comment 2 FiNeX 2009-09-13 18:14:00 UTC
Dario is right: The current stable version of KDE is 4.3.1. Bugs on older version which has been fixed in 4.3 will not be backported from the KDE team. Only bugs fixed in trunk are (if possible) backported to the next KDE 4.3.x from the KDE team. Distributors can provide the latest stable (wich is mantained for a six month release cycle) or provide an oldest and unmantained version.
Comment 3 Steve Kroon 2009-09-14 10:30:05 UTC
Alright: so then this is 3 wishes:

First, a wish that you provide more info to users how to give feedback - it's really not obvious to a newcomer that one should (specify a fake KDE version greater than your curent one, and) submit a bug/wish to the bugs.kde.org package in order to give feedback on the website itself.

Next, it's a wish that the bug-reporting wizard be more clear on where one can obtain the version information.

And third - it's a wish that KDE's fatal error crash reports, or the front page of this bug reporting site, should indicate where one should report bugs on "outdated KDE versions no longer supported, but stable in your distribution".
Comment 4 Dario Andres 2009-09-14 14:14:31 UTC
(In reply to comment #3)
> Alright: so then this is 3 wishes:
> 
> First, a wish that you provide more info to users how to give feedback - it's
> really not obvious to a newcomer that one should (specify a fake KDE version
> greater than your curent one, and) submit a bug/wish to the bugs.kde.org
> package in order to give feedback on the website itself.
> 

Yes, this should be made more clear. (I though there was another report related to this, but I can't find it...) and bug 205312 is related to "report bugs to systems not related to a specific KDE version".

> Next, it's a wish that the bug-reporting wizard be more clear on where one can
> obtain the version information.
> 

The wizard is going to be rewritten/reimplemented (bugzilla 3.4). Besides that, bug 130875 is related.

> And third - it's a wish that KDE's fatal error crash reports, or the front page
> of this bug reporting site, should indicate where one should report bugs on
> "outdated KDE versions no longer supported, but stable in your distribution".

Mh, may be some kind of hint of which versions are branch and trunk currently, and where to put reports ("in your GNU/Linux distribution bugtracker"; we can't add all the URLs of all the bugtrackers of all the distributions out there...)

Anyways, when you report a bug for KDE 4.currentStable-1; it is possible that the bug is still present on KDE4.currentStable; so bugtriagers checking that should be able to determine if the bug is still there. If KDE4.currentStable doesn't show the problem, then the reporter is asked to recheck the bug later when KDE is updated in the distribution..

Just my two cents
Regards
Comment 5 Steve Kroon 2009-09-15 09:01:32 UTC
Thanks for feedback, Dario.

Regarding your last paragraph: with the current system, we can't report bugs for currentstable-1, so bugtriagers can't check anything.  What makes it worse is I may not even know what the bug is - all I had in this case was a crash report I was asked to submit.
Comment 6 Dario Andres 2009-09-15 14:04:19 UTC
(In reply to comment #5)
> Regarding your last paragraph: with the current system, we can't report bugs
> for currentstable-1

Why ? what is stopping you from do so ? I don't remember any system limitation about this

Regards
Comment 7 Steve Kroon 2009-09-15 15:24:14 UTC
You (Dario) said 4.3 is the current stable branch.  That would mean that KDE 4.currentStable-1 is KDE 4.2.

To quote my initial post in this bug/wish: "A second problem I have is that KDE 4.2.2 (my KDE version) is current on Ubuntu Jaunty - surely not that old (I've done all my updates, etc) - yet your system says it's too old to report bugs."
Comment 8 Dario Andres 2009-09-15 15:31:41 UTC
(In reply to comment #7)
> You (Dario) said 4.3 is the current stable branch.  That would mean that KDE
> 4.currentStable-1 is KDE 4.2.
> 

That is right

> To quote my initial post in this bug/wish: "A second problem I have is that KDE
> 4.2.2 (my KDE version) is current on Ubuntu Jaunty - surely not that old (I've
> done all my updates, etc) - yet your system says it's too old to report bugs."

"your system says it's too old to report bugs" <- That is what I do not understand properly (sorry). Do you get a message from bugzilla itself in the report wizard saying it is too old ? or are you talking about we (bugzilla people) telling you that it is too old? (the bug can be reported on an "old" KDE version, but It may be still valid...... so the report isn't invalid until we check it in the current KDE version; that is why I said in comment 4).

Sorry about the confusion.
Comment 9 Steve Kroon 2009-09-15 15:40:34 UTC
The wizard says it is too old: I select KDE 4.2.2, and "Ubuntu packages".  It then takes me to the same set of options with the following text above it:

"WARNING 	You are not using a recent KDE version.  Since your bug is likely to be fixed already in more recent versions of KDE you can no longer submit bugs against your version of KDE. If possible, please update your KDE version and see whether the problem persists. If it does, please re-submit your bug with the new KDE version. You can download updated KDE versions from the  KDE Web Site or one of the many mirror sites. You can also check the homepage of your operating system or distribution's vendor to see if there are customized KDE versions available for your system."
Comment 10 Dario Andres 2009-09-15 16:32:46 UTC
(oops) I wasn't aware of that message.. sorry.. ignore all my comments about that matter.
Thanks
Comment 11 Steve Kroon 2009-10-19 14:33:33 UTC
I see this is still "UNCONFIRMED".  Is there anything I can do to help this bug report along?
Comment 12 Matt Rogers 2009-10-19 16:14:56 UTC
somehow create more time for me to spend on free software
Comment 13 Justin Zobel 2021-03-09 05:49:47 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 14 Nate Graham 2021-03-09 17:11:25 UTC
Seems to me like this is all working fine. The "your system is too old" message appears comprehensible to me.