Bug 206890 - krunner doesn't reliably show newly installed applications
Summary: krunner doesn't reliably show newly installed applications
Status: RESOLVED DUPLICATE of bug 207361
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-09 19:42 UTC by Alan Jenkins
Modified: 2010-01-03 19:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of the problem (436.23 KB, image/png)
2009-09-09 19:45 UTC, Alan Jenkins
Details
Screenshot 2a (492.65 KB, image/png)
2009-09-09 19:53 UTC, Alan Jenkins
Details
Screenshot 2b (495.88 KB, image/png)
2009-09-09 19:54 UTC, Alan Jenkins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Jenkins 2009-09-09 19:42:15 UTC
Version:            (using KDE 4.3.0)
Installed from:    Ubuntu Packages

I reproduced this with

sudo aptitude install arora

alt+f2 "arora"
->
  krunner shows the _command_ arora (i.e. with a generic cog icon), but it doesn't show the application and it's specific icon.

The Kickoff search box does not suffer from the same problem.
Comment 1 Alan Jenkins 2009-09-09 19:45:31 UTC
Created attachment 36819 [details]
Screenshot of the problem

Here's a screenshot after performing the steps above.
Comment 2 Alan Jenkins 2009-09-09 19:53:11 UTC
Created attachment 36821 [details]
Screenshot 2a

And here's why I added the qualifier "reliably": this screenshot taken 5 minutes later shows the problem occurring again, but...
Comment 3 Alan Jenkins 2009-09-09 19:54:35 UTC
Created attachment 36822 [details]
Screenshot 2b

...after deleting a few letters and re-typing them, the real Arora icon shows up.  Funky.
Comment 4 Jacopo De Simoi 2010-01-02 12:20:08 UTC
This sounds like kbuildsyscoca4 is not run after installing arora (since it is 
not a kde app maybe?).
Can you reproduce with another application?
It could then be possibly a distribution issue.
Comment 5 Jacopo De Simoi 2010-01-02 12:36:42 UTC
Alan, could you tell us which kernel version are (and were) you using?
Thanks
Comment 6 Alan Jenkins 2010-01-03 12:05:51 UTC
Thanks for the interest.  I tried again with arora, kmail, and korganizer; the same thing seems to happen with all of them.

It doesn't happen with programs which I already have installed (firefox, konqueror, akregator, systemsettings).

Kernel version is 2.6.31-16-generic.

My KDE version on the same machine is now 4.3.2.
Comment 7 Pino Toscano 2010-01-03 19:05:16 UTC
This is known problem in the KIO file change class, in conjunction with an inotify behaviour change in kernel 2.6.31 (and 32 too, maybe).

*** This bug has been marked as a duplicate of bug 207361 ***