Bug 206850 - ALT-F2 icewRETURN typed quickly without waiting for window -> crash
Summary: ALT-F2 icewRETURN typed quickly without waiting for window -> crash
Status: RESOLVED DUPLICATE of bug 192536
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-09 12:08 UTC by Steffen Möller
Modified: 2009-09-09 15:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Möller 2009-09-09 12:08:52 UTC
Application that crashed: krunner
Version of the application: 0.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux 4.0r8 (etch)

 -- Backtrace:
Application: Oberfläche zur Ausführung von Befehlen (kdeinit4), signal: Aborted
__lll_lock_wait_private ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:91
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S
[Current thread is 1 (Thread 0x7ff2354bf750 (LWP 5733))]

Thread 5 (Thread 0x7ff2142f6950 (LWP 9805)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007ff235000469 in QWaitConditionPrivate::wait (this=0x19736d8, mutex=0x1962500, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=0x19736d8, mutex=0x1962500, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007ff22b4d2e04 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x19736b0, th=0x1cd0b60) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff22b4d554b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1962200, th=0x1cd0b60) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ff22b4d3b1f in ThreadWeaver::ThreadRunHelper::run (this=0x7ff2142f6090, parent=0x19736b0, th=0x1cd0b60) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007ff22b4d3f59 in ThreadWeaver::Thread::run (this=0x1cd0b60) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007ff234fff475 in QThreadPrivate::start (arg=0x1cd0b60) at thread/qthread_unix.cpp:188
#8  0x00007ff231d3ff9a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007ff23290656d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7ff213af5950 (LWP 9806)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:91
#1  0x00007ff2328b0b1e in _L_lock_3848 () from /lib/libc.so.6
#2  0x00007ff2328ad1cb in *__GI___libc_free (mem=0x7ff204000020) at malloc.c:3623
#3  0x00007ff234c6466c in kiotraderlex_destroy () at lex.c:1915
#4  0x00007ff234c5ff65 in KTraderParse::parseConstraints (_constr=<value optimized out>) at ../../kdecore/services/ktraderparse.cpp:44
#5  0x00007ff234c5e272 in KServiceTypeTrader::applyConstraints (lst=..., constraint=...) at ../../kdecore/services/kservicetypetrader.cpp:59
#6  0x00007ff234c5e55e in KServiceTypeTrader::defaultOffers (this=<value optimized out>, serviceType=<value optimized out>, constraint=...) at ../../kdecore/services/kservicetypetrader.cpp:127
#7  0x00007ff234c5edf1 in KServiceTypeTrader::query (this=0x1bf55f0, serviceType=..., constraint=...) at ../../kdecore/services/kservicetypetrader.cpp:141
#8  0x00007ff214d616cc in ServiceRunner::match (this=0x1d42320, context=...) at ../../../../plasma/runners/services/servicerunner.cpp:56
#9  0x00007ff22cc6ca3b in Plasma::AbstractRunner::performMatch (this=0x1d42320, localContext=...) at ../../plasma/abstractrunner.cpp:160
#10 0x00007ff22b4d47ec in ThreadWeaver::JobRunHelper::runTheJob (this=0x7ff213af5000, th=0x1d258f0, job=0x24c37b0) at ../../../threadweaver/Weaver/Job.cpp:106
#11 0x00007ff22b4d4b0f in ThreadWeaver::Job::execute (this=0x24c37b0, th=0x1d258f0) at ../../../threadweaver/Weaver/Job.cpp:135
#12 0x00007ff22b4d3aef in ThreadWeaver::ThreadRunHelper::run (this=0x7ff213af5090, parent=0x19736b0, th=0x1d258f0) at ../../../threadweaver/Weaver/Thread.cpp:95
#13 0x00007ff22b4d3f59 in ThreadWeaver::Thread::run (this=0x1d258f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#14 0x00007ff234fff475 in QThreadPrivate::start (arg=0x1d258f0) at thread/qthread_unix.cpp:188
#15 0x00007ff231d3ff9a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#16 0x00007ff23290656d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ff2132f4950 (LWP 9807)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007ff235000469 in QWaitConditionPrivate::wait (this=0x19736d8, mutex=0x1962500, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=0x19736d8, mutex=0x1962500, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007ff22b4d2e04 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x19736b0, th=0x1a0c140) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff22b4d554b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1962200, th=0x1a0c140) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ff22b4d3b1f in ThreadWeaver::ThreadRunHelper::run (this=0x7ff2132f4090, parent=0x19736b0, th=0x1a0c140) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007ff22b4d3f59 in ThreadWeaver::Thread::run (this=0x1a0c140) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007ff234fff475 in QThreadPrivate::start (arg=0x1a0c140) at thread/qthread_unix.cpp:188
#8  0x00007ff231d3ff9a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007ff23290656d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff212af3950 (LWP 9808)):
[KCrash Handler]
#5  0x00007ff23286bd25 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007ff23286ede1 in *__GI_abort () at abort.c:88
#7  0x00007ff2328a1cf8 in __libc_message (do_abort=2, fmt=0x7ff232954b28 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:173
#8  0x00007ff2328ab6c8 in malloc_printerr (action=2, str=0x7ff23295213a "malloc(): memory corruption", ptr=<value optimized out>) at malloc.c:5994
#9  0x00007ff2328adfa4 in _int_malloc (av=0x7ff204000020, bytes=5) at malloc.c:4252
#10 0x00007ff2328afda8 in *__GI___libc_malloc (bytes=5) at malloc.c:3551
#11 0x00007ff234c6440f in KTraderParse_putSymbol (_name=0x25da176 "") from /usr/lib/libkdecore.so.5
#12 0x00007ff234c651a7 in kiotraderlex () from /usr/lib/libkdecore.so.5
#13 0x00007ff234c63e2f in kiotraderparse () at yacc.c:1405
#14 0x00007ff234c641ce in KTraderParse_mainParse (_code=<value optimized out>) at yacc.y:151
#15 0x00007ff234c5ff65 in KTraderParse::parseConstraints (_constr=<value optimized out>) at ../../kdecore/services/ktraderparse.cpp:44
#16 0x00007ff234c5e272 in KServiceTypeTrader::applyConstraints (lst=..., constraint=...) at ../../kdecore/services/kservicetypetrader.cpp:59
#17 0x00007ff234c5e55e in KServiceTypeTrader::defaultOffers (this=<value optimized out>, serviceType=<value optimized out>, constraint=...) at ../../kdecore/services/kservicetypetrader.cpp:127
#18 0x00007ff234c5edf1 in KServiceTypeTrader::query (this=0x1bf55f0, serviceType=..., constraint=...) at ../../kdecore/services/kservicetypetrader.cpp:141
#19 0x00007ff214d616cc in ServiceRunner::match (this=0x1d42320, context=...) at ../../../../plasma/runners/services/servicerunner.cpp:56
#20 0x00007ff22cc6ca3b in Plasma::AbstractRunner::performMatch (this=0x1d42320, localContext=...) at ../../plasma/abstractrunner.cpp:160
#21 0x00007ff22b4d47ec in ThreadWeaver::JobRunHelper::runTheJob (this=0x7ff212af3000, th=0x19f3580, job=0x24a1080) at ../../../threadweaver/Weaver/Job.cpp:106
#22 0x00007ff22b4d4b0f in ThreadWeaver::Job::execute (this=0x24a1080, th=0x19f3580) at ../../../threadweaver/Weaver/Job.cpp:135
#23 0x00007ff22b4d3aef in ThreadWeaver::ThreadRunHelper::run (this=0x7ff212af3090, parent=0x19736b0, th=0x19f3580) at ../../../threadweaver/Weaver/Thread.cpp:95
#24 0x00007ff22b4d3f59 in ThreadWeaver::Thread::run (this=0x19f3580) at ../../../threadweaver/Weaver/Thread.cpp:142
#25 0x00007ff234fff475 in QThreadPrivate::start (arg=0x19f3580) at thread/qthread_unix.cpp:188
#26 0x00007ff231d3ff9a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#27 0x00007ff23290656d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#28 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff2354bf750 (LWP 5733)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:91
#1  0x00007ff2328b0b1e in _L_lock_3848 () from /lib/libc.so.6
#2  0x00007ff2328ad1cb in *__GI___libc_free (mem=0x7ff204000020) at malloc.c:3623
#3  0x00007ff2350c7704 in qDeleteAll<QList<QProcessInfo*>::const_iterator> (this=0x17f9440, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:350
#4  qDeleteAll<QList<QProcessInfo*> > (this=0x17f9440, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qalgorithms.h:358
#5  ~QProcessManager (this=0x17f9440, __in_chrg=<value optimized out>) at io/qprocess_unix.cpp:268
#6  0x00007ff2350c78e5 in ~QGlobalStaticDeleter (this=0x7ff2353da6e8, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1632
#7  0x00007ff23287043d in *__GI_exit (status=1) at exit.c:75
#8  0x00007ff2330cce78 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:707
#9  0x00007ff233cc9e68 in KApplication::xioErrhandler (this=0x17f4730, dpy=0x1813c90) at ../../kdeui/kernel/kapplication.cpp:408
#10 0x00007ff2345d60ce in _XIOError () from /usr/lib/libX11.so.6
#11 0x00007ff2345dd028 in ?? () from /usr/lib/libX11.so.6
#12 0x00007ff2345dd937 in _XEventsQueued () from /usr/lib/libX11.so.6
#13 0x00007ff2345c6cdb in XEventsQueued () from /usr/lib/libX11.so.6
#14 0x00007ff23310780c in x11EventSourceCheck (s=0x17f8660) at kernel/qguieventdispatcher_glib.cpp:87
#15 0x00007ff231f9051c in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#16 0x00007ff231f90dd1 in ?? () from /usr/lib/libglib-2.0.so.0
#17 0x00007ff231f9106c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#18 0x00007ff23510dbff in QEventDispatcherGlib::processEvents (this=0x17f3610, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#19 0x00007ff23310764f in QGuiEventDispatcherGlib::processEvents (this=0x7ff204000020, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#20 0x00007ff2350e3de2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#21 0x00007ff2350e41b4 in QEventLoop::exec (this=0x7fffad5a4b00, flags=...) at kernel/qeventloop.cpp:201
#22 0x00007ff2350e6424 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#23 0x00007ff22a29953c in kdemain (argc=1, argv=0x17d1b20) at ../../krunner/main.cpp:65
#24 0x0000000000407264 in launch (argc=1, _name=0x17ad108 "/usr/bin/krunner", args=<value optimized out>, cwd=0x0, envc=0, envs=0x17ad121 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x40a0ff "0") at ../../kinit/kinit.cpp:677
#25 0x0000000000407a28 in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#26 0x0000000000407fae in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#27 0x000000000040863b in main (argc=2, argv=0x7fffad5a5938, envp=0x7fffad5a5950) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 206476

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-09 15:21:34 UTC
Thanks

*** This bug has been marked as a duplicate of bug 192536 ***