Bug 206788 - Plasma image wallpaper slows down KDE startup
Summary: Plasma image wallpaper slows down KDE startup
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: wallpaper-image (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 141 votes (vote)
Target Milestone: ---
Assignee: Paolo Capriotti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-08 21:53 UTC by Bartosz Kwitniewski
Modified: 2010-09-04 20:08 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Plasma image wallpaper patch for 4.3 branch (1.12 KB, patch)
2009-09-24 03:34 UTC, Bartosz Kwitniewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz Kwitniewski 2009-09-08 21:53:22 UTC
Version:            (using KDE 4.3.1)
Compiler:          GCC (GNU) 4.4.1 
OS:                Linux
Installed from:    Unlisted Binary Package

When wallpaper type is set to image then KDE start is delayed by about 10 seconds in splash screen (in final stage, when KDE logo is displayed). After changing wallpaper type to anything else (like color), KDE logo during splash disappears even before it is fully unblured.

It is 100% reproducible on my Arch Linux (64 bit) and OpenSUSE (32 bit factory build 0266 running in QEMU-KVM). KDE versions 4.3.0, 4.3.1 and SVN (08-09-2009) are affected. Problem didn't exist in KDE 4.2 on the same machine.

I have tried:
- changing wallpaper to other one
- converting wallpaper from jpg to png
- changing positioning from scaled to centered
Nothing helps - only changing wallpaper type.

More people reported same issue:

http://bbs.archlinux.org/viewtopic.php?id=79139
http://forum.kde.org/viewtopic.php?f=15&t=76325

Mostly Arch users because not many other distributions have KDE 4.3 yet.
Comment 1 Beat Wolf 2009-09-08 22:46:17 UTC
probably a ksmserver problem? (or whoever that is called)
Comment 2 Todd Partridge 2009-09-09 13:58:43 UTC
Should note too that this doesn't effect the Virus wallpaper type when setting a background.  It loads normally, haven't tried with Slideshow though.
Comment 3 Beat Wolf 2009-09-09 14:13:23 UTC
the color and the virus wallpaper don't use the ksmserver, thats the reason. sadly my kde trunk does not wan't to compile right now...
Comment 4 Beat Wolf 2009-09-09 15:48:37 UTC
SVN commit 1021550 by beatwolf:

notify the ksmserver correctly
BUG:206788


 M  +8 -4      image.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1021550
Comment 5 Maxei 2009-09-19 20:10:10 UTC
Hi, using kubuntu and kde4.3.1 in a 64-bit amd system. I want to report that KDE desktop takes too long to start. How come this bug is considered as "solved"???

I don't understand how it "was solved" and there are no indications on the steps required to fix it!!

So far, I think that it is NOT yet fixed, at least not in my system. Please kindly provide the details to do the corrections. I believe that KDE is failing to provide a NOTICE to their users that a bug has been solved and provide all the necesary information so users can bebefit from that.
Thank you
Maxei DeVraie
Comment 6 Beat Wolf 2009-09-19 21:33:57 UTC
The bug was solved, but the code is currently only in trunk (which will be released for 4.4).

I wrote the fix, but since i'm not totaly familiar with the ksmserver, i don't want to risk a regression, so i didn't backport it to 4.3.2m as i said, as long as i'm not sure the fix won't harm anybody, i won't backport it.

So, since i commited the patch in trunk there where no complaints (and it worked for me anyway).

So currently for you there is no way to get this fix. Well, you could apply the patch to the 4.3 sources and compile KDE yourself. If you are really annoyed by the progress bar, you can click on it to get it away by the way, so you have a workaround until your distribution gets a KDE with the patch.

I try to ask a few people about the patch, and if they think the patch is ok, i will backport it.
Comment 7 Todd Partridge 2009-09-23 17:24:22 UTC
Great answer beat.  Tried on kde-svn and works good on my system. Very much appreciate the patch.
Comment 8 Beat Wolf 2009-09-23 21:27:26 UTC
nice to hear that.
I'm afraid that currently with my master studies that have just begun, i'm not sure i have the time to backport that patch (well, i could backport it quick and dirty, and just hope it still compiles in the 4.3 enviroment, but since 4.3 and 4.4 are already quite different, and i don't know where what changed how much, i would have to build a whole 4.3 again to test.. and i don't have the time at least in the following month to do that, but please, if somebody whants to backport it, it's really trivial, go for it)
Comment 9 Bartosz Kwitniewski 2009-09-24 03:34:43 UTC
Created attachment 37141 [details]
Plasma image wallpaper patch for 4.3 branch

This patch applied to KDE 4.3 branch without any modifications so there is no more work needed to backport it. \o/ Also it didn't blow up after compilation and KDE 4.3.1 starts up fast now. I have attached patch for 4.3 branch. Actually, only offsets have changed. :-P

If You are not scared of running untrusted binaries then You can find patched library compiled for 64 bit Arch Linux here: http://adept.proste.pl/plasma_wallpaper_image.so Just backup original library and place it in /usr/lib/kde4/.
Comment 10 Beat Wolf 2009-09-24 09:45:46 UTC
SVN commit 1027429 by beatwolf:

correct ksmserver interaction of the wallpaper, this is the backport
CCBUG: 206788


 M  +6 -2      image.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1027429
Comment 11 dharmajunkie 2010-09-04 17:37:39 UTC
I've had this problem for a few months now, it's getting old.  Using Debian Unstable with KDE 4.4.

The only thing that has helped is if I renamed/moved/deleted the file plasma_wallpaper_image.so

One interesting thing is that Iceweasel is usable right away whereas I have to wait for what seems an eternity but is actually probably only 20 seconds for KDE apps to start after I click the icon in the panel.
Comment 12 dharmajunkie 2010-09-04 18:06:03 UTC
I have tried:

* Using the Radeon instead of fglrx video driver
* Removing everything from KDE Autostart
* Turned off compositing
* Set the background to color, globe, virus
* Using the plasma_wallpaper_image.so file in the link by Bartosz (I know, I know, I have 4.4, this is for 4.3)
* Uninstalled Pulseaudio
* Deleted the one folder view from my desksop

Actually, the desktop loads really fast (I have an SSD) but it's not usable at all for a while.  I can see the app's icon (say Konqueror or Konsole) in the taskbar but it has an hourglass and it doesn't open right away.

I have an icon for Iceweasel on my panel and it starts up and is usable right away.

If I 'kquitapp plasma-desktop' then restart plasma-desktop apps do start up right away after the restart.

After if/when this is resolved maybe I'll feel like tackling my "KDE locks up when using power management" problem.
Comment 13 dharmajunkie 2010-09-04 18:57:39 UTC
Oh, wait, this bug is FIXED. Ha ha.
Comment 14 Beat Wolf 2010-09-04 20:08:32 UTC
well, it should be fixed for a long time, so if you still have the problem, its not really fixed. or it is actually another bug.