Bug 206733 - crash after closing konqueror-4.3.1 with many tabs
Summary: crash after closing konqueror-4.3.1 with many tabs
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-08 11:56 UTC by Michał Kudła
Modified: 2009-09-08 14:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Kudła 2009-09-08 11:56:39 UTC
Application that crashed: konqueror
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-gentoo-r6 i686
Distribution: "Gentoo Base System release 2.0.0"

What I was doing when the application crashed:
crash after closing konqueror with many tabs
KDE in version 4.3.1

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb6925670 in raise () from /lib/libc.so.6
#8  0xb6926eb8 in abort () from /lib/libc.so.6
#9  0xb691e6ee in __assert_fail () from /lib/libc.so.6
#10 0xb1f628e2 in KHTMLGlobal::finalCheck () at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/khtml/khtml_global.cpp:258
#11 0xb25353cc in ~KHTMLFactory (this=0x88ff488) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/khtml/khtml_factory.cpp:35
#12 0xb7dbd241 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x88f3980}, end={i = 0x88f3670}) at /usr/include/qt4/QtCore/qalgorithms.h:350
#13 0xb7dbd2b8 in qDeleteAll<FactoryHash> (c=@0x88f34b8) at /usr/include/qt4/QtCore/qalgorithms.h:358
#14 0xb7dbd4d2 in ~FactoryHash (this=0x88f34b8) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kdecore/util/klibrary.cpp:93
#15 0xb7dbc2fd in destroy () at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kdecore/util/klibrary.cpp:97
#16 0xb7c91aeb in ~KCleanUpGlobalStatic (this=0xb7e12450) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kdecore/kernel/kglobal.h:62
#17 0xb6928551 in exit () from /lib/libc.so.6
#18 0x0804e53d in launch (argc=4, _name=0x80846bc "konqueror", args=0x80846fb "", cwd=0x80846fc "/home/m1k0", envc=62, 
    envs=0x808470b "MANPATH=/home/m1k0/.gentoo/java-config-2/current-user-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.18/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.3.3/man:/et"..., reset_env=true, tty=0x0, avoid_loops=false, startup_id_str=0x80853be "m1k0;1252397647;273873;4271_TIME2658229")
    at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kinit/kinit.cpp:677
#19 0x0804f097 in handle_launcher_request (sock=21, who=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kinit/kinit.cpp:1169
#20 0x0804f712 in handle_requests (waitForPid=0) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kinit/kinit.cpp:1353
#21 0x0804fcfa in main (argc=2, argv=0xbf8697a4, envp=0xbf8697b0) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-08 14:49:15 UTC
Thanks

*** This bug has been marked as a duplicate of bug 151453 ***