Bug 206686 - kleopatra does not import certificate that gpgsm does
Summary: kleopatra does not import certificate that gpgsm does
Status: RESOLVED DUPLICATE of bug 358392
Alias: None
Product: kleopatra
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Emanuel Schütze
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-07 22:45 UTC by mattm3a
Modified: 2016-04-08 17:21 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
certificate to reproduce error (1.80 KB, application/x-x509-ca-cert)
2009-09-07 22:46 UTC, mattm3a
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mattm3a 2009-09-07 22:45:34 UTC
Version:           2.0.9 (using 4.3.1 (KDE 4.3.1) "release 161", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.27.29-0.1-default

I have a certificate that I believe is in x509 format, csdca.cer

Importing the certificate using kleopatra fails. 
kleopatra --import-certificate csdca.cer
"Could not determine certificate type"

However, using gpgsm, the import is fine. 
gpgsm --import csdca.cer
Furthermore, the certificate shows up in kleopatra. 

If kleopatra is using gpgsm as a backend, it makes no sense for it to fail when gpgsm can import by itself.
Comment 1 mattm3a 2009-09-07 22:46:17 UTC
Created attachment 36779 [details]
certificate to reproduce error
Comment 2 Benoit Grégoire 2013-05-06 14:34:17 UTC
This is still the case in kubuntu raring (kde 4.10.2)  Here's a very mainstream certificate to reproduce the problem:  http://www.startssl.com/certs/ca.cer
Comment 3 Emanuel Schütze 2013-05-10 07:42:40 UTC
I'll check this with current Kleopatra (and Gpg4win).
Comment 4 Andre Heinecke 2016-04-08 17:21:03 UTC
I've added support for .cer certificates.

*** This bug has been marked as a duplicate of bug 358392 ***