Bug 206649 - kbookmarkedit move bookmark to tree root
Summary: kbookmarkedit move bookmark to tree root
Status: RESOLVED DUPLICATE of bug 181856
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 209969 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-07 18:21 UTC by kde
Modified: 2009-10-09 15:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kde 2009-09-07 18:21:41 UTC
Application that crashed: keditbookmarks
Version of the application: 4.3.1 (KDE 4.3.1) "release 161"
KDE Version: 4.3.1 (KDE 4.3.1) "release 161"
Qt Version: 4.5.2
Operating System: Linux 2.6.27.29-0.1-pae i686
Distribution: "openSUSE 11.1 (i586)"

What I was doing when the application crashed:
If a bookmark is dragged from the right pane and dropped on the root of the tree in the left pane (labeled "Bookmark") the bookmarck editor very reliably crashes every time.

To reproduce this error:
1.  Make sure the directory /home/foo/.kde4/share/apps/konqueror is completely empty - no files or subdirectories of any kind.
2.  Start Konqueror.
3.  Navigate to http://www.metacrawler.com/metacrawler/ws/advsearch/ShowAdvanceSearch=1/rfcid=414/rfcp=Top/_iceUrlFlag=11?_IceUrl=true&qcat=web.
4.  From the Konqueror menu bar, choose "Bookmarks" | "Add Bookmarks".
5.  From the Konqueror menu bar, choose "Bookmarks" | "Edit Bookmarks".
6.  Drag the bookmark titled "MetaCrawler - Advanced Search" from the right pane, and drop it on the root of the tree labeled "Bookmarks" at the top of the left pane.
7.  The bookmark editor will crash.  This error is extremely reliably able to be reproduced following the steps outlined above.


 -- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#6  0xb7653f86 in QDomNode::QDomNode(QDomNode const&) () from /usr/lib/libQtXml.so.4
#7  0xb7655504 in QDomElement::QDomElement(QDomElement const&) () from /usr/lib/libQtXml.so.4
#8  0xb7ee281c in TreeItem::bookmark (this=0x0) at /usr/include/kbookmark.h:34
#9  0xb7edffb1 in KBookmarkModel::dropMimeData (this=0x8177e10, data=0x8255638, action=Qt::CopyAction, row=-1, column=-1, parent=@0xbfc26e20)
    at /usr/src/debug/kdebase-4.3.1/apps/keditbookmarks/bookmarkmodel.cpp:342
#10 0xb7ee22cf in BookmarkFolderViewFilterModel::dropMimeData (this=0x8186aa8, data=0x8255638, action=Qt::CopyAction, row=1, column=0, parent=@0xbfc26ea4)
    at /usr/src/debug/kdebase-4.3.1/apps/keditbookmarks/bookmarklistview.cpp:184
#11 0xb69ba7a1 in QAbstractItemView::dropEvent(QDropEvent*) () from /usr/lib/libQtGui.so.4
#12 0xb64e2f71 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#13 0xb6874443 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#14 0xb69146df in QAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb69c6e77 in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb6a01ab6 in QTreeView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#17 0xb6916ce5 in ?? () from /usr/lib/libQtGui.so.4
#18 0xb6e5437a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb648c79a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb64950c1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb744072d in KApplication::notify (this=0xbfc2bb2c, receiver=0x80e3560, event=0xbfc2767c) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#22 0xb6e5516b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb6511ecd in ?? () from /usr/lib/libQtGui.so.4
#24 0xb6516b93 in QDragManager::drop() () from /usr/lib/libQtGui.so.4
#25 0xb6516d56 in QDragManager::eventFilter(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb6e5443c in QCoreApplicationPrivate::sendThroughApplicationEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#27 0xb648c733 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#28 0xb6495421 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#29 0xb744072d in KApplication::notify (this=0xbfc2bb2c, receiver=0x8154da8, event=0xbfc27c18) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#30 0xb6e5516b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#31 0xb649448e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
#32 0xb65046c6 in ?? () from /usr/lib/libQtGui.so.4
#33 0xb6503a9d in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#34 0xb652d5aa in ?? () from /usr/lib/libQtGui.so.4
#35 0xb5cb29c8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0xb5cb6083 in ?? () from /usr/lib/libglib-2.0.so.0
#37 0xb5cb6241 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#38 0xb6e808d8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb652cca5 in ?? () from /usr/lib/libQtGui.so.4
#40 0xb6e5378a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#41 0xb6e53bd2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#42 0xb651655b in QDragManager::drag(QDrag*) () from /usr/lib/libQtGui.so.4
#43 0xb649fe4a in QDrag::exec(QFlags<Qt::DropAction>, Qt::DropAction) () from /usr/lib/libQtGui.so.4
#44 0xb69c53cc in QAbstractItemView::startDrag(QFlags<Qt::DropAction>) () from /usr/lib/libQtGui.so.4
#45 0xb69c22fd in QAbstractItemView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#46 0xb6a018b4 in QTreeView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#47 0xb64e31fd in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#48 0xb6874443 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#49 0xb69146df in QAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#50 0xb69c6e77 in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#51 0xb6a01ab6 in QTreeView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#52 0xb6916ce5 in ?? () from /usr/lib/libQtGui.so.4
#53 0xb6e5437a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#54 0xb648c79a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#55 0xb6495421 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#56 0xb744072d in KApplication::notify (this=0xbfc2bb2c, receiver=0x817bea8, event=0xbfc29fe8) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#57 0xb6e5516b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#58 0xb649448e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
#59 0xb65046c6 in ?? () from /usr/lib/libQtGui.so.4
#60 0xb6503a9d in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#61 0xb652d5aa in ?? () from /usr/lib/libQtGui.so.4
#62 0xb5cb29c8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#63 0xb5cb6083 in ?? () from /usr/lib/libglib-2.0.so.0
#64 0xb5cb6241 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#65 0xb6e808d8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#66 0xb652cca5 in ?? () from /usr/lib/libQtGui.so.4
#67 0xb6e5378a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#68 0xb6e53bd2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#69 0xb6e56079 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#70 0xb648c637 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#71 0xb7ebc179 in kdemain (argc=6, argv=0xbfc2be84) at /usr/src/debug/kdebase-4.3.1/apps/keditbookmarks/main.cpp:203
#72 0x08048712 in main (argc=-1, argv=0xffffffff) at /usr/src/debug/kdebase-4.3.1/build/apps/keditbookmarks/keditbookmarks_dummy.cpp:3

This bug may be a duplicate of or related to bug 189869

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-07 23:22:57 UTC
Thanks

*** This bug has been marked as a duplicate of bug 181856 ***
Comment 2 Dario Andres 2009-10-09 15:24:59 UTC
*** Bug 209969 has been marked as a duplicate of this bug. ***