Bug 206581 - KToolInvocation::invokeBrowser doesn't work if Konqueror isn't installed
Summary: KToolInvocation::invokeBrowser doesn't work if Konqueror isn't installed
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdecore (show other bugs)
Version: 4.3
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 210849 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-07 04:57 UTC by Parker Coates
Modified: 2009-10-17 02:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Parker Coates 2009-09-07 04:57:33 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

KToolInvocation::invokeBrowser doesn't work unless Konqueror is installed, even if another browser has been set as the default in System Settings.

I recently did a minimum installation of a new OS. I installed kdebase/runtime and kdebase/workspace, but not all of kdebase/apps was installed. Firefox was installed and configured as KDE's default browser. I found that KDE applications (Konversation, Pastebin applet, about dialog) failed to open a browser window when links were clicked. On a whim I decided to install Konqueror to see if the problem was with Firefox, but as soon as Konqueror was installed, links started opening in Firefox.

Is this a bug? It certainly is what the user expects. Also, from a developer perspective, I was under the impression that kdebase/apps was a runtime requirement for apps built against kdelibs. I'm also not sure if kdecore is the correct product to file this against. Thanks.
Comment 1 David Faure 2009-09-07 15:21:53 UTC
SVN commit 1020883 by dfaure:

Add support for konqueror haters :)
 (I mean, for people who choose another browser *and* don't even install kdebase-apps)
BUG: 206581


 M  +15 -7     ktoolinvocation_x11.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1020883
Comment 2 Pino Toscano 2009-10-17 02:41:47 UTC
*** Bug 210849 has been marked as a duplicate of this bug. ***