Bug 206543 - zoom to 100% with 1 mouse click in the light table
Summary: zoom to 100% with 1 mouse click in the light table
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: LightTable-Canvas (show other bugs)
Version: 4.2.0
Platform: Gentoo Packages Unspecified
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-06 21:04 UTC by DrSlony
Modified: 2022-02-01 09:09 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DrSlony 2009-09-06 21:04:13 UTC
Version:            (using KDE 4.3.1)
Installed from:    Gentoo Packages

Would be nice if I could zoom to 100% in the light table by just left, right or middle clicking on one of the images.
Comment 1 caulier.gilles 2011-12-15 08:07:05 UTC
There are 2 buttons on status bar to switch on zoom to 100% on the left or right side panel. It's not enough ?

Gilles Caulier
Comment 2 Michal Thoma 2011-12-18 17:42:02 UTC
It's not really enough if we have to evaluate and rate a lot of images. The speed is important. And having faster access to enlarge/disenlarge function would make workflow considerably faster, mind that checking the sharpness is one of the very basic image evaluation task.

If we can scale to 100% by doubleclick and back to the "scale to fit" with another dobuleclik, I would be definitely happy. Also it would be nice if the place where we doubleclick would be a in the center of enlargement.
Comment 3 DrSlony 2012-03-25 22:00:15 UTC
Sorry to bother you Caulier but no, it's not enough, as Michal explained :)

I have to move the cursor to the bottom-left corner to aim at one small button to zoom the left photo to 100%, then aim for small button in the bottom-right corner to zoom the right one to 100%, and then repeat to zoom out.

Would be great if simply left-clicking/middle-clicking/double-clicking would zoom both to 100%, and out again to fit.
Comment 4 Islam Wazery 2013-05-06 12:42:50 UTC
DrSlony,

Can you please try it with the latest digiKam (3.2) and tell me if you are able to reproduce this behavior. For me the left-clicking, middile, and right are all working correctly.
Comment 5 DrSlony 2013-05-06 19:55:14 UTC
Unfortunately I can't, because the beta is not in the official Gentoo repo yet, and by the time it will be I will most likely already have left to travel for a few months or a year. But thank you, I'll be happy to use it when I get back :]

(In reply to comment #4)
> DrSlony,
> 
> Can you please try it with the latest digiKam (3.2) and tell me if you are
> able to reproduce this behavior. For me the left-clicking, middile, and
> right are all working correctly.
Comment 6 DrSlony 2013-05-28 00:40:23 UTC
In 3.2.0 zooming one zooms the other. It would still be nice to be able to zoom just by clicking on the preview instead of the small button.
Comment 7 DrSlony 2014-09-15 17:09:03 UTC
One still cannot zoom the Light Table to 100% and back to fit-to-window in 4.2.0 by left/right/middle/double-clicking. As explained before, it would be a small but nice time saver to be able to just double-click on the preview to zoom it to 100% (and double-click again to zoom it to fit-to-window).

Also see bug 338224 - Inconsistent "Zoom to 100%" shortcut behavior between Preview Mode and Image Editor
Comment 8 caulier.gilles 2018-08-11 09:26:11 UTC
DrSlony,

I'm not sure if this entry is really fixed with recent digiKam version. Can you confirm please ?

Gilles Caulier