Bug 206417 - KMail cannot correctly display subjects with UTF-8 characters encoded in quoted-printable format
Summary: KMail cannot correctly display subjects with UTF-8 characters encoded in quot...
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.12.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-05 19:46 UTC by Kirill
Modified: 2009-09-08 23:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill 2009-09-05 19:46:40 UTC
Version:           1.12.1 (using 4.3.00 (KDE 4.3.0) "release 158", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.27.29-0.1-default

Like https://bugs.kde.org/show_bug.cgi?id=201017, but in my case subject is correct:
Subject: =?utf-8?Q?ÐиÑилл,=20=D0=B4=D0=BE=D0=B1=D1=80=D1=8B=D0=B9=20=D0=B4=D0=B5=D0=BD=D1=8C?=
So, KMail doesn't display part before comma, like all other clients do (Thunderbird, The Bat, GMail Web Interface, etc)
Comment 1 Martin Koller 2009-09-08 23:01:29 UTC
SVN commit 1021324 by mkoller:

BUG: 206417

Be more tolerant and decode illegal chars in the given encoding


 M  +2 -1      kmime_codec_qp.cpp  
 M  +4 -4      kmime_header_parsing.cpp  
 M  +7 -0      tests/rfc2047test.cpp   [UTF-8 ENCODING PROBLEMS]


WebSVN link: http://websvn.kde.org/?view=rev&revision=1021324
Comment 2 Martin Koller 2009-09-08 23:05:26 UTC
SVN commit 1021325 by mkoller:

Backport r1021324 by mkoller from trunk to the 4.3 branch:

CCBUG: 206417

Be more tolerant and decode illegal chars in the given encoding



 M  +2 -1      kmime_codec_qp.cpp  
 M  +4 -4      kmime_header_parsing.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1021325