Bug 206377 - "Menu>Message>Forward" different from "Forward" in message's context menu
Summary: "Menu>Message>Forward" different from "Forward" in message's context menu
Status: RESOLVED DUPLICATE of bug 205579
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.12.1
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-05 15:18 UTC by Guido Pinkernell
Modified: 2009-09-06 16:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Pinkernell 2009-09-05 15:18:42 UTC
Version:           1.12.1 (using KDE 4.3.0)
OS:                Linux
Installed from:    SuSE RPMs

Rightclick on a message, then on "Forward".
The list of options shows four entries.

In menu bar, click Message > Forward.
The list here shows only one entry.

Acc. to the code (as said by Ingo on kdepim-users),
all four options should be shown in the
submenu's Forward list.
Comment 1 Anne Wilson 2009-09-05 16:18:53 UTC
This occurs also in Fedora 11 with KMail 1.12.0
Comment 2 Torgny Nyblom 2009-09-05 18:09:12 UTC
Could you try with KMail from KDe 4.3.1 (the bug is fixed in current trunk)?
Comment 3 Guido Pinkernell 2009-09-05 18:30:30 UTC
In fact I did. When I entered the specifications for this report the dropdown list for KDE versions ended with 4.3.0. There was no 4.3.1 entry.
Comment 4 Torgny Nyblom 2009-09-05 19:40:27 UTC
Seems like this was fixed in r1014138

Still needs to be backported to 4.3 branch.
Comment 5 Christophe Marin 2009-09-05 22:24:21 UTC

*** This bug has been marked as a duplicate of bug 205579 ***
Comment 6 Thomas McGuire 2009-09-06 16:13:53 UTC
SVN commit 1020525 by tmcguire:

Backport r1014138 by tmcguire from trunk to the 4.3 branch:

Fix the problem that the forward menu was empty, because the action list was
plugged before createGUI() was called.
Also, clean up a bit, for example don't set the shortcuts twice.

BUG: 206377


 M  +4 -6      kmmainwidget.cpp  
 M  +22 -21    messageactions.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1020525
Comment 7 Thomas McGuire 2009-09-06 16:27:54 UTC

*** This bug has been marked as a duplicate of bug 205579 ***