Bug 206225 - Crash on startup of kate
Summary: Crash on startup of kate
Status: RESOLVED DUPLICATE of bug 211401
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-04 11:20 UTC by Christoph Bartoschek
Modified: 2009-12-12 23:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Bartoschek 2009-09-04 11:20:11 UTC
Application: kate (3.3.65)
KDE Version: 4.3.65 (KDE 4.3.65 (KDE 4.4 >= 20090820)) (Compiled from sources)
Qt Version: 4.5.1
Operating System: Linux 2.6.27.29-0.1-pae i686
Distribution: "openSUSE 11.1 (i586)"

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[KCrash Handler]
#6  QDataStream::operator>> (this=0x0, i=@0xbfb5c6c8) at /home/kde-check/kdesvn/qt-copy/src/corelib/io/qdatastream.cpp:656
#7  0xb78d1d77 in KServiceFactory (this=0x8120da0) at /home/kde-check/kdesvn/kdelibs/kdecore/services/kservicefactory.cpp:44
#8  0xb78d261a in KSycocaFactorySingleton<KServiceFactory>::self (this=0x812d4c8) at /home/kde-check/kdesvn/kdelibs/kdecore/sycoca/ksycocafactory.h:200
#9  0xb78d1ea8 in KServiceFactory::self () at /home/kde-check/kdesvn/kdelibs/kdecore/services/kservicefactory.cpp:75
#10 0xb78ca428 in KService::serviceByDesktopName (_name=@0xbfb5c7d0) at /home/kde-check/kdesvn/kdelibs/kdecore/services/kservice.cpp:591
#11 0xb67d29e4 in KTextEditor::EditorChooser::editor (postfix=@0xbfb5c848, fallBackToKatePart=true) at /home/kde-check/kdesvn/kdelibs/interfaces/ktexteditor/editorchooser.cpp:129
#12 0xb801652d in KateDocManager (this=0x812d228, parent=0xbfb5cb04) at /home/kde-check/kdesvn/kdesdk/kate/app/katedocmanager.cpp:63
#13 0xb800b535 in KateApp (this=0xbfb5cb04, args=0x8067bc8) at /home/kde-check/kdesvn/kdesdk/kate/app/kateapp.cpp:59
#14 0xb8065b80 in kdemain (argc=2, argv=0xbfb5d0f4) at /home/kde-check/kdesvn/kdesdk/kate/app/katemain.cpp:306
#15 0x08048742 in main (argc=134547336, argv=0x8121418) at /home/kde-check/kdesvn/build/kdesdk/kate/app/kate_dummy.cpp:3

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-04 15:15:07 UTC
- Do you have user permissions in /var/tmp/kdecache-$USER/  ?
- Does running "kbuildsycoca4 --noincremental" as user fixes this ?
Thanks
Comment 2 Dario Andres 2009-12-12 23:59:06 UTC

*** This bug has been marked as a duplicate of bug 211401 ***