Bug 206024 (crash_ldap_search) - Crash when autocompleting LDAP address (KPIM::AddresseeLineEdit::slotLDAPSearchData)
Summary: Crash when autocompleting LDAP address (KPIM::AddresseeLineEdit::slotLDAPSear...
Status: RESOLVED FIXED
Alias: crash_ldap_search
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 206054 206072 206098 206136 206245 206256 206262 206273 206599 206940 207343 207351 207381 207491 207495 207523 207587 207687 208027 208181 208309 208880 209076 209884 209985 212062 213411 214986 215366 215579 217760 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-02 19:34 UTC by Del
Modified: 2009-12-12 18:48 UTC (History)
29 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Del 2009-09-02 19:34:34 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic x86_64
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
The mail account is set-up with a Kolab server version 2.2.2 using the kdepim wizard. The crash occurs when I try to write the e-mail address of the Kolab user as recipient (i.e., in the "To" field). It did not crash when typing another mail address. Hence I believe it is the LDAP look-up on the Kolab server causing the crash.  I had no problem on the Kontact version following KDE 4.3.0, so this seems like a regression for KDE 4.3.1.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  QListWidgetItem::text (this=0x0) at /usr/include/qt4/QtGui/qlistwidget.h:90
#6  0x00007f7816002e8c in KPIM::AddresseeLineEdit::slotLDAPSearchData (this=<value optimized out>, adrs=<value optimized out>) at /build/buildd/kdepim-4.3.1/libkdepim/addresseelineedit.cpp:820
#7  0x00007f7816003e3c in KPIM::AddresseeLineEdit::qt_metacall (this=0x278b000, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1f558040)
    at /build/buildd/kdepim-4.3.1/obj-x86_64-linux-gnu/libkdepim/addresseelineedit.moc:95
#8  0x00007f77fe72ac7d in KMLineEdit::qt_metacall (this=0x7fff1f557e90, _c=QMetaObject::InvokeMetaMethod, _id=41478272, _a=0x1)
    at /build/buildd/kdepim-4.3.1/obj-x86_64-linux-gnu/kmail/kmlineeditspell.moc:68
#9  0x00007f77fe79c46d in RecipientLineEdit::qt_metacall (this=0x7fff1f557e90, _c=QMetaObject::InvokeMetaMethod, _id=41478272, _a=0x1)
    at /build/buildd/kdepim-4.3.1/obj-x86_64-linux-gnu/kmail/recipientseditor.moc:123
#10 0x00007f7811aa8ea2 in QMetaObject::activate (sender=0x2787450, from_signal_index=<value optimized out>, to_signal_index=5, argv=0x1) at kernel/qobject.cpp:3113
#11 0x00007f7816006c15 in KPIM::LdapSearch::searchData (this=0x7fff1f557e90, _t1=<value optimized out>) at /build/buildd/kdepim-4.3.1/obj-x86_64-linux-gnu/libkdepim/ldapclient.moc:205
#12 0x00007f7816009d31 in KPIM::LdapSearch::slotDataTimer (this=0x2787450) at /build/buildd/kdepim-4.3.1/libkdepim/ldapclient.cpp:465
#13 0x00007f7816009db5 in KPIM::LdapSearch::finish (this=0x2787450) at /build/buildd/kdepim-4.3.1/libkdepim/ldapclient.cpp:472
#14 0x00007f781600c718 in KPIM::LdapSearch::qt_metacall (this=0x2787450, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1f558160)
    at /build/buildd/kdepim-4.3.1/obj-x86_64-linux-gnu/libkdepim/ldapclient.moc:184
#15 0x00007f7811aa8ea2 in QMetaObject::activate (sender=0x27b2fd0, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x1) at kernel/qobject.cpp:3113
#16 0x00007f7816007309 in KPIM::LdapClient::slotDone (this=0x27b2fd0) at /build/buildd/kdepim-4.3.1/libkdepim/ldapclient.cpp:119
#17 0x00007f781600ce60 in KPIM::LdapClient::qt_metacall (this=0x27b2fd0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1f558300)
    at /build/buildd/kdepim-4.3.1/obj-x86_64-linux-gnu/libkdepim/ldapclient.moc:92
#18 0x00007f7811aa8ea2 in QMetaObject::activate (sender=0x3a33d50, from_signal_index=<value optimized out>, to_signal_index=7, argv=0x1) at kernel/qobject.cpp:3113
#19 0x00007f78120e7942 in KJob::result (this=0x7fff1f557e90, _t1=0x3a33d50) at /build/buildd/kde4libs-4.3.1/obj-x86_64-linux-gnu/kdecore/kjob.moc:188
#20 0x00007f78120e7cbf in KJob::emitResult (this=0x3a33d50) at /build/buildd/kde4libs-4.3.1/kdecore/jobs/kjob.cpp:304
#21 0x00007f7813eff210 in KIO::SimpleJob::slotFinished (this=0x3a33d50) at /build/buildd/kde4libs-4.3.1/kio/kio/job.cpp:477
#22 0x00007f7813eff6c3 in KIO::TransferJob::slotFinished (this=0x3a33d50) at /build/buildd/kde4libs-4.3.1/kio/kio/job.cpp:948
#23 0x00007f7813efa4b5 in KIO::TransferJob::qt_metacall (this=0x3a33d50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1f558700)
    at /build/buildd/kde4libs-4.3.1/obj-x86_64-linux-gnu/kio/jobclasses.moc:343
#24 0x00007f7811aa8ea2 in QMetaObject::activate (sender=0x23cd9c0, from_signal_index=<value optimized out>, to_signal_index=8, argv=0x1) at kernel/qobject.cpp:3113
#25 0x00007f7813fbb891 in KIO::SlaveInterface::dispatch (this=0x23cd9c0, _cmd=104, rawdata=<value optimized out>) at /build/buildd/kde4libs-4.3.1/kio/kio/slaveinterface.cpp:175
#26 0x00007f7813fb83e2 in KIO::SlaveInterface::dispatch (this=0x23cd9c0) at /build/buildd/kde4libs-4.3.1/kio/kio/slaveinterface.cpp:91
#27 0x00007f7813faaf63 in KIO::Slave::gotInput (this=0x23cd9c0) at /build/buildd/kde4libs-4.3.1/kio/kio/slave.cpp:322
#28 0x00007f7813fad1c8 in KIO::Slave::qt_metacall (this=0x23cd9c0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff1f558b20) at /build/buildd/kde4libs-4.3.1/obj-x86_64-linux-gnu/kio/slave.moc:76
#29 0x00007f7811aa8ea2 in QMetaObject::activate (sender=0x2787120, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x1) at kernel/qobject.cpp:3113
#30 0x00007f7813ec7db1 in KIO::ConnectionPrivate::dequeue (this=0x40fe660) at /build/buildd/kde4libs-4.3.1/kio/kio/connection.cpp:82
#31 0x00007f7813ec820a in KIO::Connection::qt_metacall (this=0x2787120, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x23cd9e0)
    at /build/buildd/kde4libs-4.3.1/obj-x86_64-linux-gnu/kio/connection.moc:73
#32 0x00007f7811aa35d8 in QObject::event (this=0x2787120, e=0x23d9730) at kernel/qobject.cpp:1111
#33 0x00007f7812613f4d in QApplicationPrivate::notify_helper (this=0x214dfc0, receiver=0x2787120, e=0x23d9730) at kernel/qapplication.cpp:4056
#34 0x00007f781261c18a in QApplication::notify (this=0x7fff1f559580, receiver=0x2787120, e=0x23d9730) at kernel/qapplication.cpp:4021
#35 0x00007f7813a18deb in KApplication::notify (this=0x7fff1f559580, receiver=0x2787120, event=0x23d9730) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#36 0x00007f7811a936ac in QCoreApplication::notifyInternal (this=0x7fff1f559580, receiver=0x2787120, event=0x23d9730) at kernel/qcoreapplication.cpp:610
#37 0x00007f7811a9431a in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x211d850) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#38 0x00007f7811abce03 in postEventSourceDispatch (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 0x00007f780b1e420a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#40 0x00007f780b1e78e0 in ?? () from /usr/lib/libglib-2.0.so.0
#41 0x00007f780b1e7a7c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#42 0x00007f7811abca8f in QEventDispatcherGlib::processEvents (this=0x211d0a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#43 0x00007f78126acbdf in QGuiEventDispatcherGlib::processEvents (this=0x7fff1f557e90, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#44 0x00007f7811a91f42 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 525702304}) at kernel/qeventloop.cpp:149
#45 0x00007f7811a92314 in QEventLoop::exec (this=0x7fff1f5594e0, flags={i = 525702384}) at kernel/qeventloop.cpp:201
#46 0x00007f7811a945e4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#47 0x0000000000404945 in main (argc=1, argv=0x7fff1f559c68) at /build/buildd/kdepim-4.3.1/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-09-02 23:24:12 UTC
*** Bug 206054 has been marked as a duplicate of this bug. ***
Comment 2 Allen Winter 2009-09-02 23:54:52 UTC
SVN commit 1019115 by winterz:

probable crash fix when autocompleting LDAP address.
BUG: 206024
MERGE: e35,e4,4.3


 M  +1 -1      addresseelineedit.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1019115
Comment 3 Allen Winter 2009-09-03 00:02:48 UTC
SVN commit 1019119 by winterz:

Backport r1019115 by winterz from trunk to the 4.3 branch:

probable crash fix when autocompleting LDAP address.
CCBUG: 206024
MERGE: e35,e4,4.3



 M  +1 -1      addresseelineedit.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1019119
Comment 4 Christophe Giboudeaux 2009-09-03 09:46:22 UTC
*** Bug 206072 has been marked as a duplicate of this bug. ***
Comment 5 Christophe Giboudeaux 2009-09-03 13:18:19 UTC
*** Bug 206098 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Giboudeaux 2009-09-03 18:01:20 UTC
*** Bug 206136 has been marked as a duplicate of this bug. ***
Comment 7 masaj 2009-09-04 09:58:04 UTC
Is there any workaround, or do I have to wait until KDE packages are updated in my distribution? I use ldap search daily in my work.
/Thanks/
Comment 8 Christophe Giboudeaux 2009-09-04 14:15:18 UTC
*** Bug 206245 has been marked as a duplicate of this bug. ***
Comment 9 Christophe Giboudeaux 2009-09-04 16:29:42 UTC
*** Bug 206256 has been marked as a duplicate of this bug. ***
Comment 10 Allen Winter 2009-09-04 17:07:38 UTC
No workaround ,sorry.

you can contact your distro to put out a patched version
Comment 11 Christophe Giboudeaux 2009-09-04 17:25:47 UTC
*** Bug 206262 has been marked as a duplicate of this bug. ***
Comment 12 Christophe Giboudeaux 2009-09-04 21:44:34 UTC
*** Bug 206273 has been marked as a duplicate of this bug. ***
Comment 13 Christophe Giboudeaux 2009-09-07 10:12:07 UTC
*** Bug 206599 has been marked as a duplicate of this bug. ***
Comment 14 Felix Rauscher 2009-09-07 10:17:26 UTC
The fix from winterz works on my system. I checked out kdepim from the 4.3 branch. With this the crash disappeared. Thanks! I hope that there will be soon an update on the kubuntu-launchpad.
Comment 15 Christophe Giboudeaux 2009-09-10 10:28:58 UTC
*** Bug 206940 has been marked as a duplicate of this bug. ***
Comment 16 Christophe Giboudeaux 2009-09-14 13:49:34 UTC
*** Bug 207343 has been marked as a duplicate of this bug. ***
Comment 17 Christophe Giboudeaux 2009-09-14 15:09:04 UTC
*** Bug 207351 has been marked as a duplicate of this bug. ***
Comment 18 Christophe Giboudeaux 2009-09-14 20:55:29 UTC
*** Bug 207381 has been marked as a duplicate of this bug. ***
Comment 19 Christophe Giboudeaux 2009-09-15 20:48:24 UTC
*** Bug 207491 has been marked as a duplicate of this bug. ***
Comment 20 Christophe Giboudeaux 2009-09-15 22:18:46 UTC
*** Bug 207495 has been marked as a duplicate of this bug. ***
Comment 21 Dario Andres 2009-09-16 02:49:01 UTC
*** Bug 207523 has been marked as a duplicate of this bug. ***
Comment 22 Christophe Giboudeaux 2009-09-16 16:11:14 UTC
*** Bug 207587 has been marked as a duplicate of this bug. ***
Comment 23 Christophe Giboudeaux 2009-09-17 17:30:37 UTC
*** Bug 207687 has been marked as a duplicate of this bug. ***
Comment 24 Christophe Giboudeaux 2009-09-20 23:11:04 UTC
*** Bug 208027 has been marked as a duplicate of this bug. ***
Comment 25 David 2009-09-22 16:43:32 UTC
I'm not certain this is fixed or it has potentially exposed another problem.  I've updated to the most recent version of kdepim in the Fedora version where the changelog indicates they have pulled in the fix for this problem.  I'm still experiencing the segfaults on auto ldap lookups.  Backtrace below (hopefully it's helpful).  I've opened a Fedora bugzilla issue https://bugzilla.redhat.com/show_bug.cgi?id=524870 as well.  Let me know if there is more information I can provide or if we need to open a new bug.

Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x00007fa3f8f26b85 in KPIM::AddresseeLineEdit::slotLDAPSearchData () from /usr/lib64/libkdepim.so.4
#6  0x00007fa3f8f27b7c in KPIM::AddresseeLineEdit::qt_metacall () from /usr/lib64/libkdepim.so.4
#7  0x00007fa3eb68d4bd in ?? () from /usr/lib64/libkmailprivate.so.4
#8  0x00007fa3eb6feccd in ?? () from /usr/lib64/libkmailprivate.so.4
#9  0x000000302bb58f52 in QMetaObject::activate () from /usr/lib64/libQtCore.so.4
#10 0x00007fa3f8f2a905 in KPIM::LdapSearch::searchData () from /usr/lib64/libkdepim.so.4
#11 0x00007fa3f8f2da21 in KPIM::LdapSearch::slotDataTimer () from /usr/lib64/libkdepim.so.4
#12 0x00007fa3f8f2daa5 in KPIM::LdapSearch::finish () from /usr/lib64/libkdepim.so.4
#13 0x00007fa3f8f30408 in KPIM::LdapSearch::qt_metacall () from /usr/lib64/libkdepim.so.4
#14 0x000000302bb58f52 in QMetaObject::activate () from /usr/lib64/libQtCore.so.4
#15 0x00007fa3f8f2aff9 in KPIM::LdapClient::slotDone () from /usr/lib64/libkdepim.so.4
#16 0x00007fa3f8f30b50 in KPIM::LdapClient::qt_metacall () from /usr/lib64/libkdepim.so.4
#17 0x000000302bb58f52 in QMetaObject::activate () from /usr/lib64/libQtCore.so.4
#18 0x0000003b934eee52 in KJob::result (this=0x13f6850, _t1=0x2745370) at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kdecore/kjob.moc:188
#19 0x0000003b934ef1cf in KJob::emitResult (this=0x2745370) at /usr/src/debug/kdelibs-4.3.1/kdecore/jobs/kjob.cpp:304
#20 0x0000003b942f2080 in KIO::SimpleJob::slotFinished (this=0x2745370) at /usr/src/debug/kdelibs-4.3.1/kio/kio/job.cpp:477
#21 0x0000003b942f2533 in KIO::TransferJob::slotFinished (this=0x2745370) at /usr/src/debug/kdelibs-4.3.1/kio/kio/job.cpp:948
#22 0x0000003b942ed325 in KIO::TransferJob::qt_metacall (this=0x2745370, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff317320e0)
    at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kio/jobclasses.moc:343
#23 0x000000302bb58f52 in QMetaObject::activate () from /usr/lib64/libQtCore.so.4
#24 0x0000003b943afe61 in KIO::SlaveInterface::dispatch (this=0x153fb60, _cmd=104, rawdata=<value optimized out>) at /usr/src/debug/kdelibs-4.3.1/kio/kio/slaveinterface.cpp:175
#25 0x0000003b943ac9b2 in KIO::SlaveInterface::dispatch (this=0x153fb60) at /usr/src/debug/kdelibs-4.3.1/kio/kio/slaveinterface.cpp:91
#26 0x0000003b9439f533 in KIO::Slave::gotInput (this=0x153fb60) at /usr/src/debug/kdelibs-4.3.1/kio/kio/slave.cpp:322
#27 0x0000003b943a1798 in KIO::Slave::qt_metacall (this=0x153fb60, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff31732500) at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kio/slave.moc:76
#28 0x000000302bb58f52 in QMetaObject::activate () from /usr/lib64/libQtCore.so.4
#29 0x0000003b942bac21 in KIO::ConnectionPrivate::dequeue (this=0x26ca1f0) at /usr/src/debug/kdelibs-4.3.1/kio/kio/connection.cpp:82
#30 0x0000003b942bb07a in KIO::Connection::qt_metacall (this=0x153bfd0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x27456e0)
    at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kio/connection.moc:73
#31 0x000000302bb540d8 in QObject::event () from /usr/lib64/libQtCore.so.4
#32 0x000000302d39008d in QApplicationPrivate::notify_helper () from /usr/lib64/libQtGui.so.4
#33 0x000000302d3982ca in QApplication::notify () from /usr/lib64/libQtGui.so.4
#34 0x0000003b93c134ab in KApplication::notify (this=0x7fff31732f60, receiver=0x153bfd0, event=0x26c1640) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#35 0x000000302bb4407c in QCoreApplication::notifyInternal () from /usr/lib64/libQtCore.so.4
#36 0x000000302bb44cea in QCoreApplicationPrivate::sendPostedEvents () from /usr/lib64/libQtCore.so.4
#37 0x000000302bb6d903 in ?? () from /usr/lib64/libQtCore.so.4
#38 0x0000003bcd8377bb in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#39 0x0000003bcd83af8d in ?? () from /lib64/libglib-2.0.so.0
#40 0x0000003bcd83b14b in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#41 0x000000302bb6d58f in QEventDispatcherGlib::processEvents () from /usr/lib64/libQtCore.so.4
#42 0x000000302d4274cf in ?? () from /usr/lib64/libQtGui.so.4
#43 0x000000302bb42912 in QEventLoop::processEvents () from /usr/lib64/libQtCore.so.4
#44 0x000000302bb42ce4 in QEventLoop::exec () from /usr/lib64/libQtCore.so.4
#45 0x000000302bb44fb4 in QCoreApplication::exec () from /usr/lib64/libQtCore.so.4
#46 0x00000000004045f5 in main (argc=1, argv=0x7fff31733648) at /usr/src/debug/kdepim-4.3.1/kontact/src/main.cpp:218
Comment 26 David 2009-09-22 17:32:51 UTC
There is a work-around to this problem; however, it's rather cumbersome but better than having Kontact segfault on you.  Instead of typing the e-mail address/name in the the to/cc/bcc lines press the "select" button to the far right.  In the pop-up window click the "search directory service" button.  Enter the name you want to search for.  Select your name and then click "add selected".  Like I said, it's cumbersome but better than having the app segfault on you.
Comment 27 Christophe Giboudeaux 2009-09-22 17:34:49 UTC
*** Bug 208181 has been marked as a duplicate of this bug. ***
Comment 28 Christophe Giboudeaux 2009-09-23 17:23:37 UTC
*** Bug 208309 has been marked as a duplicate of this bug. ***
Comment 29 David 2009-09-23 18:17:36 UTC
I don't seem to have permissions to re-open this bug but I'm not convinced that this issue is really resolved.  I'm pasting in more (complete backtraces).  Fedora confirms they have taken in the complete patch in their latest kdepim package.  I can reproduce this problem at will so please let me know how I can help debug/test.  

Reproduced while working in online mode while starting a new e-mail with an address that does not show up in in recent addresses or local address book:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  QListWidgetItem::text () at /usr/include/QtGui/qlistwidget.h:90
#6  KPIM::AddresseeLineEdit::slotLDAPSearchData (this=<value optimized out>, adrs=<value optimized out>) at /usr/src/debug/kdepim-4.3.1/libkdepim/addresseelineedit.cpp:820
#7  0x00007f95bb0b8b7c in KPIM::AddresseeLineEdit::qt_metacall (this=0x5003900, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb2599b60)
    at /usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/libkdepim/addresseelineedit.moc:95
#8  0x00007f95ad81e4bd in KMLineEdit::qt_metacall (this=0x33c7fb0, _c=QMetaObject::InvokeMetaMethod, _id=54296496, _a=0x1)
    at /usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/kmail/kmlineeditspell.moc:68
#9  0x00007f95ad88fccd in RecipientLineEdit::qt_metacall (this=0x33c7fb0, _c=QMetaObject::InvokeMetaMethod, _id=54296496, _a=0x1)
    at /usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/kmail/recipientseditor.moc:123
#10 0x000000302bb58f52 in QMetaObject::activate (sender=0x26277d0, from_signal_index=<value optimized out>, to_signal_index=5, argv=0x1) at kernel/qobject.cpp:3113
#11 0x00007f95bb0bb905 in KPIM::LdapSearch::searchData (this=0x33c7fb0, _t1=<value optimized out>) at /usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/libkdepim/ldapclient.moc:205
#12 0x00007f95bb0bea21 in KPIM::LdapSearch::slotDataTimer (this=0x26277d0) at /usr/src/debug/kdepim-4.3.1/libkdepim/ldapclient.cpp:465
#13 0x00007f95bb0beaa5 in KPIM::LdapSearch::finish (this=0x26277d0) at /usr/src/debug/kdepim-4.3.1/libkdepim/ldapclient.cpp:472
#14 0x00007f95bb0c1408 in KPIM::LdapSearch::qt_metacall (this=0x26277d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb2599c80)
    at /usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/libkdepim/ldapclient.moc:184
#15 0x000000302bb58f52 in QMetaObject::activate (sender=0x2a95f60, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x1) at kernel/qobject.cpp:3113
#16 0x00007f95bb0bbff9 in KPIM::LdapClient::slotDone (this=0x2a95f60) at /usr/src/debug/kdepim-4.3.1/libkdepim/ldapclient.cpp:119
#17 0x00007f95bb0c1b50 in KPIM::LdapClient::qt_metacall (this=0x2a95f60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb2599e20)
    at /usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/libkdepim/ldapclient.moc:92
#18 0x000000302bb58f52 in QMetaObject::activate (sender=0x444b0a0, from_signal_index=<value optimized out>, to_signal_index=7, argv=0x1) at kernel/qobject.cpp:3113
#19 0x0000003b934eee52 in KJob::result (this=0x33c7fb0, _t1=0x444b0a0) at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kdecore/kjob.moc:188
#20 0x0000003b934ef1cf in KJob::emitResult (this=0x444b0a0) at /usr/src/debug/kdelibs-4.3.1/kdecore/jobs/kjob.cpp:304
#21 0x0000003b942f2080 in KIO::SimpleJob::slotFinished (this=0x444b0a0) at /usr/src/debug/kdelibs-4.3.1/kio/kio/job.cpp:477
#22 0x0000003b942f2533 in KIO::TransferJob::slotFinished (this=0x444b0a0) at /usr/src/debug/kdelibs-4.3.1/kio/kio/job.cpp:948
#23 0x0000003b942ed325 in KIO::TransferJob::qt_metacall (this=0x444b0a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb259a220)
    at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kio/jobclasses.moc:343
#24 0x000000302bb58f52 in QMetaObject::activate (sender=0x4471030, from_signal_index=<value optimized out>, to_signal_index=8, argv=0x1) at kernel/qobject.cpp:3113
#25 0x0000003b943afe61 in KIO::SlaveInterface::dispatch (this=0x4471030, _cmd=104, rawdata=<value optimized out>) at /usr/src/debug/kdelibs-4.3.1/kio/kio/slaveinterface.cpp:175
#26 0x0000003b943ac9b2 in KIO::SlaveInterface::dispatch (this=0x4471030) at /usr/src/debug/kdelibs-4.3.1/kio/kio/slaveinterface.cpp:91
#27 0x0000003b9439f533 in KIO::Slave::gotInput (this=0x4471030) at /usr/src/debug/kdelibs-4.3.1/kio/kio/slave.cpp:322
#28 0x0000003b943a1798 in KIO::Slave::qt_metacall (this=0x4471030, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffb259a640) at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kio/slave.moc:76
#29 0x000000302bb58f52 in QMetaObject::activate (sender=0x4fd5900, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x1) at kernel/qobject.cpp:3113
#30 0x0000003b942bac21 in KIO::ConnectionPrivate::dequeue (this=0x4d0ee10) at /usr/src/debug/kdelibs-4.3.1/kio/kio/connection.cpp:82
#31 0x0000003b942bb07a in KIO::Connection::qt_metacall (this=0x4fd5900, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x4d870e0)
    at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kio/connection.moc:73
#32 0x000000302bb540d8 in QObject::event (this=0x4fd5900, e=0x4fbf2e0) at kernel/qobject.cpp:1111
#33 0x000000302d39008d in QApplicationPrivate::notify_helper (this=0x1cba890, receiver=0x4fd5900, e=0x4fbf2e0) at kernel/qapplication.cpp:4056
#34 0x000000302d3982ca in QApplication::notify (this=0x7fffb259b0a0, receiver=0x4fd5900, e=0x4fbf2e0) at kernel/qapplication.cpp:4021
#35 0x0000003b93c134ab in KApplication::notify (this=0x7fffb259b0a0, receiver=0x4fd5900, event=0x4fbf2e0) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#36 0x000000302bb4407c in QCoreApplication::notifyInternal (this=0x7fffb259b0a0, receiver=0x4fd5900, event=0x4fbf2e0) at kernel/qcoreapplication.cpp:610
#37 0x000000302bb44cea in QCoreApplication::sendEvent () at kernel/qcoreapplication.h:213
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1c88850) at kernel/qcoreapplication.cpp:1247
#39 0x000000302bb6d903 in QCoreApplication::sendPostedEvents () at kernel/qcoreapplication.h:218
#40 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#41 0x0000003bcd8377bb in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#42 0x0000003bcd83af8d in ?? () from /lib64/libglib-2.0.so.0
#43 0x0000003bcd83b14b in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#44 0x000000302bb6d58f in QEventDispatcherGlib::processEvents (this=0x1c88110, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#45 0x000000302d4274cf in QGuiEventDispatcherGlib::processEvents (this=0x33c7fb0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#46 0x000000302bb42912 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#47 0x000000302bb42ce4 in QEventLoop::exec (this=0x7fffb259b000, flags=) at kernel/qeventloop.cpp:201
#48 0x000000302bb44fb4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#49 0x00000000004045f5 in main (argc=1, argv=0x7fffb259b788) at /usr/src/debug/kdepim-4.3.1/kontact/src/main.cpp:218

Reproduced while working in offline mode.  Address being in the recent addresses or local address seems to have no bearing.
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb43ce68810 (LWP 4487))]

Thread 2 (Thread 0x7fb427c99950 (LWP 4528)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:217
#1  0x000000302ba5b597 in QWaitConditionPrivate::wait () at
thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (this=0x2802e38, mutex=0x2802e30, time=30000) at
thread/qwaitcondition_unix.cpp:159
#3  0x000000302ba51239 in QThreadPoolThread::run (this=0x2802530) at
concurrent/qthreadpool.cpp:140
#4  0x000000302ba5a5d5 in QThreadPrivate::start (arg=0x2802530) at
thread/qthread_unix.cpp:188
#5  0x00000035e3c073da in start_thread (arg=<value optimized out>) at
pthread_create.c:297
#6  0x00000035e30e62bd in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112

Thread 1 (Thread 0x7fb43ce68810 (LWP 4487)):
[KCrash Handler]
#5  QListWidgetItem::text () at /usr/include/QtGui/qlistwidget.h:90
#6  KPIM::AddresseeLineEdit::slotLDAPSearchData (this=<value optimized out>,
adrs=<value optimized out>) at
/usr/src/debug/kdepim-4.3.1/libkdepim/addresseelineedit.cpp:820
#7  0x00007fb43cf35b7c in KPIM::AddresseeLineEdit::qt_metacall (this=0x1a405a0,
_c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff87510340)
    at
/usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/libkdepim/addresseelineedit.moc:95
#8  0x00007fb42f69b4bd in KMLineEdit::qt_metacall (this=0x1a859c0,
_c=QMetaObject::InvokeMetaMethod, _id=27810240, _a=0x1)
    at
/usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/kmail/kmlineeditspell.moc:68
#9  0x00007fb42f70cccd in RecipientLineEdit::qt_metacall (this=0x1a859c0,
_c=QMetaObject::InvokeMetaMethod, _id=27810240, _a=0x1)
    at
/usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/kmail/recipientseditor.moc:123
#10 0x000000302bb58f52 in QMetaObject::activate (sender=0x1b08c10,
from_signal_index=<value optimized out>, to_signal_index=5, argv=0x1) at
kernel/qobject.cpp:3113
#11 0x00007fb43cf38905 in KPIM::LdapSearch::searchData (this=0x1a859c0,
_t1=<value optimized out>) at
/usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/libkdepim/ldapclient.moc:205
#12 0x00007fb43cf3ba21 in KPIM::LdapSearch::slotDataTimer (this=0x1b08c10) at
/usr/src/debug/kdepim-4.3.1/libkdepim/ldapclient.cpp:465
#13 0x00007fb43cf3baa5 in KPIM::LdapSearch::finish (this=0x1b08c10) at
/usr/src/debug/kdepim-4.3.1/libkdepim/ldapclient.cpp:472
#14 0x00007fb43cf3e408 in KPIM::LdapSearch::qt_metacall (this=0x1b08c10,
_c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff87510460)
    at
/usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/libkdepim/ldapclient.moc:184
#15 0x000000302bb58f52 in QMetaObject::activate (sender=0x1f78ad0,
from_signal_index=<value optimized out>, to_signal_index=4, argv=0x1) at
kernel/qobject.cpp:3113
#16 0x00007fb43cf38ff9 in KPIM::LdapClient::slotDone (this=0x1f78ad0) at
/usr/src/debug/kdepim-4.3.1/libkdepim/ldapclient.cpp:119
#17 0x00007fb43cf3eb50 in KPIM::LdapClient::qt_metacall (this=0x1f78ad0,
_c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff87510600)
    at
/usr/src/debug/kdepim-4.3.1/x86_64-redhat-linux-gnu/libkdepim/ldapclient.moc:92
#18 0x000000302bb58f52 in QMetaObject::activate (sender=0x2bb6280,
from_signal_index=<value optimized out>, to_signal_index=7, argv=0x1) at
kernel/qobject.cpp:3113
#19 0x0000003b934eee52 in KJob::result (this=0x1a859c0, _t1=0x2bb6280) at
/usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kdecore/kjob.moc:188
#20 0x0000003b934ef1cf in KJob::emitResult (this=0x2bb6280) at
/usr/src/debug/kdelibs-4.3.1/kdecore/jobs/kjob.cpp:304
#21 0x0000003b942f2080 in KIO::SimpleJob::slotFinished (this=0x2bb6280) at
/usr/src/debug/kdelibs-4.3.1/kio/kio/job.cpp:477
#22 0x0000003b942f2533 in KIO::TransferJob::slotFinished (this=0x2bb6280) at
/usr/src/debug/kdelibs-4.3.1/kio/kio/job.cpp:948
#23 0x0000003b942ed325 in KIO::TransferJob::qt_metacall (this=0x2bb6280,
_c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff87510a00)
    at
/usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kio/jobclasses.moc:343
#24 0x000000302bb58f52 in QMetaObject::activate (sender=0x1947770,
from_signal_index=<value optimized out>, to_signal_index=8, argv=0x1) at
kernel/qobject.cpp:3113
#25 0x0000003b943afe61 in KIO::SlaveInterface::dispatch (this=0x1947770,
_cmd=104, rawdata=<value optimized out>) at
/usr/src/debug/kdelibs-4.3.1/kio/kio/slaveinterface.cpp:175
#26 0x0000003b943ac9b2 in KIO::SlaveInterface::dispatch (this=0x1947770) at
/usr/src/debug/kdelibs-4.3.1/kio/kio/slaveinterface.cpp:91
#27 0x0000003b9439f533 in KIO::Slave::gotInput (this=0x1947770) at
/usr/src/debug/kdelibs-4.3.1/kio/kio/slave.cpp:322
#28 0x0000003b943a1798 in KIO::Slave::qt_metacall (this=0x1947770,
_c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff87510e20) at
/usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kio/slave.moc:76
#29 0x000000302bb58f52 in QMetaObject::activate (sender=0x2b27ad0,
from_signal_index=<value optimized out>, to_signal_index=4, argv=0x1) at
kernel/qobject.cpp:3113
#30 0x0000003b942bac21 in KIO::ConnectionPrivate::dequeue (this=0x2bb5490) at
/usr/src/debug/kdelibs-4.3.1/kio/kio/connection.cpp:82
#31 0x0000003b942bb07a in KIO::Connection::qt_metacall (this=0x2b27ad0,
_c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x291eb50)
    at
/usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kio/connection.moc:73
#32 0x000000302bb540d8 in QObject::event (this=0x2b27ad0, e=0x2b27f00) at
kernel/qobject.cpp:1111
#33 0x000000302d39008d in QApplicationPrivate::notify_helper (this=0x119b890,
receiver=0x2b27ad0, e=0x2b27f00) at kernel/qapplication.cpp:4056
#34 0x000000302d3982ca in QApplication::notify (this=0x7fff87511880,
receiver=0x2b27ad0, e=0x2b27f00) at kernel/qapplication.cpp:4021
#35 0x0000003b93c134ab in KApplication::notify (this=0x7fff87511880,
receiver=0x2b27ad0, event=0x2b27f00) at
/usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#36 0x000000302bb4407c in QCoreApplication::notifyInternal
(this=0x7fff87511880, receiver=0x2b27ad0, event=0x2b27f00) at
kernel/qcoreapplication.cpp:610
#37 0x000000302bb44cea in QCoreApplication::sendEvent () at
kernel/qcoreapplication.h:213
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0,
data=0x1169850) at kernel/qcoreapplication.cpp:1247
#39 0x000000302bb6d903 in QCoreApplication::sendPostedEvents () at
kernel/qcoreapplication.h:218
#40 postEventSourceDispatch (s=<value optimized out>) at
kernel/qeventdispatcher_glib.cpp:210
#41 0x0000003bcd8377bb in g_main_context_dispatch () from
/lib64/libglib-2.0.so.0
#42 0x0000003bcd83af8d in ?? () from /lib64/libglib-2.0.so.0
#43 0x0000003bcd83b14b in g_main_context_iteration () from
/lib64/libglib-2.0.so.0
#44 0x000000302bb6d58f in QEventDispatcherGlib::processEvents (this=0x1169110,
flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#45 0x000000302d4274cf in QGuiEventDispatcherGlib::processEvents
(this=0x1a859c0, flags=<value optimized out>) at
kernel/qguieventdispatcher_glib.cpp:202
#46 0x000000302bb42912 in QEventLoop::processEvents (this=<value optimized
out>, flags=) at kernel/qeventloop.cpp:149
#47 0x000000302bb42ce4 in QEventLoop::exec (this=0x7fff875117e0, flags=) at
kernel/qeventloop.cpp:201
#48 0x000000302bb44fb4 in QCoreApplication::exec () at
kernel/qcoreapplication.cpp:888
#49 0x00000000004045f5 in main (argc=1, argv=0x7fff87511f68) at
/usr/src/debug/kdepim-4.3.1/kontact/src/main.cpp:218
Comment 30 Thomas McGuire 2009-09-23 18:45:45 UTC
Works here, with the KDE 4.3 branch. The commits that fixed this are r1019119 and r1019358, looks like we didn't tell that the packagers, sorry.
Comment 31 Allen Winter 2009-09-23 18:51:47 UTC
not true.

I sent 2 messages to kde-packagers informing them of the bug and the patch.

If you have yet to get the fix then please nag your distro. We've done all we can on the developer's side.
Comment 32 Thomas McGuire 2009-09-23 19:07:33 UTC
Ok, to clarify: There were 2 commits fixing the issue, and we only told the packagers about one of them, which wasn't enough to prevent the crash.

I've mailed the packagers again to clarify that.
Comment 33 David 2009-09-23 19:17:05 UTC
Okay, thanks guys.  I've posted an update to the Fedora BZ pointing them to these latest comments.
Comment 34 Christophe Giboudeaux 2009-09-29 17:37:37 UTC
*** Bug 208880 has been marked as a duplicate of this bug. ***
Comment 35 Dario Andres 2009-10-02 04:02:51 UTC
*** Bug 209076 has been marked as a duplicate of this bug. ***
Comment 36 Christophe Giboudeaux 2009-10-08 17:39:03 UTC
*** Bug 209884 has been marked as a duplicate of this bug. ***
Comment 37 Christophe Giboudeaux 2009-10-09 14:44:38 UTC
*** Bug 209985 has been marked as a duplicate of this bug. ***
Comment 38 Christophe Giboudeaux 2009-10-27 15:01:38 UTC
*** Bug 212062 has been marked as a duplicate of this bug. ***
Comment 39 Christophe Giboudeaux 2009-10-27 15:21:14 UTC
@Debian users still experimenting this crash: can you indicate what is the *exact* version of your kdepim package ?

Thanks. (for Debian Squeeze, I suppose it should be 4:4.3.1-2)
Comment 40 Fathi Boudra 2009-10-28 11:29:43 UTC
At the time of this writing, Debian has:
- kdepim 4.3.1-2 in squeeze (testing)
- kdepim 4.3.2-1 in sid (unstable)

The packages in squeeze are affected by the issue as they doesn't contain the fixes. You should wait until kdepim 4.3.2-1 enters in squeeze.

If don't want to wait you can pick up the required packages (kdelibs5, kdepimlibs5, etc...) directly from sid.
Comment 41 Dario Andres 2009-11-06 14:19:56 UTC
*** Bug 213411 has been marked as a duplicate of this bug. ***
Comment 42 Christophe Giboudeaux 2009-11-17 19:33:03 UTC
*** Bug 214986 has been marked as a duplicate of this bug. ***
Comment 43 Christophe Giboudeaux 2009-11-20 10:50:43 UTC
*** Bug 215366 has been marked as a duplicate of this bug. ***
Comment 44 Christophe Giboudeaux 2009-11-21 18:26:14 UTC
*** Bug 215579 has been marked as a duplicate of this bug. ***
Comment 45 Dario Andres 2009-12-10 17:31:00 UTC
*** Bug 217760 has been marked as a duplicate of this bug. ***