Bug 205844 - #7 0x00007fb11cca8df3 in KBuildMimeTypeFactory::save (this=0x12f8bf0, str=...) at ../../kded/kbuildmimetypefactory.cpp:307
Summary: #7 0x00007fb11cca8df3 in KBuildMimeTypeFactory::save (this=0x12f8bf0, str=.....
Status: RESOLVED DUPLICATE of bug 202871
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: ksycoca (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-31 23:03 UTC by Marc Jeffrey Driftmeyer
Modified: 2009-09-02 01:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Jeffrey Driftmeyer 2009-08-31 23:03:22 UTC
Application that crashed: kbuildsycoca4
Version of the application: 1.1
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

 -- Backtrace:
Application: KBuildSycoca (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#5  KSycocaEntry::offset (this=0x0) at ../../kdecore/sycoca/ksycocaentry.cpp:132
#6  0x00007fb11cca894d in KBuildMimeTypeFactory::savePatternLists (this=0x12f8bf0, str=...) at ../../kded/kbuildmimetypefactory.cpp:361
#7  0x00007fb11cca8df3 in KBuildMimeTypeFactory::save (this=0x12f8bf0, str=...) at ../../kded/kbuildmimetypefactory.cpp:307
#8  0x00007fb11cca1d21 in KBuildSycoca::save (this=0x1fd45b0, str=0x1286d20) at ../../kded/kbuildsycoca.cpp:525
#9  0x00007fb11cca3ee5 in KBuildSycoca::recreate (this=0x1fd45b0) at ../../kded/kbuildsycoca.cpp:433
#10 0x00007fb11cca5d4b in kdemain (argc=2, argv=0x11f1fe0) at ../../kded/kbuildsycoca.cpp:829
#11 0x0000000000407264 in launch (argc=2, _name=0x11f21c8 "/usr/bin/kbuildsycoca4", args=<value optimized out>, cwd=0x0, envc=1, envs=0x11f2201 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x11f220a "horus;1251751553;31505;15689_TIME0") at ../../kinit/kinit.cpp:676
#12 0x0000000000407a28 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1168
#13 0x0000000000407fae in handle_requests (waitForPid=15813) at ../../kinit/kinit.cpp:1361
#14 0x00000000004085a9 in main (argc=2, argv=0x7fff15c49af8, envp=0x7fff15c49b10) at ../../kinit/kinit.cpp:1751

Reported using DrKonqi
Comment 1 Christoph Feck 2009-09-02 01:22:09 UTC

*** This bug has been marked as a duplicate of bug 202871 ***