Bug 205287 - using ctrl + tab to change the current tab causes the program to crash
Summary: using ctrl + tab to change the current tab causes the program to crash
Status: RESOLVED DUPLICATE of bug 203809
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-27 05:20 UTC by Zach
Modified: 2009-08-27 09:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zach 2009-08-27 05:20:18 UTC
Application that crashed: konqueror
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.29.6 i686
Distribution: "Fedora release 11 (Leonidas)"

What I was doing when the application crashed:
With multiple tabs open, using ctrl+tab to change the tab causes konqueror to crash. Feedora 11, kernel 2.6.29.6. Happens every time the button combination is used

 -- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[KCrash Handler]
#6  0x0632ad99 in QTabWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libQtGui.so.4
#7  0x0321a28a in KTabWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdeui.so.5
#8  0x0208d7fa in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib/libkdeinit4_konqueror.so
#9  0x04849c73 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#10 0x0484a8d2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#11 0x02084e77 in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib/libkdeinit4_konqueror.so
#12 0x02081b5d in KConfigGroup::writeEntry(QString const&, QStringList const&, QFlags<KConfigBase::WriteConfigFlag>) () from /usr/lib/libkdeinit4_konqueror.so
#13 0x048330fa in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#14 0x05ea785c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0x05eafff1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x0310aa7a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0x04833f4b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#18 0x05ea875e in ?? () from /usr/lib/libQtGui.so.4
#19 0x05f43200 in ?? () from /usr/lib/libQtGui.so.4
#20 0x05f45735 in ?? () from /usr/lib/libQtGui.so.4
#21 0x05f1b4cf in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#22 0x05f47302 in ?? () from /usr/lib/libQtGui.so.4
#23 0x0060ccf8 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00610370 in ?? () from /lib/libglib-2.0.so.0
#25 0x006104a3 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x0485e9dc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x05f469e5 in ?? () from /usr/lib/libQtGui.so.4
#28 0x04832539 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x0483298a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#30 0x04834dff in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#31 0x05ea7707 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#32 0x02102121 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#33 0x080486db in _start ()

This bug may be a duplicate of or related to bug 203809

Reported using DrKonqi
Comment 1 Frank Reininghaus 2009-08-27 09:07:38 UTC
Thanks for the bug report. This crash has been reported already, I'll mark it as a duplicate.

*** This bug has been marked as a duplicate of bug 203809 ***