Bug 205240 - kde 4.3 bookmark editor crash dragging one folder onto another
Summary: kde 4.3 bookmark editor crash dragging one folder onto another
Status: RESOLVED DUPLICATE of bug 160679
Alias: None
Product: keditbookmarks
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-26 21:53 UTC by ancow
Modified: 2009-08-26 23:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ancow 2009-08-26 21:53:10 UTC
Application that crashed: keditbookmarks
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
Open the bookmark editor and drag a folder from the main pane onto a folder in the main pane (dragging a folder from the main pane onto the left pane usually doesn't cause a crash).

 -- Backtrace:
Application: Lesezeichen-Editor (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#6  0xb7844a50 in QDomElementPrivate::save (this=0x9c85bd0, s=@0xbfcc2b90, depth=5, indent=1) at dom/qdom.cpp:4603
#7  0xb7837e92 in QDomNodePrivate::save (this=0x9c67200, s=@0xbfcc2b90, depth=5, indent=1) at dom/qdom.cpp:1916
#8  0xb7844677 in QDomElementPrivate::save (this=0x9c67200, s=@0xbfcc2b90, depth=4, indent=1) at dom/qdom.cpp:4640
#9  0xb7837e92 in QDomNodePrivate::save (this=0x9c84b08, s=@0xbfcc2b90, depth=4, indent=1) at dom/qdom.cpp:1916
#10 0xb7844677 in QDomElementPrivate::save (this=0x9c84b08, s=@0xbfcc2b90, depth=3, indent=1) at dom/qdom.cpp:4640
#11 0xb7837e92 in QDomNodePrivate::save (this=0x9ca2850, s=@0xbfcc2b90, depth=3, indent=1) at dom/qdom.cpp:1916
#12 0xb7844677 in QDomElementPrivate::save (this=0x9ca2850, s=@0xbfcc2b90, depth=2, indent=1) at dom/qdom.cpp:4640
#13 0xb7837e92 in QDomNodePrivate::save (this=0x9a20828, s=@0xbfcc2b90, depth=2, indent=1) at dom/qdom.cpp:1916
#14 0xb7844677 in QDomElementPrivate::save (this=0x9a20828, s=@0xbfcc2b90, depth=1, indent=1) at dom/qdom.cpp:4640
#15 0xb7837e92 in QDomNodePrivate::save (this=0x99c8f48, s=@0xbfcc2b90, depth=1, indent=1) at dom/qdom.cpp:1916
#16 0xb7844677 in QDomElementPrivate::save (this=0x99c8f48, s=@0xbfcc2b90, depth=0, indent=1) at dom/qdom.cpp:4640
#17 0xb78490c6 in QDomDocumentPrivate::saveDocument (this=0x996f650, s=@0xbfcc2b90, indent=1, encUsed=QDomNode::EncodingFromDocument) at dom/qdom.cpp:6473
#18 0xb7849763 in QDomNode::save (this=0xbfcc2c50, str=@0xbfcc2b90, indent=1) at dom/qdom.cpp:2684
#19 0xb78497ce in QDomDocument::toString (this=0xbfcc2c50, indent=1) at dom/qdom.cpp:6845
#20 0xb7b34e9c in KBookmarkManager::saveAs (this=0x99dd420, filename=@0x9969d38, toolbarCache=true) at /build/buildd/kde4libs-4.3.0/kio/bookmarks/kbookmarkmanager.cc:402
#21 0xb7b353bf in KBookmarkManager::save (this=0x99dd420, toolbarCache=<value optimized out>) at /build/buildd/kde4libs-4.3.0/kio/bookmarks/kbookmarkmanager.cc:368
#22 0xb7b35400 in KBookmarkManager::emitChanged (this=0x99dd420, group=@0xbfcc2d30) at /build/buildd/kde4libs-4.3.0/kio/bookmarks/kbookmarkmanager.cc:516
#23 0xb804efdb in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#24 0xb80526a1 in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#25 0xb80720d0 in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#26 0xb6c40e31 in QAbstractItemView::dropEvent (this=0xbfcc2d34, event=0xbfcc363c) at itemviews/qabstractitemview.cpp:1849
#27 0xb6749551 in QWidget::event (this=0x99dd6a8, event=0xbfcc363c) at kernel/qwidget.cpp:7731
#28 0xb6afaa53 in QFrame::event (this=0x99dd6a8, e=0xbfcc363c) at widgets/qframe.cpp:559
#29 0xb6b9ac2f in QAbstractScrollArea::viewportEvent (this=0x99dd6a8, e=0xb71ae448) at widgets/qabstractscrollarea.cpp:962
#30 0xb6c4d4a7 in QAbstractItemView::viewportEvent (this=0x99dd6a8, event=0xbfcc363c) at itemviews/qabstractitemview.cpp:1476
#31 0xb6c87ff6 in QTreeView::viewportEvent (this=0x99dd6a8, event=0xbfcc363c) at itemviews/qtreeview.cpp:1266
#32 0xb6b9d235 in QAbstractScrollAreaFilter::eventFilter (this=0x9a62708, o=0x99ddbb8, e=0xbfcc363c) at widgets/qabstractscrollarea_p.h:100
#33 0xb70b9dea in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x984af00, receiver=0x99ddbb8, event=0xbfcc363c) at kernel/qcoreapplication.cpp:726
#34 0xb66f2d1a in QApplicationPrivate::notify_helper (this=0x984af00, receiver=0x99ddbb8, e=0xbfcc363c) at kernel/qapplication.cpp:4052
#35 0xb66fb651 in QApplication::notify (this=0xbfcc7aec, receiver=0x99ddbb8, e=0xbfcc363c) at kernel/qapplication.cpp:4009
#36 0xb766f5cd in KApplication::notify (this=0xbfcc7aec, receiver=0x99ddbb8, event=0xbfcc363c) at /build/buildd/kde4libs-4.3.0/kdeui/kernel/kapplication.cpp:302
#37 0xb70babcb in QCoreApplication::notifyInternal (this=0xbfcc7aec, receiver=0x99ddbb8, event=0xbfcc363c) at kernel/qcoreapplication.cpp:610
#38 0xb67789cd in QX11Data::xdndHandleDrop (this=0x984eb00, xe=0xbfcc3738, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#39 0xb677d693 in QDragManager::drop (this=0x9aec520) at kernel/qdnd_x11.cpp:1709
#40 0xb677d856 in QDragManager::eventFilter (this=0x9aec520, o=0x9b0a748, e=0xbfcc3bd8) at kernel/qdnd_x11.cpp:1302
#41 0xb70b9eac in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x984af00, receiver=0x9b0a748, event=0xbfcc3bd8) at kernel/qcoreapplication.cpp:707
#42 0xb66f2cb3 in QApplicationPrivate::notify_helper (this=0x984af00, receiver=0x9b0a748, e=0xbfcc3bd8) at kernel/qapplication.cpp:4031
#43 0xb66fb9b1 in QApplication::notify (this=0xbfcc7aec, receiver=0x9b0a748, e=0xbfcc3bd8) at kernel/qapplication.cpp:3758
#44 0xb766f5cd in KApplication::notify (this=0xbfcc7aec, receiver=0x9b0a748, event=0xbfcc3bd8) at /build/buildd/kde4libs-4.3.0/kdeui/kernel/kapplication.cpp:302
#45 0xb70babcb in QCoreApplication::notifyInternal (this=0xbfcc7aec, receiver=0x9b0a748, event=0xbfcc3bd8) at kernel/qcoreapplication.cpp:610
#46 0xb66faa1e in QApplicationPrivate::sendMouseEvent (receiver=0x9b0a748, event=0xbfcc3bd8, alienWidget=0x0, nativeWidget=0x9b0a748, buttonDown=0xb6f74aa0, lastMouseReceiver=@0xb6f74aa4)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#47 0xb676acce in QETWidget::translateMouseEvent (this=0x9b0a748, event=0xbfcc526c) at kernel/qapplication_x11.cpp:4409
#48 0xb676a085 in QApplication::x11ProcessEvent (this=0xbfcc7aec, event=0xbfcc526c) at kernel/qapplication_x11.cpp:3428
#49 0xb679537a in x11EventSourceDispatch (s=0x984de68, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#50 0xb5f06b88 in IA__g_main_context_dispatch (context=0x984d090) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#51 0xb5f0a0eb in g_main_context_iterate (context=0x984d090, block=1, dispatch=1, self=0x984ad68) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#52 0xb5f0a268 in IA__g_main_context_iteration (context=0x984d090, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#53 0xb70e62f8 in QEventDispatcherGlib::processEvents (this=0x9834d10, flags={i = -1077128152}) at kernel/qeventdispatcher_glib.cpp:327
#54 0xb6794a75 in QGuiEventDispatcherGlib::processEvents (this=0x9834d10, flags={i = -1077128104}) at kernel/qguieventdispatcher_glib.cpp:202
#55 0xb70b91fa in QEventLoop::processEvents (this=0x9a683c0, flags={i = -1077128040}) at kernel/qeventloop.cpp:149
#56 0xb70b9642 in QEventLoop::exec (this=0x9a683c0, flags={i = -1077127928}) at kernel/qeventloop.cpp:201
#57 0xb677d05b in QDragManager::drag (this=0x9aec520, o=0x9a75548) at kernel/qdnd_x11.cpp:1969
#58 0xb67063da in QDrag::exec (this=0x9a75548, supportedActions={i = -1077127676}, defaultDropAction=Qt::CopyAction) at kernel/qdrag.cpp:282
#59 0xb6c4b9fc in QAbstractItemView::startDrag (this=0x99dd6a8, supportedActions={i = -1077127420}) at itemviews/qabstractitemview.cpp:3205
#60 0xb6c4890d in QAbstractItemView::mouseMoveEvent (this=0x99dd6a8, event=0xbfcc5fa8) at itemviews/qabstractitemview.cpp:1552
#61 0xb6c87df4 in QTreeView::mouseMoveEvent (this=0x99dd6a8, event=0xbfcc5fa8) at itemviews/qtreeview.cpp:1872
#62 0xb67497dd in QWidget::event (this=0x99dd6a8, event=0xbfcc5fa8) at kernel/qwidget.cpp:7534
#63 0xb6afaa53 in QFrame::event (this=0x99dd6a8, e=0xbfcc5fa8) at widgets/qframe.cpp:559
#64 0xb6b9ac2f in QAbstractScrollArea::viewportEvent (this=0x99dd6a8, e=0xb71ae448) at widgets/qabstractscrollarea.cpp:962
#65 0xb6c4d4a7 in QAbstractItemView::viewportEvent (this=0x99dd6a8, event=0xbfcc5fa8) at itemviews/qabstractitemview.cpp:1476
#66 0xb6c87ff6 in QTreeView::viewportEvent (this=0x99dd6a8, event=0xbfcc5fa8) at itemviews/qtreeview.cpp:1266
#67 0xb6b9d235 in QAbstractScrollAreaFilter::eventFilter (this=0x9a62708, o=0x99ddbb8, e=0xbfcc5fa8) at widgets/qabstractscrollarea_p.h:100
#68 0xb70b9dea in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x984af00, receiver=0x99ddbb8, event=0xbfcc5fa8) at kernel/qcoreapplication.cpp:726
#69 0xb66f2d1a in QApplicationPrivate::notify_helper (this=0x984af00, receiver=0x99ddbb8, e=0xbfcc5fa8) at kernel/qapplication.cpp:4052
#70 0xb66fb9b1 in QApplication::notify (this=0xbfcc7aec, receiver=0x99ddbb8, e=0xbfcc5fa8) at kernel/qapplication.cpp:3758
#71 0xb766f5cd in KApplication::notify (this=0xbfcc7aec, receiver=0x99ddbb8, event=0xbfcc5fa8) at /build/buildd/kde4libs-4.3.0/kdeui/kernel/kapplication.cpp:302
#72 0xb70babcb in QCoreApplication::notifyInternal (this=0xbfcc7aec, receiver=0x99ddbb8, event=0xbfcc5fa8) at kernel/qcoreapplication.cpp:610
#73 0xb66faa1e in QApplicationPrivate::sendMouseEvent (receiver=0x99ddbb8, event=0xbfcc5fa8, alienWidget=0x99ddbb8, nativeWidget=0x996fc48, buttonDown=0xb6f74aa0, lastMouseReceiver=@0xb6f74aa4)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#74 0xb676acce in QETWidget::translateMouseEvent (this=0x996fc48, event=0xbfcc763c) at kernel/qapplication_x11.cpp:4409
#75 0xb676a085 in QApplication::x11ProcessEvent (this=0xbfcc7aec, event=0xbfcc763c) at kernel/qapplication_x11.cpp:3428
#76 0xb679537a in x11EventSourceDispatch (s=0x984de68, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#77 0xb5f06b88 in IA__g_main_context_dispatch (context=0x984d090) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#78 0xb5f0a0eb in g_main_context_iterate (context=0x984d090, block=1, dispatch=1, self=0x984ad68) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#79 0xb5f0a268 in IA__g_main_context_iteration (context=0x984d090, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#80 0xb70e62f8 in QEventDispatcherGlib::processEvents (this=0x9834d10, flags={i = -1077118984}) at kernel/qeventdispatcher_glib.cpp:327
#81 0xb6794a75 in QGuiEventDispatcherGlib::processEvents (this=0x9834d10, flags={i = -1077118936}) at kernel/qguieventdispatcher_glib.cpp:202
#82 0xb70b91fa in QEventLoop::processEvents (this=0xbfcc78a0, flags={i = -1077118872}) at kernel/qeventloop.cpp:149
#83 0xb70b9642 in QEventLoop::exec (this=0xbfcc78a0, flags={i = -1077118808}) at kernel/qeventloop.cpp:201
#84 0xb70bbae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#85 0xb66f2bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#86 0xb804e109 in kdemain () from /usr/lib/libkdeinit4_keditbookmarks.so
#87 0x080486a2 in _start ()

This bug may be a duplicate of or related to bug 160679

Reported using DrKonqi
Comment 1 FiNeX 2009-08-26 23:10:23 UTC

*** This bug has been marked as a duplicate of bug 160679 ***