Bug 204327 - when the konqueror has closed it's crash
Summary: when the konqueror has closed it's crash
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-18 21:03 UTC by tzopik
Modified: 2009-08-18 21:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tzopik 2009-08-18 21:03:36 UTC
Application that crashed: konqueror
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-gentoo-r5 x86_64

What I was doing when the application crashed:
when the aplication close, it's crash

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
[KCrash Handler]
#5  0x00007f91199c7095 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007f91199c84c0 in abort () at abort.c:88
#7  0x00007f91199c011a in __assert_fail (assertion=0x7f910aa27431 "!s_refcnt", file=<value optimized out>, line=258, function=0x7f910aa275a0 "static void KHTMLGlobal::finalCheck()") at assert.c:78
#8  0x00007f910a7013ab in KHTMLGlobal::finalCheck () at /home/portage/kde-base/kdelibs-4.3.0/work/kdelibs-4.3.0/khtml/khtml_global.cpp:258
#9  0x00007f9104cb184a in ~KHTMLFactory (this=0x2d64390) at /home/portage/kde-base/kdelibs-4.3.0/work/kdelibs-4.3.0/khtml/khtml_factory.cpp:35
#10 0x00007f911cb9fa51 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x2e4ec70}, end={i = 0x2874be0}) at /usr/include/qt4/QtCore/qalgorithms.h:350
#11 0x00007f911cb9fc79 in ~FactoryHash (this=0x220c) at /home/portage/kde-base/kdelibs-4.3.0/work/kdelibs-4.3.0/kdecore/util/klibrary.cpp:93
#12 0x00007f911cb9edd2 in destroy () at /home/portage/kde-base/kdelibs-4.3.0/work/kdelibs-4.3.0/kdecore/util/klibrary.cpp:97
#13 0x00007f91199c9b35 in __run_exit_handlers (status=0, listp=0x7f9119ce54a8, run_list_atexit=true) at exit.c:78
#14 0x00007f91199c9b85 in exit (status=8716) at exit.c:100
#15 0x0000000000407302 in launch (argc=2, _name=0x22d5b08 "/usr/bin/konqueror", args=0x22d5b23 "", cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x22d5b34 "taco;1250596266;932308;8062_TIME311744851") at /home/portage/kde-base/kdelibs-4.3.0/work/kdelibs-4.3.0/kinit/kinit.cpp:676
#16 0x0000000000407dd2 in handle_launcher_request (sock=8, who=<value optimized out>) at /home/portage/kde-base/kdelibs-4.3.0/work/kdelibs-4.3.0/kinit/kinit.cpp:1168
#17 0x00000000004084d1 in handle_requests (waitForPid=0) at /home/portage/kde-base/kdelibs-4.3.0/work/kdelibs-4.3.0/kinit/kinit.cpp:1361
#18 0x0000000000408a2d in main (argc=2, argv=0x7fff27a5ec38, envp=0x7fff27a5ec50) at /home/portage/kde-base/kdelibs-4.3.0/work/kdelibs-4.3.0/kinit/kinit.cpp:1788

Reported using DrKonqi
Comment 1 Dario Andres 2009-08-18 21:50:29 UTC
Merging with bug 151453. Thanks

*** This bug has been marked as a duplicate of bug 151453 ***