Bug 204257 - dragging a mail over the filtered foldertree unfilters it
Summary: dragging a mail over the filtered foldertree unfilters it
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: folder list (show other bugs)
Version: 1.12.1
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 182688 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-18 12:32 UTC by Martin Koller
Modified: 2009-08-19 21:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2009-08-18 12:32:46 UTC
Version:           1.12.1 (using 4.3.00 (KDE 4.3.0) "release 152", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (i686) release 2.6.27.25-0.1-pae

I look at the inbox.
When I filter the folder tree via the folder quicksearch field, which reduces the number of folders seen, but still keeps me watching the inbox (which is what I want) and now I drag a mail from the inbox over the filtered folder tree, it suddenly becomes unfiltered and I see all my folders.
This is a regression to KDE3 and makes the whole folder-filter useless.
Comment 1 FiNeX 2009-08-19 00:21:54 UTC
I've reproduced this bug on trunk too... It has been introduced recently, some months ago this feature were working.
Comment 2 Martin Koller 2009-08-19 21:29:52 UTC
SVN commit 1013400 by mkoller:

BUG: 204257

Don't unhide all folders when dragging over the tree, as the hidden
folders got hidden due to a filter for a reason


 M  +0 -9      folderview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1013400
Comment 3 Martin Koller 2009-08-19 21:30:32 UTC
SVN commit 1013402 by mkoller:


Backport r1013400 by mkoller from trunk to the 4.3 branch:

CCBUG: 204257

Don't unhide all folders when dragging over the tree, as the hidden
folders got hidden due to a filter for a reason



 M  +0 -9      folderview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1013402
Comment 4 Martin Koller 2009-08-19 21:39:17 UTC
*** Bug 182688 has been marked as a duplicate of this bug. ***