Bug 204247 - Konqueror crash on closing by clicking top right cross icon
Summary: Konqueror crash on closing by clicking top right cross icon
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-18 09:50 UTC by andrew brewster
Modified: 2009-08-18 10:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andrew brewster 2009-08-18 09:50:45 UTC
Application that crashed: konqueror
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30.1-desktop-1mnb i686
Distribution: "Mandriva Linux 2010.0"

What I was doing when the application crashed:
Close Konqueror using the "X" at the top right of the window (when viewing http://news.bbc.co.uk/ in this case)

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb664b611 in raise () from /lib/i686/libc.so.6
#8  0xb664cf62 in abort () from /lib/i686/libc.so.6
#9  0xb664469e in __assert_fail () from /lib/i686/libc.so.6
#10 0xb2682c94 in KHTMLGlobal::finalCheck () at /usr/src/debug/kdelibs-4.3.0/khtml/khtml_global.cpp:258
#11 0xb2cc80c5 in ~KHTMLFactory (this=0x99145a8) at /usr/src/debug/kdelibs-4.3.0/khtml/khtml_factory.cpp:35
#12 0xb7e095de in QObjectCleanupHandler::clear (this=0x99253c8) at kernel/qobjectcleanuphandler.cpp:140
#13 0xb7e09631 in ~QObjectCleanupHandler (this=0x99253c8) at kernel/qobjectcleanuphandler.cpp:86
#14 0xb7bec93d in destroy () at /usr/src/debug/kdelibs-4.3.0/kdecore/util/kpluginfactory.cpp:29
#15 0xb7abb5c9 in ~KCleanUpGlobalStatic (this=0xb7c94474) at /usr/src/debug/kdelibs-4.3.0/kdecore/kernel/kglobal.h:62
#16 0xb664e6df in ?? () from /lib/i686/libc.so.6
#17 0xb664e74f in exit () from /lib/i686/libc.so.6
#18 0x0804dbb0 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=1, envs=0x95eeb30 "DISPLAY=:0.0", reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x8051ba4 "0") at /usr/src/debug/kdelibs-4.3.0/kinit/kinit.cpp:676
#19 0x0804e2ed in handle_launcher_request (sock=7, who=<value optimized out>) at /usr/src/debug/kdelibs-4.3.0/kinit/kinit.cpp:1168
#20 0x0804f04c in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.3.0/kinit/kinit.cpp:1361
#21 0x0804f8c5 in main (argc=1, argv=0xbf9f86d4, envp=0xbf9f86dc) at /usr/src/debug/kdelibs-4.3.0/kinit/kinit.cpp:1788

This bug may be a duplicate of or related to bug 171447

Reported using DrKonqi
Comment 1 Tommi Tervo 2009-08-18 10:40:30 UTC

*** This bug has been marked as a duplicate of bug 151453 ***