Bug 203418 - amarok crashes on copying songs from cd to mtp device
Summary: amarok crashes on copying songs from cd to mtp device
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Collections/MTP player (show other bugs)
Version: 2.3-GIT
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: 2.2.2
Assignee: Amarok Developers
URL:
Keywords: release_blocker
: 211572 221969 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-11 12:54 UTC by Martin Stitz
Modified: 2011-12-20 11:45 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Stitz 2009-08-11 12:54:51 UTC
Application that crashed: amarok
Version of the application: 2.2-GIT
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-ARCH i686

What I was doing when the application crashed:
i tried to copy some songs directly from a cd to an mtp-device (creative zen touch), and amarok crashed

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 0 (LWP 17011)]

Thread 10 (Thread 0xb03e1b70 (LWP 17014)):
#0  0xb7f7a424 in __kernel_vsyscall ()
#1  0xb66dcbc5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb681b3ad in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb6906047 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#4  0xb5c57ae0 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned () from /usr/lib/libthreadweaver.so.4
#5  0xb5c5a14c in ThreadWeaver::WorkingHardState::waitForAvailableJob () from /usr/lib/libthreadweaver.so.4
#6  0xb5c5619b in ThreadWeaver::WeaverImpl::waitForAvailableJob () from /usr/lib/libthreadweaver.so.4
#7  0xb5c5a242 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#8  0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#9  0xb5c5a261 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#10 0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#11 0xb5c5a261 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#12 0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#13 0xb5c5836e in ThreadWeaver::ThreadRunHelper::run () from /usr/lib/libthreadweaver.so.4
#14 0xb5c5898b in ThreadWeaver::Thread::run () from /usr/lib/libthreadweaver.so.4
#15 0xb6905032 in ?? () from /usr/lib/libQtCore.so.4
#16 0xb66d868c in start_thread () from /lib/libpthread.so.0
#17 0xb680de2e in clone () from /lib/libc.so.6

Thread 9 (Thread 0xaeda5b70 (LWP 17015)):
[KCrash Handler]
#6  0xb78d3906 in Meta::MediaDeviceHandler::setBasicMediaDeviceTrackInfo () from /usr/lib/libamaroklib.so.1
#7  0xb78d3dbf in Meta::MediaDeviceHandler::privateCopyTrackToDevice () from /usr/lib/libamaroklib.so.1
#8  0xb78d406c in Meta::CopyWorkerThread::run () from /usr/lib/libamaroklib.so.1
#9  0xb5c5932d in ThreadWeaver::JobRunHelper::runTheJob () from /usr/lib/libthreadweaver.so.4
#10 0xb5c59691 in ThreadWeaver::Job::execute () from /usr/lib/libthreadweaver.so.4
#11 0xb5c5833a in ThreadWeaver::ThreadRunHelper::run () from /usr/lib/libthreadweaver.so.4
#12 0xb5c5898b in ThreadWeaver::Thread::run () from /usr/lib/libthreadweaver.so.4
#13 0xb6905032 in ?? () from /usr/lib/libQtCore.so.4
#14 0xb66d868c in start_thread () from /lib/libpthread.so.0
#15 0xb680de2e in clone () from /lib/libc.so.6

Thread 8 (Thread 0xad35cb70 (LWP 17017)):
#0  0xb7f7a424 in __kernel_vsyscall ()
#1  0xb66dcbc5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb681b3ad in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb6906047 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#4  0xb5c57ae0 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned () from /usr/lib/libthreadweaver.so.4
#5  0xb5c5a14c in ThreadWeaver::WorkingHardState::waitForAvailableJob () from /usr/lib/libthreadweaver.so.4
#6  0xb5c5619b in ThreadWeaver::WeaverImpl::waitForAvailableJob () from /usr/lib/libthreadweaver.so.4
#7  0xb5c5a242 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#8  0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#9  0xb5c5a261 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#10 0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#11 0xb5c5a261 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#12 0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#13 0xb5c5a261 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#14 0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#15 0xb5c5836e in ThreadWeaver::ThreadRunHelper::run () from /usr/lib/libthreadweaver.so.4
#16 0xb5c5898b in ThreadWeaver::Thread::run () from /usr/lib/libthreadweaver.so.4
#17 0xb6905032 in ?? () from /usr/lib/libQtCore.so.4
#18 0xb66d868c in start_thread () from /lib/libpthread.so.0
#19 0xb680de2e in clone () from /lib/libc.so.6

Thread 7 (Thread 0xab358b70 (LWP 17021)):
#0  0xb7f7a424 in __kernel_vsyscall ()
#1  0xb66dcbc5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb681b3ad in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb6906047 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#4  0xb5c57ae0 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned () from /usr/lib/libthreadweaver.so.4
#5  0xb5c5a14c in ThreadWeaver::WorkingHardState::waitForAvailableJob () from /usr/lib/libthreadweaver.so.4
#6  0xb5c5619b in ThreadWeaver::WeaverImpl::waitForAvailableJob () from /usr/lib/libthreadweaver.so.4
#7  0xb5c5a242 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#8  0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#9  0xb5c5a261 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#10 0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#11 0xb5c5a261 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#12 0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#13 0xb5c5a261 in ThreadWeaver::WorkingHardState::applyForWork () from /usr/lib/libthreadweaver.so.4
#14 0xb5c57d63 in ThreadWeaver::WeaverImpl::applyForWork () from /usr/lib/libthreadweaver.so.4
#15 0xb5c5836e in ThreadWeaver::ThreadRunHelper::run () from /usr/lib/libthreadweaver.so.4
#16 0xb5c5898b in ThreadWeaver::Thread::run () from /usr/lib/libthreadweaver.so.4
#17 0xb6905032 in ?? () from /usr/lib/libQtCore.so.4
#18 0xb66d868c in start_thread () from /lib/libpthread.so.0
#19 0xb680de2e in clone () from /lib/libc.so.6

Thread 6 (Thread 0xae3ffb70 (LWP 20176)):
#0  0xb7f7a424 in __kernel_vsyscall ()
#1  0xb66dcbc5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb681b3ad in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb0d0e0b1 in gst_queue_loop () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#4  0xb0df4c1d in gst_task_func () from /usr/lib/libgstreamer-0.10.so.0
#5  0xb447407f in g_thread_pool_thread_proxy () from /usr/lib/libglib-2.0.so.0
#6  0xb4472a4f in g_thread_create_proxy () from /usr/lib/libglib-2.0.so.0
#7  0xb66d868c in start_thread () from /lib/libpthread.so.0
#8  0xb680de2e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xabb59b70 (LWP 20177)):
#0  0xb7f7a424 in __kernel_vsyscall ()
#1  0xb66dcbc5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb681b3ad in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb0d0e0b1 in gst_queue_loop () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#4  0xb0df4c1d in gst_task_func () from /usr/lib/libgstreamer-0.10.so.0
#5  0xb447407f in g_thread_pool_thread_proxy () from /usr/lib/libglib-2.0.so.0
#6  0xb4472a4f in g_thread_create_proxy () from /usr/lib/libglib-2.0.so.0
#7  0xb66d868c in start_thread () from /lib/libpthread.so.0
#8  0xb680de2e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xacb5bb70 (LWP 20178)):
#0  0xb7f7a424 in __kernel_vsyscall ()
#1  0xb66dcbc5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb681b3ad in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb0d0e0b1 in gst_queue_loop () from /usr/lib/gstreamer-0.10/libgstcoreelements.so
#4  0xb0df4c1d in gst_task_func () from /usr/lib/libgstreamer-0.10.so.0
#5  0xb447407f in g_thread_pool_thread_proxy () from /usr/lib/libglib-2.0.so.0
#6  0xb4472a4f in g_thread_create_proxy () from /usr/lib/libglib-2.0.so.0
#7  0xb66d868c in start_thread () from /lib/libpthread.so.0
#8  0xb680de2e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xac35ab70 (LWP 20179)):
#0  0xb7f7a424 in __kernel_vsyscall ()
#1  0xb66dcbc5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb681b3ad in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb0df4e46 in gst_task_func () from /usr/lib/libgstreamer-0.10.so.0
#4  0xb447407f in g_thread_pool_thread_proxy () from /usr/lib/libglib-2.0.so.0
#5  0xb4472a4f in g_thread_create_proxy () from /usr/lib/libglib-2.0.so.0
#6  0xb66d868c in start_thread () from /lib/libpthread.so.0
#7  0xb680de2e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa8e12b70 (LWP 20180)):
#0  0xb67b5a36 in memcpy () from /lib/libc.so.6
#1  0xb67651ad in __dcigettext () from /lib/libc.so.6
#2  0xb67642f3 in dcgettext () from /lib/libc.so.6
#3  0xb67b3881 in strerror_r () from /lib/libc.so.6
#4  0xb67b3795 in strerror () from /lib/libc.so.6
#5  0xb1119700 in snd_strerror () from /usr/lib/libasound.so.2
#6  0xb11d8538 in gst_alsa_error_wrapper () from /usr/lib/gstreamer-0.10/libgstalsa.so
#7  0xb114576c in snd_pcm_hw_prepare () from /usr/lib/libasound.so.2
#8  0xb1136321 in snd_pcm_prepare () from /usr/lib/libasound.so.2
#9  0xb1149d91 in snd_pcm_plugin_prepare () from /usr/lib/libasound.so.2
#10 0xb1136321 in snd_pcm_prepare () from /usr/lib/libasound.so.2
#11 0xb11d8ffb in gst_alsasink_write () from /usr/lib/gstreamer-0.10/libgstalsa.so
#12 0xb0d2d3dc in audioringbuffer_thread_func () from /usr/lib/libgstaudio-0.10.so.0
#13 0xb4472a4f in g_thread_create_proxy () from /usr/lib/libglib-2.0.so.0
#14 0xb66d868c in start_thread () from /lib/libpthread.so.0
#15 0xb680de2e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb2bce730 (LWP 17011)):
#0  0xb681b546 in pthread_mutex_lock () from /lib/libc.so.6
#1  0xb427f104 in _xcb_conn_wait () from /usr/lib/libxcb.so.1
#2  0xb42813d1 in xcb_wait_for_reply () from /usr/lib/libxcb.so.1
#3  0xb65daaa6 in _XReply () from /usr/lib/libX11.so.6
#4  0xb65c88dd in XQueryPointer () from /usr/lib/libX11.so.6
#5  0xb6ec9d40 in QCursor::pos () from /usr/lib/libQtGui.so.4
#6  0xb6e50a9c in QApplicationPrivate::sendSyntheticEnterLeave () from /usr/lib/libQtGui.so.4
#7  0xb6e9c7a6 in QWidgetPrivate::hideChildren () from /usr/lib/libQtGui.so.4
#8  0xb6e9c75b in QWidgetPrivate::hideChildren () from /usr/lib/libQtGui.so.4
#9  0xb6e9c95a in QWidgetPrivate::hide_helper () from /usr/lib/libQtGui.so.4
#10 0xb6ea4e10 in QWidget::setVisible () from /usr/lib/libQtGui.so.4
#11 0xb732ce0b in QDialog::setVisible () from /usr/lib/libQtGui.so.4
#12 0xb732bde6 in QDialog::done () from /usr/lib/libQtGui.so.4
#13 0xb732aa6c in QDialog::accept () from /usr/lib/libQtGui.so.4
#14 0xb0b30d09 in FormatSelectionDialog::accept () from /usr/lib/kde4/libamarok_collection-audiocdcollection.so
#15 0xb0b30bfe in FormatSelectionDialog::qt_metacall () from /usr/lib/kde4/libamarok_collection-audiocdcollection.so
#16 0xb6a0998c in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#17 0xb6a0a5c2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#18 0xb72293d7 in QDialogButtonBox::accepted () from /usr/lib/libQtGui.so.4
#19 0xb7229668 in ?? () from /usr/lib/libQtGui.so.4
#20 0xb722b396 in QDialogButtonBox::qt_metacall () from /usr/lib/libQtGui.so.4
#21 0xb6a0998c in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#22 0xb6a09dd8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#23 0xb74caae1 in QAbstractButton::clicked () from /usr/lib/libQtGui.so.4
#24 0xb71f58c9 in ?? () from /usr/lib/libQtGui.so.4
#25 0xb71f7524 in ?? () from /usr/lib/libQtGui.so.4
#26 0xb71f77b1 in QAbstractButton::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
#27 0xb6e9df12 in QWidget::event () from /usr/lib/libQtGui.so.4
#28 0xb71f576e in QAbstractButton::event () from /usr/lib/libQtGui.so.4
#29 0xb729f02d in QPushButton::event () from /usr/lib/libQtGui.so.4
#30 0xb6e496c4 in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#31 0xb6e516f0 in QApplication::notify () from /usr/lib/libQtGui.so.4
#32 0xb7dbbfaa in KApplication::notify () from /usr/lib/libkdeui.so.5
#33 0xb69f3fab in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#34 0xb6e506b3 in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
#35 0xb6ebe0d4 in ?? () from /usr/lib/libQtGui.so.4
#36 0xb6ebd5b5 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#37 0xb6ee7c22 in ?? () from /usr/lib/libQtGui.so.4
#38 0xb4448d98 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#39 0xb444c3e0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#40 0xb444c513 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#41 0xb6a1e6ac in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#42 0xb6ee7355 in ?? () from /usr/lib/libQtGui.so.4
#43 0xb69f2559 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#44 0xb69f29aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#45 0xb69f4e1f in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#46 0xb6e49547 in QApplication::exec () from /usr/lib/libQtGui.so.4
#47 0x0804c379 in main ()

Reported using DrKonqi
Comment 1 Mikko C. 2009-08-11 13:00:45 UTC
I don't think transcoding from cd to other formats is implemented yet. That's probably why it crashes.
Comment 2 Nikolaj Hald Nielsen 2009-09-02 17:34:12 UTC
This is an issue with the way media devices have implemented their ColectionLocation. I have discussed it with Alejandro a little while back as I hit much the same issue.
Comment 3 Myriam Schweingruber 2009-10-21 20:10:49 UTC
Is there anything we can do about that? Else we might issue a warning message or similar if we can't fix it ourselves.
Comment 4 Myriam Schweingruber 2009-10-23 23:51:28 UTC
*** Bug 211572 has been marked as a duplicate of this bug. ***
Comment 5 Myriam Schweingruber 2009-11-28 20:05:18 UTC
Please change the keyword if this is not Amarok, but libmtp releated, and reassign.
Comment 6 Mark Kretschmann 2009-12-21 09:33:29 UTC
Could you please try to get a better backtrace? This one here is missing debugging symbols, so it's almost useless to us.


Please see here:

http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports
Comment 7 Myriam Schweingruber 2009-12-21 10:19:35 UTC
Here is the backtrace from the duplicate, bug 211572. Looks good

Thread 1 (Thread 0xb349e710 (LWP 8590)):
[KCrash Handler]
#6  0xaf1109a7 in Meta::MtpHandler::libGetAlbum (this=0x9abd290, track=...) at
../../../../src/collection/mtpcollection/handler/MtpHandler.cpp:979
#7  0xaf119a16 in Handler::MtpReadCapability::libGetAlbum (this=0x9c86c70,
track=...) at
../../../../src/collection/mtpcollection/handler/capabilities/MtpReadCapability.cpp:67
#8  0xb7031caf in Meta::MediaDeviceHandler::setupAlbumMap (this=0x9abd290,
track=..., albumMap=..., artistMap=...) at
../../src/collection/mediadevicecollection/handler/MediaDeviceHandler.cpp:737
#9  0xb70346da in Meta::MediaDeviceHandler::addMediaDeviceTrackToCollection
(this=0x9abd290, track=...) at
../../src/collection/mediadevicecollection/handler/MediaDeviceHandler.cpp:196
#10 0xb7035280 in Meta::MediaDeviceHandler::slotFinalizeTrackCopy
(this=0x9abd290, track=...) at
../../src/collection/mediadevicecollection/handler/MediaDeviceHandler.cpp:542
#11 0xb70356f7 in Meta::MediaDeviceHandler::slotCopyNextTrackDone
(this=0x9abd290, job=0xcc592e0, track=...) at
../../src/collection/mediadevicecollection/handler/MediaDeviceHandler.cpp:962
#12 0xb7038e3f in Meta::MediaDeviceHandler::qt_metacall (this=0x9abd290,
_c=QMetaObject::InvokeMetaMethod, _id=17, _a=0xbfec7898) at
./MediaDeviceHandler.moc:138
#13 0xaf10c16a in Meta::MtpHandler::qt_metacall (this=0x9abd290,
_c=QMetaObject::InvokeMetaMethod, _id=21, _a=0xbfec7898) at
moc_MtpHandler.cpp:64
#14 0xb6aa8303 in QMetaObject::activate(QObject*, int, int, void**) () from
/usr/lib/libQtCore.so.4
#15 0xb6aa8f42 in QMetaObject::activate(QObject*, QMetaObject const*, int,
void**) () from /usr/lib/libQtCore.so.4
#16 0xb702fc39 in Meta::CopyWorkerThread::copyTrackDone (this=0xcc592e0,
_t1=0xcc592e0, _t2=...) at ./MediaDeviceHandler.moc:270
#17 0xb702fc5c in Meta::CopyWorkerThread::slotDoneSuccess (this=0xcc592e0) at
../../src/collection/mediadevicecollection/handler/MediaDeviceHandler.cpp:1266
#18 0xb702ff54 in Meta::CopyWorkerThread::qt_metacall (this=0xcc592e0,
_c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfec79bc) at
./MediaDeviceHandler.moc:257
#19 0xb6aa8303 in QMetaObject::activate(QObject*, int, int, void**) () from
/usr/lib/libQtCore.so.4
#20 0xb6aa8f42 in QMetaObject::activate(QObject*, QMetaObject const*, int,
void**) () from /usr/lib/libQtCore.so.4
#21 0xb527c143 in ThreadWeaver::Job::done(ThreadWeaver::Job*) () from
/usr/lib/libthreadweaver.so.4
#22 0xb527c317 in ThreadWeaver::Job::qt_metacall(QMetaObject::Call, int,
void**) () from /usr/lib/libthreadweaver.so.4
#23 0xb702feea in Meta::CopyWorkerThread::qt_metacall (this=0xcc592e0,
_c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xa337e7f0) at
./MediaDeviceHandler.moc:250
#24 0xb6aa1b0b in QMetaCallEvent::placeMetaCall(QObject*) () from
/usr/lib/libQtCore.so.4
#25 0xb6aa35e0 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#26 0xb60d2a94 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from
/usr/lib/libQtGui.so.4
#27 0xb60dabee in QApplication::notify(QObject*, QEvent*) () from
/usr/lib/libQtGui.so.4
#28 0xb75430fd in KApplication::notify(QObject*, QEvent*) () from
/usr/lib/libkdeui.so.5
#29 0xb6a931eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from
/usr/lib/libQtCore.so.4
#30 0xb6a93e2e in QCoreApplicationPrivate::sendPostedEvents(QObject*, int,
QThreadData*) () from /usr/lib/libQtCore.so.4
#31 0xb6a9400d in QCoreApplication::sendPostedEvents(QObject*, int) () from
/usr/lib/libQtCore.so.4
#32 0xb6abe4cf in ?? () from /usr/lib/libQtCore.so.4
#33 0xb3b84e98 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#34 0xb3b88623 in ?? () from /lib/libglib-2.0.so.0
#35 0xb3b887a8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#36 0xb6abe041 in
QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
from /usr/lib/libQtCore.so.4
#37 0xb6172305 in ?? () from /usr/lib/libQtGui.so.4
#38 0xb6a9183a in
QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from
/usr/lib/libQtCore.so.4
#39 0xb6a91c82 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
from /usr/lib/libQtCore.so.4
#40 0xb6a940d9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#41 0xb60d2917 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#42 0x08051f9d in main (argc=1, argv=0xbfec8c04) at ../../src/main.cpp:225
Comment 8 Mark Kretschmann 2009-12-21 10:27:43 UTC
This might potentially have been fixed by this commit (in Git master), please
test, and reopen the report if the problem persists. Thanks.


commit acf150893523a4c1693abb2ccae32f91140cb01d
Author: Mark Kretschmann <kretschmann@kde.org>
Date:   Mon Dec 21 08:53:42 2009 +0100

   Fix many MTP crashes caused by dangling pointers.

   The main cause for many crashes in MtpHandler were dangling pointers to
   structures from LibMTP. Using the new QSharedPointer (from Qt 4.5) makes it
   easy to fix such issues elegantly and safely. Please consider using it in
   other places too. It's often worth the tiny overhead.

   Note: I'm not sure how many bug reports this affects. Probably several.
Comment 9 Myriam Schweingruber 2010-01-09 23:16:38 UTC
*** Bug 221969 has been marked as a duplicate of this bug. ***