Bug 203267 - Plasma crashed doing nothing
Summary: Plasma crashed doing nothing
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-10 07:21 UTC by Dolgov Roman
Modified: 2009-08-13 14:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dolgov Roman 2009-08-10 07:21:19 UTC
Version:            (using KDE 4.3.0)
Compiler:          g++ gcc
OS:                Linux
Installed from:    Ubuntu Packages

Приложение: Рабочее пространство Plasma (plasma), сигнал SIGABRT
[Current thread is 0 (LWP 3626)]

Thread 6 (Thread 0xa94afb90 (LWP 3627)):
#0  0xb8062430 in __kernel_vsyscall ()
#1  0xb524a0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb64062ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb65eb172 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#4  0xb7a1eac2 in ?? () from /usr/lib/libQtNetwork.so.4
#5  0xb65ea132 in ?? () from /usr/lib/libQtCore.so.4
#6  0xb52464ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb63f749e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xa8affb90 (LWP 3628)):
#0  0xb8062430 in __kernel_vsyscall ()
#1  0xb63ef7b1 in select () from /lib/tls/i686/cmov/libc.so.6
#2  0xb66bc780 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb65ea132 in ?? () from /usr/lib/libQtCore.so.4
#4  0xb52464ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb63f749e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xa8272b90 (LWP 3630)):
#0  0xb8062430 in __kernel_vsyscall ()
#1  0xb524a0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb64062ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb65eb172 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#4  0xa9624b9a in ?? () from /usr/lib/kde4/plasma_wallpaper_image.so
#5  0xb65ea132 in ?? () from /usr/lib/libQtCore.so.4
#6  0xb52464ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb63f749e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xa38f8b90 (LWP 15099)):
#0  0xb8062430 in __kernel_vsyscall ()
#1  0xb52498db in pthread_rwlock_wrlock () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb633827b in ?? () from /lib/tls/i686/cmov/libc.so.6
#3  0xb63383e8 in bindtextdomain () from /lib/tls/i686/cmov/libc.so.6
#4  0xb7511d09 in ?? () from /usr/lib/libkdecore.so.5
#5  0xb7511ed8 in ?? () from /usr/lib/libkdecore.so.5
#6  0xb75262e2 in ?? () from /usr/lib/libkdecore.so.5
#7  0xb7526e0a in KLocale::translateQt () from /usr/lib/libkdecore.so.5
#8  0xb779de60 in ?? () from /usr/lib/libkdeui.so.5
#9  0xb66fc291 in QTranslator::translate () from /usr/lib/libQtCore.so.4
#10 0xb66e227a in QCoreApplication::translate () from /usr/lib/libQtCore.so.4
#11 0xb66e26c6 in QCoreApplication::translate () from /usr/lib/libQtCore.so.4
#12 0xb66e56e2 in QMetaObject::tr () from /usr/lib/libQtCore.so.4
#13 0xb7a28d86 in ?? () from /usr/lib/libQtNetwork.so.4
#14 0xb7a1ebd3 in QHostInfo::fromName () from /usr/lib/libQtNetwork.so.4
#15 0xb7c42c4d in ?? () from /usr/lib/libkio.so.5
#16 0xb7c43b61 in ?? () from /usr/lib/libkio.so.5
#17 0xb65dfa24 in ?? () from /usr/lib/libQtCore.so.4
#18 0xb65ea132 in ?? () from /usr/lib/libQtCore.so.4
#19 0xb52464ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#20 0xb63f749e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa30dfb90 (LWP 15100)):
[KCrash Handler]
#6  0xb8062430 in __kernel_vsyscall ()
#7  0xb633e6d0 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb6340098 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb637c24d in ?? () from /lib/tls/i686/cmov/libc.so.6
#10 0xb6382604 in ?? () from /lib/tls/i686/cmov/libc.so.6
#11 0xb63855b6 in ?? () from /lib/tls/i686/cmov/libc.so.6
#12 0xb63869c5 in malloc () from /lib/tls/i686/cmov/libc.so.6
#13 0xb633bd99 in ?? () from /lib/tls/i686/cmov/libc.so.6
#14 0xb633bfa1 in ?? () from /lib/tls/i686/cmov/libc.so.6
#15 0xb6339f22 in ?? () from /lib/tls/i686/cmov/libc.so.6
#16 0xb6339701 in ?? () from /lib/tls/i686/cmov/libc.so.6
#17 0xb6338433 in dcgettext () from /lib/tls/i686/cmov/libc.so.6
#18 0xb751126b in ?? () from /usr/lib/libkdecore.so.5
#19 0xb7511ef7 in ?? () from /usr/lib/libkdecore.so.5
#20 0xb75262e2 in ?? () from /usr/lib/libkdecore.so.5
#21 0xb7526e0a in KLocale::translateQt () from /usr/lib/libkdecore.so.5
#22 0xb779de60 in ?? () from /usr/lib/libkdeui.so.5
#23 0xb66fc291 in QTranslator::translate () from /usr/lib/libQtCore.so.4
#24 0xb66e227a in QCoreApplication::translate () from /usr/lib/libQtCore.so.4
#25 0xb66e26c6 in QCoreApplication::translate () from /usr/lib/libQtCore.so.4
#26 0xb66e56e2 in QMetaObject::tr () from /usr/lib/libQtCore.so.4
#27 0xb7a28d86 in ?? () from /usr/lib/libQtNetwork.so.4
#28 0xb7a1ebd3 in QHostInfo::fromName () from /usr/lib/libQtNetwork.so.4
#29 0xb7c42c4d in ?? () from /usr/lib/libkio.so.5
#30 0xb7c43b61 in ?? () from /usr/lib/libkio.so.5
#31 0xb65dfa24 in ?? () from /usr/lib/libQtCore.so.4
#32 0xb65ea132 in ?? () from /usr/lib/libQtCore.so.4
#33 0xb52464ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#34 0xb63f749e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb4d37710 (LWP 3626)):
#0  0xb8062430 in __kernel_vsyscall ()
#1  0xb6406643 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0xb6387f5d in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
Comment 1 FiNeX 2009-08-10 15:08:58 UTC
Please, could you explain what you were doing before the crash and, if possible, how to reproduce it?

If the bug is reproducible, you could install debug enabled packages and provide a better backtrace following the instruction on this page:

http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports


many thanks
Comment 2 Dario Andres 2009-08-10 22:31:57 UTC
Mh, this should have been fixed already by fixes at bug 195692 / bug 191122.
- What is the version of your "kdelibs5-*" packages ?
Thanks
Comment 3 Dolgov Roman 2009-08-12 07:28:57 UTC
I do nothing. I come to work and see that (sorry for my english it's bad =( ).
Comment 4 Dario Andres 2009-08-12 20:24:05 UTC
- What is the version of your "kdelibs5-*" packages ?
Thanks
Comment 5 Dolgov Roman 2009-08-13 06:21:11 UTC
root@awork:/home/alter/tmp# dpkg -s kdelibs5

Package: kdelibs5                           
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 27316
Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
Architecture: i386
Source: kde4libs
Version: 4:4.2.2-0ubuntu5
Replaces: kio-bookmarks
Depends: libacl1 (>= 2.2.11-1), libattr1 (>= 2.4.41-1), libbz2-1.0, libc6 (>= 2.7), libcomerr2 (>= 1.01), libenchant1c2a (>= 1.4.2), libgcc1 (>= 1:4.1.1), libgif4 (>= 4.1.6), libice6 (>= 1:1.0.0), libilmbase6, libjasper1 (>= 1.900.1), libjpeg62, libkrb53 (>= 1.6.dfsg.2), libopenexr6 (>= 1.6.1), libpcre3 (>= 7.7), libphonon4 (>> 4:4.3.1), libpng12-0 (>= 1.2.13-4), libqt4-dbus (>= 4.5.0~+rc1), libqt4-designer (>= 4.5.0~+rc1), libqt4-network (>= 4.5.0~+rc1), libqt4-qt3support (>= 4.5.0~+rc1), libqt4-script (>= 4.5.0~+rc1), libqt4-svg (>= 4.5.0~+rc1), libqt4-xml (>= 4.5.0~+rc1), libqtcore4 (>= 4.5.0~+rc1), libqtgui4 (>= 4.5.0~+rc1), libsm6, libsoprano4 (>= 2.2.2), libssl0.9.8 (>= 0.9.8f-5), libstdc++6 (>= 4.2.1), libstreamanalyzer0 (>= 0.6.4), libstreams0 (>= 0.6.4), libx11-6, libxau6, libxcursor1 (>> 1.1.2), libxdmcp6, libxext6, libxfixes3 (>= 1:4.0.1), libxft2 (>> 2.1.1), libxml2 (>= 2.6.27), libxrender1, libxslt1.1 (>= 1.1.18), libxtst6, zlib1g (>= 1:1.2.3.3.dfsg), kdelibs5-data (>= 4:4.2.2-0ubuntu5), kdelibs-bin (>= 4:4.2.2-0ubuntu5), dbus-x11, shared-mime-info, xauth, launchpad-integration
Pre-Depends: dpkg (>= 1.14.12ubuntu3)
Recommends: ttf-dejavu
Conflicts: kformula, kio-bookmarks
Description: core libraries for all KDE 4 applications
 This package contains shared libraries needed to run KDE 4 applications.
 .
 This package is part of the KDE 4 libraries module.
Homepage: http://www.kde.org/
Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Comment 6 Dario Andres 2009-08-13 14:24:56 UTC
Yes, this is bug 191122, and it is fixed on KDE4.3. Thanks

*** This bug has been marked as a duplicate of bug 191122 ***