Bug 203116 - [Ati] Video tearing with Kwin desktop effects
Summary: [Ati] Video tearing with Kwin desktop effects
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: investigated, triaged
Depends on:
Blocks:
 
Reported: 2009-08-08 21:48 UTC by Manuel
Modified: 2018-10-27 03:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel 2009-08-08 21:48:24 UTC
Version:            (using KDE 4.3.0)
OS:                Linux
Installed from:    Ubuntu Packages

The big problem here is video tearing... its not the old tearing ati problem which just happened with compositing... its some kwin tearing problem... it just happens with kwin compositing on... I tested it with compiz and without any compositing... and there is no tearing. With tearing i mean something which breaks the screen in 2 slices overlapped... it happens in fast motion scenes...)

I tested it with VLC and SMplayer, driver Opengl2(Yuv) which worked very well for other tearing problems on ati cards... xv and X11 ones... and the problem remains. This looks like some vsync problems (just like other ati easy tearing issues...) with kwin's opengl vsync option on, nothing happens...

When I switch to compiz, all is fine, no compositing also works well.

Kde 4.3 ubuntu packages from ppa.
Catalyst Ati driver 9.7.
32 bit Ubuntu Jackalope
what else?

Its like the bug 193187 https://bugs.kde.org/show_bug.cgi?id=193187 but with an ati card.

Thanks.
Comment 1 Manuel 2009-08-08 21:49:47 UTC
Oh right... its an Ati HD3200 card.
Comment 2 Martin Flöser 2011-01-22 13:39:12 UTC
There are some vsync improvements in 4.6. Could you please try if that fixes it. Also nowadays there is the option to switch to the free radeon driver.
Comment 3 Andrew Crouthamel 2018-09-22 01:57:47 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Andrew Crouthamel 2018-10-27 03:58:51 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!