Bug 203074 - Unable to mount NFS volume via NFS shortcut on desktop
Summary: Unable to mount NFS volume via NFS shortcut on desktop
Status: RESOLVED DUPLICATE of bug 172023
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-08 14:24 UTC by Martin Samek
Modified: 2009-10-11 01:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Samek 2009-08-08 14:24:26 UTC
Version:            (using KDE 4.3.0)
Compiler:          gcc version 4.3.2 (Gentoo 4.3.2-r3 p1.6, pie-10.1.5) 
OS:                Linux
Installed from:    Gentoo Packages

When I try to mount a NFS volume via NFS shortcut, which I added at my desktop, I get this error:

Could not mount device.
The reported error was:
mount: only root can do this.

Of course my rights are ok. I can mount/umount this volume in the konsole as a user. Here is appropriate entry from my /etc/fstab:

192.168.1.1:/var/data/music/mnt/music      nfs     rsize=8192,wsize=8192,nolock,user,noauto        0 0
Comment 1 Martin Samek 2009-08-08 14:28:56 UTC
When is the NFS volume mounted manually and I try to unmount it via NFS shortcut. Then I get this error:

Could not unmount device.
The reported error was:
sh: /bin/umount/home/marsark/Desktop/NFS: is not directory

It is obvious that there is some bug in the path.
Comment 2 Dario Andres 2009-08-08 17:48:49 UTC
The unmount path bugs is related to KIO (I'm fixing it right now).
Comment 3 Dario Andres 2009-08-08 17:56:48 UTC
Mountpoint and desktopfile path switches bug, fixed at:
4.4 -> svn rev.1008897 , 4.3.x -> svn rev. 1008898
Comment 4 Dario Andres 2009-08-08 18:17:04 UTC
Unmount command + path being merged (missing space) bug, fixed at:
4.4 -> svn rev 1008901 , 4.3.x -> 1008904.
Comment 5 Dario Andres 2009-08-08 18:22:50 UTC
So, the two problems you described in comment 1 are already fixed.

Can you check this:
- Open Dolphin and browse to your Desktop folder (or where you NFS device link is), then try to mount it or unmount it. 
Confirm me that you are getting the same error (and therefore, this is not a Plasma bug, but a KIO one). 

BTW, this looks related to bug 172023

Thanks
Comment 6 Martin Samek 2009-08-08 23:01:30 UTC
Yes, I can confirm that. I get same error when mount/unmount NFS link from Dolphin. My NFS link is placed in ~/Desktop/ and the Desktop directory is set to be displayed in Folder view widget at my Plasma desktop.
Comment 7 Martin Samek 2009-08-08 23:33:54 UTC
I think, that problem with mounting of NFS or HDD (as in bug 172023) may be also caused by wrong path given to mount.
Comment 8 Dario Andres 2009-08-09 00:04:04 UTC
IIRC, the path given to mount is the proper one. The problem I fixed was related to the unmount() call.
Comment 9 Martin Samek 2009-09-04 10:49:16 UTC
Still remains in 4.3.1. No I am able to mount from konsole and umount by icon on desktop. So umount has been fixed, but mount still waiting to be fixed.
Any ideas?
Comment 10 Martin Samek 2009-10-07 15:26:24 UTC
Mount doesn't work in kde 4.3.2.
Comment 11 Dario Andres 2009-10-10 17:35:10 UTC
- Do you agree on merging this with bug 172023 ?
Regards
Comment 12 Martin Samek 2009-10-11 00:51:10 UTC
Yes, I agree. It seems to be same issue.
Comment 13 Dario Andres 2009-10-11 01:00:55 UTC
Thanks

*** This bug has been marked as a duplicate of bug 172023 ***