Bug 203042 - Option to display image count while browsing.
Summary: Option to display image count while browsing.
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist with 65 votes (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: usability
: 174618 241476 292590 298839 321398 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-08 05:47 UTC by Brand
Modified: 2018-04-25 07:25 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In: 18.08.0


Attachments
Proposed fix - View status bar (43.70 KB, image/png)
2018-04-13 00:54 UTC, Huon
Details
Proposed fix - View full screen (23.90 KB, image/png)
2018-04-13 00:55 UTC, Huon
Details
Proposed fix - View full screen (large document count) (15.17 KB, image/png)
2018-04-13 00:56 UTC, Huon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brand 2009-08-08 05:47:11 UTC
Version:            (using KDE 4.2.4)
OS:                Linux
Installed from:    Ubuntu Packages

The option to see what number image out of x number of images in the directory you are viewing would be useful. 

For example: Say there are 50 images in a directory, you are on the 25th. In the titlebar, sidebar, or tooltip on hovering over the background would show foo.png 25/50 or bar.tiff 25/th out of 50.
Comment 1 Aurelien Gateau 2009-09-01 09:08:14 UTC
I agree. Added to my TODO.
Comment 2 Jekyll Wu 2012-01-03 02:23:42 UTC
*** Bug 174618 has been marked as a duplicate of this bug. ***
Comment 3 Jekyll Wu 2012-01-03 03:25:19 UTC
*** Bug 241476 has been marked as a duplicate of this bug. ***
Comment 4 Jekyll Wu 2012-01-27 14:20:46 UTC
*** Bug 292590 has been marked as a duplicate of this bug. ***
Comment 5 Benni Hill 2013-04-12 13:03:21 UTC
*** Bug 298839 has been marked as a duplicate of this bug. ***
Comment 6 Frank Steinmetzger 2013-09-10 14:05:55 UTC
In light of the recent change that viewing now loops without option to turn it off,
Comment 7 Stephane Couturier 2017-06-11 13:31:04 UTC
Hi,

I would really enjoy this feature too.
Is there any plan/progress about it ?

It would be nice to have it on the usually main screen first, maybe later when in full screen as an option.


Thanks!
Comment 8 Nate Graham 2017-09-09 20:14:16 UTC
*** Bug 321398 has been marked as a duplicate of this bug. ***
Comment 9 Huon 2018-04-13 00:54:56 UTC
Created attachment 111988 [details]
Proposed fix - View status bar
Comment 10 Huon 2018-04-13 00:55:07 UTC
I've got a patch incoming for this, displaying e.g. "Document 8 of 64" in the status bar in View mode, and e.g. "8/64" to the right of the filename in Full Screen View mode.
Is there any benefit to putting it in the window title as well (in the 8/64 format)? I don't want to unnecessarily clutter the title.

I'm attaching some screenshots for feedback on the display/formatting.
Comment 11 Huon 2018-04-13 00:55:39 UTC
Created attachment 111989 [details]
Proposed fix - View full screen
Comment 12 Huon 2018-04-13 00:56:10 UTC
Created attachment 111990 [details]
Proposed fix - View full screen (large document count)
Comment 13 null 2018-04-13 11:18:36 UTC
Quick feedback:
- Image count in fullscreen looks great. Only the linebreaks for long filenames look a bit odd, we should not regress on that. Will need lots of testing, also with all of the configuration options this toolbar provides. One idea would be to anchor the filename top-left, and the counter bottom-right for the multi-line case.
- There are already lots of items in the window title, no need to add on top of that.
- It might also be worth thinking about Browse mode at the same time to provide a consistent experience (wording, content, positioning).

In View mode, there are some issues (which your screenshot does not show, because it does not show the full window and not the default window size ;)

See https://phabricator.kde.org/D8306 for some screenshots where it is very clear that there is absolutely no more space we can fit anything in. On the contrary, we might have to think about removing or rearranging things, to get the minimum window width down again. Next, a user interface, i.e. the status bar in our case, becomes less usable once we cram too many items in and the information and button density becomes too high.

I thought about displaying the image count somewhere else, e.g. in the toolbar, in the sidepanel or as an overlay. However, all of those options are not very appealing. What we could do here is to only display the label if there is enough space, i.e. based on the width of the label plus a (generous!) amount of whitespace on both sides. To improve grouping, I'd probably also prefer centering the label.

@Nate: Do you think we need "Document 1 of 2", or is "1 of 2" or "1/2" (which is what the old Gwenview showed) good enough? For example in Okular's page counter (which is a bit different, but relevant nevertheless) it says "1 of 2".

(Also, we might need to rethink the "Document" wording, because Okular is the document viewer which can view images too, but Gwenview is an image viewer which can view document-like images…)
Comment 14 Nate Graham 2018-04-13 13:58:06 UTC
The "1 of 15" style sounds good and should automatically cover all cases, as well as being consistent with Okular. I don'd like the use of the generic term "document" here. It seems less than applicable to Gwenview and its target audience.
Comment 15 Huon 2018-04-13 23:07:52 UTC
(In reply to Henrik Fehlauer from comment #13)
> Quick feedback:
> - Image count in fullscreen looks great. Only the linebreaks for long
> filenames look a bit odd, we should not regress on that.

Thanks for the feedback, I'll investigate that line break.

> Will need lots of testing, also with all of the configuration options this toolbar provides.

With the thumbnail bar turned off, the counter sticks to the far right, leaving lots of room for the filename. More important is the (default) mode as in the screenshots given it's a bit cramped.

> One idea would be to anchor the filename top-left, and the counter
> bottom-right for the multi-line case.
> - There are already lots of items in the window title, no need to add on top
> of that.

Might be tricky but I'll look into it.

> - It might also be worth thinking about Browse mode at the same time to
> provide a consistent experience (wording, content, positioning).

Also thought about this, but since we can multi-select, it might be confusing if we're still displaying "5 of 13" based on the current URL (in the context manager). Hence why I left it as is for now.

> In View mode, there are some issues (which your screenshot does not show,
> because it does not show the full window and not the default window size ;)
> 
> See https://phabricator.kde.org/D8306 for some screenshots where it is very
> clear that there is absolutely no more space we can fit anything in. On the
> contrary, we might have to think about removing or rearranging things, to
> get the minimum window width down again. Next, a user interface, i.e. the
> status bar in our case, becomes less usable once we cram too many items in
> and the information and button density becomes too high.
> 
> I thought about displaying the image count somewhere else, e.g. in the
> toolbar, in the sidepanel or as an overlay. However, all of those options
> are not very appealing. What we could do here is to only display the label
> if there is enough space, i.e. based on the width of the label plus a
> (generous!) amount of whitespace on both sides. To improve grouping, I'd
> probably also prefer centering the label.

Perhaps putting the zoom modes in the toolbar is the answer. They'd fit right in next to other buttons that affect the current image, like rotating.
If we moved the document count out of the status bar, we'd also need to move it for Browse mode. IMO the status bar is the best place for it, that's where users expect it to be (see: file managers).

> @Nate: Do you think we need "Document 1 of 2", or is "1 of 2" or "1/2"
> (which is what the old Gwenview showed) good enough? For example in Okular's
> page counter (which is a bit different, but relevant nevertheless) it says
> "1 of 2".

> (Also, we might need to rethink the "Document" wording, because Okular is
> the document viewer which can view images too, but Gwenview is an image
> viewer which can view document-like images…)

If we go with "1 of 50", and get rid of "document" (which I agree is confusing), what do we do in Browse? The wording needs to include images and videos, but not folders, archives, etc. "Items" is a bit too ambiguous. "Media items"?
Comment 16 Nate Graham 2018-04-13 23:09:22 UTC
(In reply to Huon from comment #15)
> If we go with "1 of 50", and get rid of "document" (which I agree is
> confusing), what do we do in Browse? The wording needs to include images and
> videos, but not folders, archives, etc. "Items" is a bit too ambiguous.
> "Media items"?
It this even needed in Browse mode?
Comment 17 Huon 2018-04-13 23:11:25 UTC
(In reply to Nate Graham from comment #16)
> (In reply to Huon from comment #15)
> > If we go with "1 of 50", and get rid of "document" (which I agree is
> > confusing), what do we do in Browse? The wording needs to include images and
> > videos, but not folders, archives, etc. "Items" is a bit too ambiguous.
> > "Media items"?
> It this even needed in Browse mode?

Browse mode already displays the total document count as "64 Documents". IMO we should definitely keep the total there.
Comment 18 null 2018-04-13 23:24:57 UTC
> putting the zoom modes in the toolbar
The zoom functions should be grouped together, and the zoom level slider in the bottom right is iconic for Gwenview and standard in most graphics apps. Thus, you'd have to present a very convincing new design which has massive improvements, before there will be agreement to such a change…

> If we go with "1 of 50", and get rid of "document"
> (which I agree is confusing), what do we do in Browse?
That's why I suggested to also think about Browse mode ;)

I could imagine something like "1 of 2 selected", or if nothing is selected perhaps "4 images | 2 videos", with the last part hidden if there are no videos? Adding both numbers only to have a total does not seem too useful. Or some combination thereof?

Dolphin has "2 folders, 3 files (4KiB)", which also provides value. Why not "files", and some size information?
Comment 19 Huon 2018-04-13 23:35:31 UTC
(In reply to Henrik Fehlauer from comment #18)
> > putting the zoom modes in the toolbar
> The zoom functions should be grouped together, and the zoom level slider in
> the bottom right is iconic for Gwenview and standard in most graphics apps.
> Thus, you'd have to present a very convincing new design which has massive
> improvements, before there will be agreement to such a change…

Good point about grouping all the zoom functions. I retract my idea :P

> > If we go with "1 of 50", and get rid of "document"
> > (which I agree is confusing), what do we do in Browse?
> That's why I suggested to also think about Browse mode ;)
> 
> I could imagine something like "1 of 2 selected", or if nothing is selected
> perhaps "4 images | 2 videos", with the last part hidden if there are no
> videos? Adding both numbers only to have a total does not seem too useful.
> Or some combination thereof?

> Dolphin has "2 folders, 3 files (4KiB)", which also provides value. Why not
> "files", and some size information?

"Files" is too broad I think, and it would be weird if Dolphin said "7 files" and Gwenview said "6 Files" because one was a zip file. Gwenview should make it clear it's only counting media files.

We could do something similar to Dolphin though: show "4 images, 2 videos" when nothing is selected. And display "2 of 6 selected (356KiB)" when one or more items are selected.
(Perhaps this would be best put in a different patch though.)
Comment 20 null 2018-04-13 23:41:51 UTC
> (Perhaps this would be best put in a different patch though.)
Sure, but it's good to have a plan before starting to implement wording changes.

One more thing to note is that by default there is always 1 image selected, so sadly the "nothing is selected" situation is quite uncommon.
Comment 21 null 2018-04-13 23:45:35 UTC
Hm, it's so obvious, isn't: We only show "selected" once the user selected more than one item. This way by default we show what's in the folder, and in the special situation of selecting multiple files we make this very clear with a totally different label.

Rest of your suggestion sounds good, BTW ;)
Comment 22 Huon 2018-04-13 23:55:49 UTC
(In reply to Henrik Fehlauer from comment #21)
> Hm, it's so obvious, isn't: We only show "selected" once the user selected
> more than one item. This way by default we show what's in the folder, and in
> the special situation of selecting multiple files we make this very clear
> with a totally different label.

Ah yes, that sounds good.

So, when 0 or 1 item selected:

2 images, 4 videos (2MiB)
2 images (574KiB), 4 videos (1.3MiB)

And when >1 selected:

2 of 4 selected (456KiB)
Selected 2 of 4 (456KiB)
Comment 23 null 2018-04-14 06:17:41 UTC
> 2 images, 4 videos (2MiB)
That's a bit ambigous…

> 2 images (574KiB), 4 videos (1.3MiB)
Including the size in this way might result in a string which is too long in some languages, and this is also on the heavier side of information density.

I'd try without size here in the first iteration, and only use size for the selection.

> 2 of 4 selected (456KiB)
> Selected 2 of 4 (456KiB)
I'd probably prefer the second variant for its emphasis on the selection, making it different to the "1 of 2" in View mode. For other languages it's different anyway.

---

One more thing: Don't forget about the light table ;)
Comment 24 Huon 2018-04-25 07:25:43 UTC
Git commit 14199f3bc2ed0ad20ecdbd0b8ea1aed704067465 by Huon Imberger.
Committed on 25/04/2018 at 07:25.
Pushed by huoni into branch 'master'.

Display document count labels in View, Browse, and Full Screen modes

Summary:
{nav Browse} mode: The existing total count is now split into images
and videos, e.g. "5 images, 3 videos". When 2 or more documents (that
is, images or videos) are selected, the label changes to display how
many are selected and their total size. E.g. "4 of 10 selected (3.4
MiB).

{nav View} mode: A new label in the status bar, showing the current
document index, and total in the folder, e.g. "32 of 753". This label is
hidden in Lighttable mode, and elided if there's no room for it.

{nav Full Screen} mode: Similar to {nav View}, the current index and
total count is displayed. This is in the format "32 of 753", and is
anchored to the bottom right of the information panel.

Each mode calculates these values independently. This is because for
{nav View} and {nav Full Screen}, the thumbnail bar model has already
filtered out any item that isn't viewable, therefore it's easy to simply
get the current index and total items. In {nav Browse}, folders and
archives are displayed, so there needs to be extra logic that filters
them out appropriately.
FIXED-IN: 18.08.0

Browse:
{F5811297}

Browse (with selection):
{F5811298}

View:
{F5811299}

View (compare):
{F5811300}

Full Screen:
{F5814068}

Full Screen (large thumbnails):
{F5814069}

Full Screen (thumbnail bar disabled):
{F5814071}

Test Plan:
Browse:
  - Only images and videos should be counted (directories and archives
  ignored).
  - Label should change to "Selected..." when 2 or more images/videos
  selected

View:
  - Count/index should match the thumbnail view, i.e., only items in the
  thumbnail bar should be counted.
  - Changes to documents should be reflected in the index and total:
    - Renaming causing a change in sort order
    - Adding/deleting documents
  - Document count label should be hidden in Compare/Lighttable mode to
  allow room for the Synchronize checkbox

Full Screen View:
  - Same as View above, plus;
  - Enable/disable the thumbnail bar
  - Enable and resize the thumbnail bar
  - View images with long filesnames, and/or addition meta info enabled
  - In Compare/Lighttable mode, current document index should reflect the
  currently selected image

Reviewers: #gwenview, rkflx

Reviewed By: #gwenview, rkflx

Subscribers: rkflx, muhlenpfordt

Tags: #gwenview

Differential Revision: https://phabricator.kde.org/D12301

M  +90   -26   app/browsemainpage.cpp
M  +2    -0    app/browsemainpage.h
M  +4    -7    app/browsemainpage.ui
M  +53   -15   app/fullscreencontent.cpp
M  +4    -1    app/fullscreencontent.h
M  +34   -0    app/viewmainpage.cpp
M  +2    -0    app/viewmainpage.h

https://commits.kde.org/gwenview/14199f3bc2ed0ad20ecdbd0b8ea1aed704067465