Bug 202309 - keeps polling all fs in /etc/fstab
Summary: keeps polling all fs in /etc/fstab
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdeinit (show other bugs)
Version: 4.2
Platform: Debian testing Linux
: NOR normal
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-02 16:34 UTC by Jan De Luyck
Modified: 2018-11-18 09:36 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan De Luyck 2009-08-02 16:34:37 UTC
Version:            (using KDE 4.2.96)
OS:                Linux
Installed from:    Debian testing/unstable Packages

When starting KDE4, the panel & desktop take ages to show up (upwards from 20+ minutes).

I've attached strace to the "kdeinit4: plasma-desktop" process, which seems to be doing continuous loops of:

---------------------------------------------------------
writev(12, [{"l\1\0\1\31\0\0\0\264\2\0\0\267\0\0\0\1\1o\0E\0\0\0/org/fre"..., 200}, {"\24\0\0\0storage.hotpluggable\0", 25}], 2) = 225
poll([{fd=12, events=POLLIN}], 1, 25000) = 1 ([{fd=12, revents=POLLIN}])
read(12, "l\2\1\1\4\0\0\0L\6\0\0-\0\0\0\6\1s\0\5\0\0\0:1.22\0\0\0"..., 2048) = 68
read(12, 0x1ff9720, 2048)               = -1 EAGAIN (Resource temporarily unavailable)
writev(12, [{"l\1\0\1\20\0\0\0\265\2\0\0\277\0\0\0\1\1o\0L\0\0\0/org/fre"..., 208}, {"\v\0\0\0volume.disc\0", 16}], 2) = 224
poll([{fd=12, events=POLLIN}], 1, 25000) = 1 ([{fd=12, revents=POLLIN}])
read(12, "l\2\1\1\4\0\0\0M\6\0\0-\0\0\0\6\1s\0\5\0\0\0:1.22\0\0\0"..., 2048) = 68
read(12, 0x1ff9720, 2048)               = -1 EAGAIN (Resource temporarily unavailable)
writev(12, [{"l\1\0\1\30\0\0\0\266\2\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\23\0\0\0org.freedesktop.Hal\0", 24}], 2) = 168
poll([{fd=12, events=POLLIN}], 1, 25000) = 1 ([{fd=12, revents=POLLIN}])
read(12, "l\2\1\1\t\0\0\0009\1\0\0=\0\0\0\6\1s\0\5\0\0\0:1.22\0\0\0"..., 2048) = 89
read(12, 0x1ff9720, 2048)               = -1 EAGAIN (Resource temporarily unavailable)
writev(12, [{"l\1\0\1\30\0\0\0\267\2\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\23\0\0\0org.freedesktop.Hal\0", 24}], 2) = 168
poll([{fd=12, events=POLLIN}], 1, 25000) = 1 ([{fd=12, revents=POLLIN}])
read(12, "l\2\1\1\t\0\0\0:\1\0\0=\0\0\0\6\1s\0\5\0\0\0:1.22\0\0\0"..., 2048) = 89
read(12, 0x1ff9720, 2048)               = -1 EAGAIN (Resource temporarily unavailable)
writev(12, [{"l\1\0\1\30\0\0\0\270\2\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\23\0\0\0org.freedesktop.Hal\0", 24}], 2) = 168
poll([{fd=12, events=POLLIN}], 1, 25000) = 1 ([{fd=12, revents=POLLIN}])
read(12, "l\2\1\1\t\0\0\0;\1\0\0=\0\0\0\6\1s\0\5\0\0\0:1.22\0\0\0"..., 2048) = 89
read(12, 0x1ff9720, 2048)               = -1 EAGAIN (Resource temporarily unavailable)
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1067, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1067, ...}) = 0
open("/etc/fstab", O_RDONLY)            = 13
fstat(13, {st_mode=S_IFREG|0644, st_size=1960, ...}) = 0
fcntl(13, F_SETFD, FD_CLOEXEC)          = 0
stat("/etc/fstab", {st_mode=S_IFREG|0644, st_size=1960, ...}) = 0
stat("/etc/fstab", {st_mode=S_IFREG|0644, st_size=1960, ...}) = 0
fstat(13, {st_mode=S_IFREG|0644, st_size=1960, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f8113d00000
read(13, "# /etc/fstab: static file system"..., 4096) = 1960
read(13, "", 4096)                      = 0
lstat("proc", 0x7fffef9e4430)           = -1 ENOENT (No such file or directory)
lstat("/proc", {st_mode=S_IFDIR|0555, st_size=0, ...}) = 0
lstat("usbfs", 0x7fffef9e4430)          = -1 ENOENT (No such file or directory)
lstat("/proc/bus/usb", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
lstat("/dev/md0", {st_mode=S_IFBLK|0660, st_rdev=makedev(9, 0), ...}) = 0
lstat("/boot", {st_mode=S_IFDIR|0755, st_size=1024, ...}) = 0
lstat("/dev/md1", {st_mode=S_IFBLK|0660, st_rdev=makedev(9, 1), ...}) = 0
lstat("/", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/dev/vg/usr", {st_mode=S_IFLNK|0777, st_size=18, ...}) = 0
readlink("/dev/vg/usr", "/dev/mapper/vg-usr"..., 4096) = 18
stat("/dev/vg/usr", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 2), ...}) = 0
lstat("/dev/mapper/vg-usr", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 2), ...}) = 0
lstat("/usr", {st_mode=S_IFDIR|0755, st_size=143, ...}) = 0
lstat("/dev/vg/tmp", {st_mode=S_IFLNK|0777, st_size=18, ...}) = 0
readlink("/dev/vg/tmp", "/dev/mapper/vg-tmp", 4096) = 18
stat("/dev/vg/tmp", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 0), ...}) = 0
lstat("/dev/mapper/vg-tmp", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 0), ...}) = 0
lstat("/tmp", {st_mode=S_IFDIR|S_ISVTX|0777, st_size=4096, ...}) = 0
lstat("/dev/vg/data", {st_mode=S_IFLNK|0777, st_size=19, ...}) = 0
readlink("/dev/vg/data", "/dev/mapper/vg-data"..., 4096) = 19
stat("/dev/vg/data", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 1), ...}) = 0
lstat("/dev/mapper/vg-data", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 1), ...}) = 0
lstat("/mnt/data", {st_mode=S_IFDIR|0755, st_size=120, ...}) = 0
lstat("/dev/vg/var", {st_mode=S_IFLNK|0777, st_size=18, ...}) = 0
readlink("/dev/vg/var", "/dev/mapper/vg-var"..., 4096) = 18
stat("/dev/vg/var", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 4), ...}) = 0
lstat("/dev/mapper/vg-var", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 4), ...}) = 0
lstat("/var", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/dev/vg/home", {st_mode=S_IFLNK|0777, st_size=19, ...}) = 0
readlink("/dev/vg/home", "/dev/mapper/vg-home", 4096) = 19
stat("/dev/vg/home", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 3), ...}) = 0
lstat("/dev/mapper/vg-home", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 3), ...}) = 0
lstat("/home", {st_mode=S_IFDIR|0755, st_size=61, ...}) = 0
lstat("/dev/sdc1", {st_mode=S_IFBLK|0660, st_rdev=makedev(8, 33), ...}) = 0
lstat("/mnt/dump2", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/dev/sdb2", {st_mode=S_IFBLK|0660, st_rdev=makedev(8, 18), ...}) = 0
lstat("none", 0x7fffef9e4430)           = -1 ENOENT (No such file or directory)
lstat("/dev/sdd2", {st_mode=S_IFBLK|0660, st_rdev=makedev(8, 50), ...}) = 0
lstat("none", 0x7fffef9e4430)           = -1 ENOENT (No such file or directory)
lstat("/dev/scd0", {st_mode=S_IFLNK|0777, st_size=3, ...}) = 0
readlink("/dev/scd0", "sr0"..., 4096)   = 3
stat("/dev/scd0", {st_mode=S_IFBLK|0660, st_rdev=makedev(11, 0), ...}) = 0
lstat("/dev/sr0", {st_mode=S_IFBLK|0660, st_rdev=makedev(11, 0), ...}) = 0
lstat("/mnt/cdrom", {st_mode=S_IFLNK|0777, st_size=23, ...}) = 0
readlink("/mnt/cdrom", "/etc/autofs/cdrom/cdrom", 4096) = 23
stat("/mnt/cdrom", 0x2016418)           = -1 ENOENT (No such file or directory)
lstat("/etc/autofs/cdrom/cdrom", 0x7fffef9e4430) = -1 ENOENT (No such file or directory)
lstat("/dev/scd1", {st_mode=S_IFLNK|0777, st_size=3, ...}) = 0
readlink("/dev/scd1", "sr1"..., 4096)   = 3
stat("/dev/scd1", {st_mode=S_IFBLK|0660, st_rdev=makedev(11, 1), ...}) = 0
lstat("/dev/sr1", {st_mode=S_IFBLK|0660, st_rdev=makedev(11, 1), ...}) = 0
lstat("/mnt/cdrom", {st_mode=S_IFLNK|0777, st_size=23, ...}) = 0
readlink("/mnt/cdrom", "/etc/autofs/cdrom/cdrom", 4096) = 23
stat("/mnt/cdrom", 0x2016648)           = -1 ENOENT (No such file or directory)
lstat("/etc/autofs/cdrom/cdrom", 0x7fffef9e4430) = -1 ENOENT (No such file or directory)
lstat("/dev/fd0", {st_mode=S_IFBLK|0660, st_rdev=makedev(2, 0), ...}) = 0
lstat("/mnt/floppy", {st_mode=S_IFDIR|0755, st_size=6, ...}) = 0
lstat("/dev/disk/by-id/usb-Apple_iPod-0:0-part3", 0x7fffef9e4430) = -1 ENOENT (No such file or directory)
lstat("/mnt/ipod", {st_mode=S_IFDIR|0755, st_size=6, ...}) = 0
lstat("/dev/sde1", 0x7fffef9e4430)      = -1 ENOENT (No such file or directory)
lstat("/mnt/sde", {st_mode=S_IFDIR|0755, st_size=6, ...}) = 0
lstat("/dev/sdf1", 0x7fffef9e4430)      = -1 ENOENT (No such file or directory)
lstat("/mnt/sdf", {st_mode=S_IFDIR|0755, st_size=6, ...}) = 0
stat("/etc/fstab", {st_mode=S_IFREG|0644, st_size=1960, ...}) = 0
close(13)                               = 0
munmap(0x7f8113d00000, 4096)            = 0
......
---------------------------------------------------------

making the system unusable, since it's 1. dead slow and 2. no desktop, no panel.
Comment 1 Romain 2009-10-27 17:39:42 UTC
Add an unresponsive SMB share to the mix and you got the perfect recipe for a systemwide clusterfcsk of unresponsive plasma (<= frozen plasma ?).
Comment 2 Romain 2010-01-06 13:32:36 UTC
This is probably a duplicate of this bug: 184062
Comment 3 Romain 2010-12-06 11:40:28 UTC
Problem still exists in KDE 4.5.3... A messed-up CIFS share and half of my desktop apps are stuck.
Comment 4 Romain 2011-07-18 16:38:00 UTC
Still there in KDE 4.6.4. At least I know when one of my NFS shares drops...
Comment 5 Andrew Crouthamel 2018-11-06 15:09:14 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Andrew Crouthamel 2018-11-17 04:55:22 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? This bug will be moved back to REPORTED Status for manual review later, which may take a while. If you are able to, please lend us a hand.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Jan De Luyck 2018-11-18 09:36:15 UTC
I haven't seen this behaviour in KDE5 (on Fedora), so for me this bug can be closed.